• Online: 6.950

Scotty18- Blog

Andy´s Blog- Codierungen, Umbauten und vieles mehr

11.04.2012 09:40    |    Scotty18    |    Kommentare (283)    |   Stichworte: 4G RFK, A6, A7, A8, Nachrüstung, Rückfahrkamera, Rückfahrkamera A5 A4

 Nachrüstung einer Rückfahrkamera (org. Audi) am A4 A5 A7 A6 A8

 

Hier ein kurzer Überblick über eine Nachrüstung einer Rückfahrkamera am A4 A5 A7 , die Nachrüstung ist

bei allen beschriebenen Modellen nahezu gleich :

 

Das APS Advance (Audi Bezeichnung)

• Weitwinklige Darstellung des rückwärtigen Bereiches im MMI durch eine in die Griffleiste

integrierte Kamera.

• Wesentlich vereinfachte Orientierung durch in das Videobild eingeblendete Hilfslinen und -felder

welche sich entsprechend des Lenkwinkels verändern.

• Es stehen zwei Parkmodi zur Verfügung - Lenksparken, Querparken

• Alle serienmäßigen Funktionen bleiben vollständig erhalten.

 

 

was wird benötigt:

Kamera

Steuergerät

Leitungssatz

- codieren&freischalten

 

 

was ist vorraussettzung für eine RFK :

 

MMi2G (hier muss zusätzlich ;falls nicht ab werk ein TV Tuner vorhanden ist, dass Displayinterface getauscht werden) kosten ~200-400€ gebraucht .

MMi 3G

MMi 3G plus

MMi 4G (nur A6 A7)

 

- das ganze geht auch OHNE Vorhandene PDC Sensoren ! 

 

 

 

Die Nachrüstung ist unter oben genannten Bedingungen bei allen A4 8K / A5 / A6 4G / A7 / A8 möglich .

 

Ich habe die komplettsets (Steuergerät/Kamera/Leitungssatz) bei Kufatec bestellt . Kostenpunkt ~600€ 

 

 

Der Einbau ist mit etwas Zeit und Aufwand verbunden, grober Ablauf:

 

Das Steuergerät wird im Kofferraum Rechts verbaut, hierzu muss Dauerplus und Masse aufgelegt werden, zudem beim A4 A5 eine Canbus Leitung nach vorne zum Beifahrer Can-Bus Verteiler gezogen werden.

Beim A6 A7 A8 befindet sich dieser Verteiler im Kofferraum.

 

Desweiteren muss eine  Videoleitung nach vorne zum MMi - Rechner (Mittelkonosle) gezogen werden- Dazu muss das Handschuhfach demontiert werden.

 

 

Die Kamera wird wie org. in der Griffleiste integriert -. Die Leitungen müssen hierzu am org. Kabelstrang bis in den Kofferraum gelegt werden.

 

 

Nach erfolgter Montage muss das ganze Codiert werden :

 

Codierung

 

• Adresse 19 - Diagnoseinterface - in der Verbauliste die RFK Funktion hinzufügen Adr. 6C

 

• Adresse 6C (A4 8K) - 1020006 (APS+, ohne AHK)

1030006 (APS+, mit AHK)

1000006 (ohne APS+, ohne AHK)

1010006 (ohne APS+, mit AHK)

 

• Adresse 6C (A5 8T) - 1020008 (APS+, ohne AHK)

1030008 (APS+, mit AHK)

1000008 (ohne APS+, ohne AHK)

1010008 (ohne APS+, mit AHK)

 

• Adresse 6C (A5 8F) - 1020009 (APS+, ohne AHK)

1030009 (APS+, mit AHK)

1000009 (ohne APS+, ohne AHK)

1010009 (ohne APS+, mit AHK)

 

• Adresse 10 (HINWEIS: Nur für Fahrzeuge wo Adresse 10 existiert)

Byte 00 - Bit 5

 

• Adresse 5F

Byte 07 - Bit 1

 

 

Abschließend ist ein MMI Reset durchzuführen!

Damit die Hilfslinien im MMi RFK Screen aktiv werden- MUSS der can-bus resetet werden (can-bus verteilerstecker abziehen)

 

Nach erfolgreicher Montage und Codierung sollte nun das Bild der Rückfahrkamera im MMi erscheinen! 

 

- Die bilder in der Galarie zeigen einen kleinen Überblick über die Montagearbeiten

 

Zeitauwand ~ 2-3std.  

 

 

 

Ich habe die RFK bisher mehrfach an folgenden Modellen nachgerüstet :

A4 (limo&avant)

A5 (coupe/cabrio/sportback)

A7 

A6 4G

 

Auf Anfrage ist dies bei mir vor Ort mögilch.

 

 

bei Fragen einfach PN an mich

 

 

 

Gruss

Andy


06.05.2013 01:19    |    tonl

Hi everybody

 

I hope somebody can help me with coding of the rear camera.

The rear camera with harness are from Kufatec

 

My car is A6 (4G) have parking sensor at front and rear (APS+). mmi radio plus.

Tools to coding the system is from ross-tech, VCDS version 11.11.5.

 

I tried to coding the system according the instruction from kufatec, but it seems that i have done something wrong since the camera not working. See attachment.



06.05.2013 08:16    |    Scotty18

do you have a black monitor with R-gear ?


06.05.2013 10:31    |    tonl

no black screen/monitor. it just show APS+.


Bild

17.05.2013 10:52    |    Trackback

Kommentiert auf: Audi Q5 & SQ5:

 

Rückfahrkamera nachrüsten

 

[...] du brauchst

Kamera in der Griffleiste

Steuergerät

Halter + Schrauben

Kabelsatz

codieren und einbauen

 

http://www.motor-talk.de/.../...era-am-a4-a5-a7-a6-4g-a8-t3836288.html

[...]

 

Artikel lesen ...


27.05.2013 20:37    |    Trackback

Kommentiert auf: Audi A5, S5 & RS5:

 

Rückfahrkamera nachrüsten?

 

[...] http://www.motor-talk.de/.../...era-am-a4-a5-a7-a6-4g-a8-t3836288.html

 

siehe bei mir im blog

[...]

 

Artikel lesen ...


04.06.2013 09:36    |    gatohidraulico

Hallo Scotty18,

Hallo alle zusammen,

 

ich habe auch die Rückfahrkamera von Kufatec nachgerüstet aber leider funkioniert sie noch nicht. Die Teilenummern sind: Strg: 8T0907441C, Kamera: 5N0827566AA, Kabelsatz: Kufatec

 

Mein Auto ist ein A4 8K Limousine MJ2010 mit Navigation MMi 3G und mit PDC (vorne und hinten) ab Werk. Ich habe keine AHK.

 

Nach dem Einbau, wenn ich nun den Rückswärtsgang einlege, schaltet das Display auf die Kameranzeige, die bleibt jedoch schwarz (trotzdem sieht man links das kleine Auto mit der Einparkhilfe) und im Eck gibt es die Auswahl (längs oder quer). 3-4 Sekunden später schaltet das PDC Display aus, wieder zum Radio, Car, Navigation, etc. Der PDC-Knopf bleibt beleuchtet und ich muss ihn manuell ausschalten. Wenn ich nochmals das schwarze Bild sehen will, muss ich den Motor ausmachen und noch einmail anmachen.

 

Alle Stecker sind im Prinzip sind OK. CAN 14 (Low und High) war bereits belegt also ich habe CAN 19 (Low und High) benutzt. Ich habe später auch mit dem letzten CAN versucht, CAN 23 (Low und High) aber auch ohne Erfolg.

 

Beim MMi 3G habe ich die Stecker auf PINs 11 und 5 richtig angeschlossen (blauer Stecker im MMi 3G) und die Kamera sollte auf Steuergerät im Kofferraum (siehe Bild 1) auch richtig angeschlossen sein.

 

Dauerplus habe ich in Sicherungsträger im Kofferraum angeschlossen (siehe Bild 2). Ist das OK? Wo soll ich sonst anschließen? Die Masse habe ich einfach mit der Karroserie verbindet.

 

Die Codierung habe ich mit meinem VCDS genau wie in der Anleitung durchgefürt. Ich habe Adresse 19, 6C, 10 und 5F problemlos codiert. Ich habe auf den zweiten Schritt Adresse 6C "APS+ ohne AHK" ausgewählt, das heißt "1020006". Das ist auch richtig, oder? (ich habe PDC vorne und hinten). Ich habe sogar mit "1000006" versucht, aber ohne Erfolg.

 

Schließlich habe ich natürlich ein MMi-Reset durchgeführt aber gibt es noch kein Bild aus die Kamera, nur 3-4 Sekunden das schwarze Bild und leider nicht mehr. VCDS-Scan sagt: "Fehler: Kamera nicht kalibriert" aber ich glaube, dass es kein Problem ist.

 

Ich bitte um Hilfe!!

 

PS. Sorry wegen meines Deutsches, ich komme aus Spanien ;)



04.06.2013 11:30    |    Scotty18

Fehlerspeicher auslesen

sieht nach einer Unterbrechung der Videoleitung MMi <---> Stg aus


04.06.2013 12:14    |    gatohidraulico

Anbei findest du mein Fehlerspeicher (log).

 

Plotzlich gibt es viele Fehler (Motor, Bremsen, etc.). :confused:

 

Vielleicht gabt es eine Unterbrechung?

 

Grüße



04.06.2013 12:16    |    Scotty18

Can Bus verteiler abgezogen und dann Zündung ein ;)

in dem Scan sehe ich aber keine Fehler!

 

wurde das stg 5F richtig codiert ?

Stg 10 PDC auf RFK gesetzt?


04.06.2013 13:43    |    gatohidraulico

Vor allem VIELEN DANK für deine höfliche Hilfe!

 

Zitat:

Can Bus verteiler abgezogen und dann Zündung ein

Was meinst du genau? Soll ich die rosafarbene Hebel betätigen, das gelbe Gehäuse abziehen und dann Zündung ein?

 

Übrigens, ich erinnere mich, dass ich die andere rosafarbene Verriegelung, die unten ist (siehe Bild) nach rechts betätigt habe. Dannach erinnere mich nicht, ob ich sie wieder nach links betätigt habe. Kann das etwas zu tun haben, oder ist nur eine mechanische Verriegelung?

 

Zitat:

in dem Scan sehe ich aber keine Fehler!

Doch, ganz oben steht es:

 

01-Engine -- Status: Malfunction 0010

03-ABS Brakes -- Status: Malfunction 0010

04-Steering Angle -- Status: OK 0000

05-Acc/Start Auth. -- Status: Malfunction 0010

08-Auto HVAC -- Status: Malfunction 0010

09-Cent. Elect. -- Status: Malfunction 1010

...

 

Zitat:

wurde das stg 5F richtig codiert ?

Stg 10 PDC auf RFK gesetzt?

Im Prinzip ja...

Adresse 5F: Byte 07 - Bit 1 auf 1

Adresse 10: Byte 00 - Bit 5 auf 1

und bei der Adresse 6C: 1020006


Bild

05.06.2013 17:12    |    gatohidraulico

Zitat:

Can Bus verteiler abgezogen und dann Zündung ein

Das funktioniert leider nicht.

 

Anschluss an CAN ist OK, sowie auch an MMi 3G (blauer Stecker) OK.

 

Dauerplus und Masse... kann da etwas falsch angeschloßen sein?

 

Anschluss an Steuergerät?

 

Wenn ich die Adresse 6C codiert habe, habe ich 1020006. Bei meinem VCDS gibt es Information über die Bedeutung von jeder Nummer. Unten steht etwas wie Werkstatt, Manufacturer...

Die andere Codierungen sind OK.

 

:confused:


05.06.2013 17:15    |    Scotty18

legales VCDS?

oder china clone oder gecrackte Version?

 

im Stg 10 unter Anpassung mal auf OPTISCHE Anzeige bzw. RFK codiert?


05.06.2013 17:22    |    gatohidraulico

Kein legales VCDS, glaube ich...

 

Ja, im Stg 10 (oder 5F, bin ich nicht sicher), gibt es diese Zwei Moglichkeiten, wenn ich mich richtig erinnere:

- Back-up camera

- Optical display

 

Optical display war schon aktiviert, da ich APS+ habe. Dann muss ich Back-up camera aktiviert (auf 1 setzen). Das mache ich, aber...


10.06.2013 20:45    |    gatohidraulico

Zum Glück klappt es schon.

 

Ich habe die Anschlüsse nochmals überprüft und jetzt funktioniert die RFK.

 

Ich vermute, etwas war los... keine Ahnung.

 

MfG


10.06.2013 20:45    |    gatohidraulico

Zum Glück klappt es schon.

 

Ich habe die Anschlüsse nochmals überprüft und jetzt funktioniert die RFK.

 

Ich vermute, etwas war los... keine Ahnung.

 

MfG


12.06.2013 10:37    |    gatohidraulico

Hallo,

 

kurze Frage!

 

Soll ich im Dauerplus (Sicherungsträger im Kofferraum) eine Sicherung einstecken?

 

Falls ja, wie viele Ampere?

 

Danke


13.06.2013 09:21    |    gatohidraulico

keine Ahnung?


13.06.2013 09:24    |    Scotty18

ja ohne Sicherung liegt wohl keine Spannung an!

5A reichen


24.06.2013 06:41    |    Berndix01

Guten Morgen,

 

ich habe die RFK von Audi eingebaut. Gestern gem. Anleitung codiert. Leider blieb der Bildschirm schwarz.. Links war das PDC+ zu sehen. Heute morgen dann das Bild im Anhang.

Kann es sein, dass ich beim Verlängern der Stromkabel für die Kamera die Polarität vertauscht habe? rot+ und schwarz Masse. MMi Reset durchgeführt. keine änderung. Canbus Reset nicht gemacht, da ich nicht weiß welcher Stecker abgezogen werden muß und wo dann dieser sitzt. (A6 4F Avant MMI 2G).

Alle Kabel sind durchgemessen und sind i.O.

Hat jemand eine Idee?

Lg

Bernd


Bild

24.06.2013 06:44    |    Scotty18

das sieht eher nach einer defekten Videoquelle oder signal aus

Kabel und Stg überprüfen!

sowie die Verbindung zum Interface


24.06.2013 06:56    |    Berndix01

War halt interessant, dass ich gestern gar kein Bild hatte und heute dieses. Die Kamera war neu. Kann ich sie testen mit einem Fernseher?


02.07.2013 16:38    |    Trackback

Kommentiert auf: Audi A4 8K:

 

Rückfahrkamera anschliessen MMI 2g

 

[...] meinst Du etwas sowas

[...]

 

Artikel lesen ...


03.07.2013 07:54    |    Trackback

Kommentiert auf: Audi A5, S5 & RS5:

 

PDC Steuergerät

 

[...] müsste nach richtiger codierung auch noch was anderes im Fehlerspeicher auftauchen

 

sonst siehe hier :

http://www.motor-talk.de/.../...era-am-a4-a5-a7-a6-4g-a8-t3836288.html

 

Gruss Andy

[...]

 

Artikel lesen ...


03.07.2013 08:10    |    Berndix01

Steuergerät 07

Anpassungskanal 01

bestehender Wert +32768

 

glaube das muß noch gemacht werden.

 

Gruss Bernd


18.10.2013 10:04    |    berbs

Hallo Scotty,

 

will bei meinem A6F Avant Kamera und El. Heckklappe nachr�sten.

 

Wohin gehen die Can Bus Leitungen?

Kannst Du mir weiterhelfen, haenge gerade am Auto..

ElHe geht lt Formum wohl parallel (da wohl belegt) an T32D 17 und T32D 1 - richtig?

R�ka geht in Steuergeraet J772 - soweit gut

ABER wohin gehen T54b/39 und T54b/40 von Steuerger�t J772 ?

Lt. Schaltplan auf B406 und B397, aber wo sind die?

 

Du schreibst, CAn-Bus liegt hinten - muss ich ebenfalls an T32d ?

Wenn ja an welche Steckplaetze?

 

Vorab Danke

 

Gruss

 

Martin


18.10.2013 18:10    |    Scotty18

der Can Bus ist vorne - am Gateway- dort parallel auflegen

 

gruss

Andy


19.10.2013 01:49    |    berbs

Danke !

 

Darf man eigentlich an eine bestehende CAn Bus Leitung einen zweite Can Bus anlöten ?

Oder fahren alle nur und ausschließlich im Bus mit ?


19.10.2013 07:24    |    Scotty18

ja kannst du. Can Bus läuft immer parallel !


10.11.2013 20:28    |    Trackback

Kommentiert auf: Audi A5, S5 & RS5:

 

Rückfahrkamera

 

[...] siehe

http://www.kufatec.de/.../aps-advance-rckfahrkamera-audi-a5-8t-mmi-3g

 

geht auch etwas günstiger mit gebrauchten teile.einbau ca 2-3 stunden.

 

http://www.motor-talk.de/.../...era-am-a4-a5-a7-a6-4g-a8-t3836288.html

[...]

 

Artikel lesen ...


12.11.2013 11:40    |    Trackback

Kommentiert auf: Audi A5, S5 & RS5:

 

Nummernschild Rückfahrkamera an MMI 3G...welchen Adapter brauche ich??

 

[...] es wenn org und gescheit nach zumal hier auch die Qualität deutlich besser ist als die "china Ware"

http://www.motor-talk.de/.../...era-am-a4-a5-a7-a6-4g-a8-t3836288.html

 

für 90€ kannst du eh nichts erwarten

[...]

 

Artikel lesen ...


19.11.2013 22:19    |    da77su

Hallo zusammen

Meine RFK von Kufatec ist im Q5 richtig eingebaut worden. Bevor die RFK codiert wurde hat mein Audipartner einen SoftwareUpdate laufen lassen. Zuvor hatte ich einen dunkeln Bildschirm und die PDC-Anzeige. Im MMI 3g war unten in der rechten Ecke "Grafik" anwählbar. Nach derm Softwareupdate von Audi kam die normale PDC-Anzeige und nach dem richtigen codieren gibt es keine PDC-Anzeige und "Grafik" bleibt weg. Die Kamera funktioniert mit Hilfslinien. PDC akkustisch vorhanden. Kennt jemand das Problem?


20.11.2013 18:57    |    Scotty18

Kodierung überprüfen...sollte daran liegen


21.11.2013 20:32    |    da77su

Danke, das habe ich gemacht und festgestellt, dass ich in Adresse 10 das bit 4 umgesetzt hatte. Dieses bit 4 ist ja für die optische Anzeige zuständig. Jetzt funktioniert die RFK perfekt. Schon eine tolle Sache :-)


21.11.2013 20:46    |    Scotty18

geht doch !


03.01.2014 17:25    |    michelmacgyver

Moin Scotty,

erst mal wollte ich dir ein frohes neues Jahr wünschen!

Bin gerade dabei an meinem A5Cabrio die RFK zu installieren und brauche mal deinen Rat bzgl. der Kabeldurchführung vom Deckel in den Kofferraum. Wie und vor allem womit kriegst du das Videokabel durch den Gummischlauch? Plastikgehäuse ist natürlich vom Kabel ab! Hab es gerade mal geschafft einen dünnen Draht durch zu ziehen mit dem es mir aber nicht gelingt das Kabel durch zu ziehen. Hatte auch schon alles ein bisschen gefettet, aber leider bisher ohne Erfolg.

 

LG aus Hamburg

Michael


03.01.2014 17:27    |    Scotty18

mit viel fummeln und PRIL durchziehen


03.01.2014 18:20    |    michelmacgyver

OK, wenn ich weiss das er da durch passen muss dann werde ich mein Glück nochmal versuchen.

Danke!


03.01.2014 18:22    |    Scotty18

stecker vorne von der Fakraleitung aber demontieren!


03.01.2014 23:06    |    fenomenalny

Ich habe ein Problem . Es tut mir leid für die Fehler , aber ich bin Pole , und mein Deutsch ist tragisch :-( .

Habe ich eine Rückfahrkamera. Alles ist miteinander verbunden , wie es sein sollte.

Coding wurde ordnungsgemäß durchgeführt .

Nach dem Scannen das Auto bleibt für mich ein Fehler in der Kamera-Treiber ( unkalibrierten ) .

Nach dem Einschalten Abstand Steuertaste , passiert nichts. Das gleiche gilt bei der Umkehrung .

Wenn ich den Rückwärtsgang nicht einmal eine grafische Helfer , ich höre nur die Signalabstand Steuersensoren .

Wenn ich auf die Abstandsregelung oder werfen umgekehrt und so habe ich verlassen , und ich werde neu starten MMI zeigt ein Bild der Kamera in einer der Leitungen . Beim Ausschalten der Kamera -Taste , oder schalten Sie das Gegenteil, dass ich die Kamera nicht neu starten , es sei denn, Sie starten den MMI zu tun. Könnte dies ein Treiber Problem der Park sein? Konnte er zu alt sein? Auto vom 01.02.2011 abgeleitet und die Kamera -Treiber ist das Symbol B.

Treiber Abstandsregelung ist das Symbol E und weich, um es hochgeladen hat auch ein Symbol E ?

Ist der Austausch der Fahrer Parktronik etwas passiert, das Radar in der Front? Da bemerkte ich , dass sie auch in ihr codiert ? Die gesamte ACC es wird überprüft.


05.01.2014 21:19    |    michelmacgyver

So, kurze Rückmeldung Kabel ist drin! Der entscheidende Tipp war PRIL!

DANKE!!!!!


Deine Antwort auf "Nachr�stung R�ckfahrkamera am A4 / A5 / A7 / A6 4G / A8"

Blogautor(en)

Scotty18 Scotty18

Diagnose-Service

Audi

sonstiges Hobbys :

Mountainbiken

Wasserski

 

GEHT NICHT - GIBTS NICHT

-------------------------------------------------------------------------------------------------------------------

Wer kein Ziel vor Augen hat, kann auch keinen Weg hinter sich bringen

-------------------------------------------------------------------------------------------------------------------

Blogleser (955)

Informationen

Audi S5 (27-12-2011) @ 10030km

Golf VI (27-12-2011) @ 24440km

----------------------------------------

Smart 4Two verkauft   @ 50320km

A3 Sportback verkauft @ 26235km

A3 8P           verkauft @ 41250km

Über Mich :

Name :   Andy S.

Geburtstag : 12.04.1985

Alter : 32

Ort: NRW - Kreis RE

Kontakt:    Mail to - Klick hier   (unter INFO) 

 

Private Message via PN

Hobbys: Audi  / Joggen / Mountainbiken / 

Motto:GEHT nicht GIBTS nicht - was nicht geht, wird gehend gemacht

Mein alter Sportback

Besucher :

  • anonym
  • Corradodave
  • andy1power
  • Pristupniik1
  • mpb_goala
  • Schlimpi28
  • DaFrostii
  • Marcwa19197
  • eboran
  • N8mare00

Countdown

Es ist soweit...ABHOLUNG AUDI S5 in Ingolstadt .....

Blog Ticker