ForumA4 B9
  1. Startseite
  2. Forum
  3. Auto
  4. Audi
  5. A4
  6. A4 B9
  7. Problem mit dem Schiebedach und dem Dachrollo

Problem mit dem Schiebedach und dem Dachrollo

Audi S4 B9/8W, Audi A4 B9/8W Allroad, Audi A4 B9/8W
Themenstarteram 1. Juli 2020 um 11:39

Hallo zusammen,

ich habe seit gestern Probleme mit dem Schiebedach und dem Dachrollo in meinem A4 B9 Avant BJ2017 200kW.

Ich habe gestern versucht mit OBD11 die vollständige Sicherung durchzuführen, bevor ich irgendwas an der Fahrzeugcodierung ändere. Vor diesem Zeitpunkt habe ich OBD11 an diesem Fahrzeug nur zum Auslesen der Fehlercodes verwendet.

Die Sicherung wurde zunächst bei eingeschalteter Zündung angestoßen. Da der Vorgang recht lange dauerte und ich Sorgen um den Ladezustand der Batterie hatte, startete ich den Motor. Dies führte zu zahlreichen Fehlermeldungen im Virtual Cockpit und die Sicherung im OBD11 stoppte/abstürzte.

Anschließend habe ich den Motor aus und wieder angemacht, was ohne Probleme und ohne jegliche Fehlermeldungen im Virtual Cockpit funktionierte. Dann wurde die OBD11 App mit dem Dongle verbunden und die Fehlercodes ausgelesen. Es wurden etwa 70 Fehler gefunden. Die meisten von denen hießen in etwa „Daten Bus Fehler“ oder so ähnlich. Die meisten aller dieser Fehlercodes ließen sich auch problemlos löschen und traten, zumindest bisher, nicht mehr auf.

Leider konnten insgesamt 3 Fehlercodes im Steuergerät für Schiebedach nicht gelöscht werden:

B154354 "Schiebedach keine Grundeinstellung"

B154454 "Dachrollo keine Grundeinstellung"

B169400 "Kein Fahrzeug codier" (oder so ähnlich, habe leider kein Screenshot davon gemacht)

Die automatische Öffnung des Schiebedachs und des Dachrollos beim Betätigen der entsprechenden Tasten über den ersten Druckpunkt hinaus funktionierte nicht. Weiterhin öffneten das Schiebedach und das Rollo beim Drücken und Halten der entsprechenden Tasten nur zu etwa 50%.

Weiter ist mir aufgefallen, dass der Wert von „vehicle_variant“ unter Lange Codierung „0“ beträgt und der eigentliche lange code 60 80 00 00 00 00 (hex).

Im Verlauf der Änderungen habe ich weiterhin einen Eintrag zur Änderung des langen codes von 60 80 00 04 92 02 (hex) zu 60 80 00 00 00 00 (hex) gefunden. Diese Änderung wurde definitiv nicht von mir ausgeführt.

Weitere Internetrecherche ergab, dass die letzten 3 bytes des langen codes wohl den Fahrzeug code darstellen sollen. Daher habe ich den langen code von 60 80 00 00 00 00 (hex) zu 60 80 00 04 92 02 (hex) geändert und der Fehlercode B169400 verschwand.

Daraufhin habe ich versucht die Grundeinstellungen für das Dach und das Rollo durch die Zurücksetzung der Normierung und anschließende Normierung im Menü „Grundeinstellung“ des Schiebedachsteuergeräts vorzunehmen. Dies führte bei dem Rollo zur Öffnung um ca. 50% und zum Schließen ohne dass die Einstellungen gespeichert wurden. Das Dach öffnete mal um 50% und mal komplett. Die Einstellungen wurden aber auch hier nicht gespeichert.

Die Problematik der Überhitzung der Motoren vom Rollo und vom Dach ist mir bekannt. Dies wird entsprechend in den Fehlercodes auch angezeigt. Die obige Prozedur habe ich bereits mehrfach durchgeführt mit hinreichenden Pausen, damit die Motoren abkühlen konnten. Leider werden die Grundeinstellungen immer noch nicht behalten.

Noch folgendes:

Bei der Ansteuerung des Dachs und des Rollos über den Ausgabetest der OBD11 App öffnet das Dach stets vollständig, wohingegen das Rollo nur zu ca. 50% öffnet.

Und ja, vor der Aktion mit der Sicherung hat alles ordnungsgemäß funktioniert.

Nun die Fragen:

Hatte jemand schon gleiche/ähnliche Probleme erlebt? Wir wurde die Problematik gelöst?

War das eine richtige Entscheidung den langen code von 60 80 00 00 00 00 (hex) zu 60 80 00 04 92 02 (hex) zu ändern?

Kann das sein, dass das Rollo aufgrund eines falschen Fahrzeug codes sogar beim Ausgabetest nicht vollständig öffnet?

Hat jemand eine Idee wie ich das Problem mit dem Schiebedach und dem Dachrollo lösen kann?

MfG Anatoliy

Ähnliche Themen
8 Antworten

OBD11 ist nicht ohne! Kann im schlimmsten Fall dein Audi stillegen.

Hast du odis oder vcp?

Hast du schon irgendwelche Werte geändert?

Langer Text zuwenig Informationen, nur vom sichern verstellt sich nix

Bei nochmaligem lesen, ich würd an deiner Stelle zu Audi. Da du schon einiges in den Bits und Bytes geändert hast, Audi macht Abgleich und danach kannst wieder drauf loscodieren...

Die Öffnung kannst du wieder leicht auf 100% stellen , bei obd11 kann ich dir aber nicht helfen da ich das net nutz...

Is Luxus beim Dach , man kann einstellen wo es endet, glaub das hast du auch unbewusst gemacht

Ich will Auch mal ne Frage stellen...

Warum spielt man da rum (Grundeinstellung Test etc.)

Themenstarteram 1. Juli 2020 um 12:16

SgtTbone, erstmal danke für deine Rückmeldung.

Zitat:

OBD11 ist nicht ohne! Kann im schlimmsten Fall dein Audi stillegen.

Das OBD11 nicht ohne ist, merke ich auch gerade...

Zitat:

Hast du odis oder vcp?

ODIS, VCP oder VCDS habe ich leider nicht.

Zitat:

Langer Text zuwenig Informationen, nur vom sichern verstellt sich nix

Der lange Text umschreibt das Problem und die bereits durchgeführten Maßnahmen umfassend. Und es wurde nur gesichert. Davor erfolgte lediglich das Auslesen der Fehlercodes. Mehr nicht. Deswegen habe ich es ja auch so ausführlich geschrieben.

Nach dem Auftreten des Problems wurde die in der Änderungshistorie vermerkte Änderung rückgängig gemacht. Diese ursprüngliche Änderung stammt aber zweifelsfrei nicht von mir.

Zitat:

Is Luxus beim Dach , man kann einstellen wo es endet, glaub das hast du auch unbewusst gemacht

Wurde von mir definitiv nicht verstellt. Siehe die Ausführungen oben.

Zitat:

Ich will Auch mal ne Frage stellen...

Warum spielt man da rum (Grundeinstellung Test etc.)

Weil die Fehlermeldung "Schiebedach keine Grundeinstellung" heißt.

Ist es nicht naheliegend, bei dieser Fehlermeldung eine Grundeinstellung durchzuführen?

Und der Ausgabetest sollte zeigen ob die Mechanik und die Antriebe korrekt funktionieren.

 

Kommst du an deine orginalcodierung ran? Meine würde dir nichts nützen. Nullstellung schon probiert? Keine Ahnung ob das mit obd11 geht.

OBD würd ich da nicht vertrauen was gesicherte Codierung angeht

Nachfolgende Nutzung auf eigene Gefahr

Bei mir ist 49100 unter dieser Adresse

60 80 00 04 92 02 Sicher das der richtig ist?

Hab deine Ausstattung nicht, geh aber davon aus du hast auch normales El sunroof mit El Rollo?

Sicher das da am Anfang 60 kommt?

00 04 ok

92 bin ich auch nicht sicher ob das richtig ist

Themenstarteram 1. Juli 2020 um 12:40

Zitat:

Kommst du an deine orginalcodierung ran?

Das ist ja genau das Problem :)

Die Sache ist bei der Erstellung der ersten Sicherung ausgeartet.

Daher verfüge ich über keine Originalcodierung.

Zitat:

Nullstellung schon probiert?

Was meinst du damit?

Ob OBD11 das kann, muss ich nachschauen. Bin erst heute Abend wieder am Fahrzeug.

Zitat:

Bei mir ist 49100 unter dieser Adresse

Kann es sein, dass du eine Limousine fährst?

;)

Zitat:

@ToKcuKo3 schrieb am 1. Juli 2020 um 12:40:41 Uhr:

Zitat:

Kommst du an deine orginalcodierung ran?

Das ist ja genau das Problem :)

Die Sache ist bei der Erstellung der ersten Sicherung ausgeartet.

Daher verfüge ich über keine

Schön war das früher, da mal paar Minuten Strom runter und danach Schiebedach manuell auf endstellung auf und wieder zu aber das wird bei Vorsprung durch Technik nicht funktionieren xd

Wenn dein langcode passen sollte kein Plan mehr, vielleicht kommt noch einer und hat bessere Tipps...

Hoffentlich hast dir nich die Parameter zerschossen

 

 

***Mod Edit: Quote repariert.

MfG
DJ BlackEagle | MT-Team***

Themenstarteram 1. Juli 2020 um 12:51

Ich hoffe ich darf hier aus einem anderen Forum zitieren:

Zitat:

Now for the car code - The code 49100 sort of did the trick for me - Mine is a A4 Sedan 2016 with several optionals:

- 4xxxx for A4,

- x9xxx as in 9th iteration of an A4, ie B9,

- xx1xx probably meaning type 1, or Sedan,

- xxx00 probably meaning no variation of its basic schematics.

Erscheint soweit plausibel, oder?

Und ich habe mich ja für 49202 aufgrund des alten Werts in der Änderungshistorie entschieden.

Am Anfang kommt eine 60. Siehe Screenshot unten.

Und es ist ein Panoramadach. Fahre einen Avant.

Zitat:

Hoffentlich hast dir nich die Parameter zerschossen

Was meinst du mit den Parametern? Endlagen?

Auszug aus der Änerungshistorie

Bin überfragt aber bei deiner Argumentation, bin ich der gleichen Meinung, müsste passen.

Aber da mein Englisch so gut ist wie meine Kochkünste halt ich mich da raus :)

Wenn nur was verstellt ist, kannst du es in den Anpassungen einstellen.

Sollte dein panodach nicht wissen was 100% offen und 100% geschlossen ist, musst de es deinem Auto beibringen, neu anlernen.

Wie das mit obd11 funktioniert würd ich bei denen fragen, die haben bestimmt eine community....

Ps. Mal abgesehen vom normalen bedienen, was macht er bei den komfortfunktionen öffnen, schließen?

Zur Not einfach mal Batterie ab und auf die selbstheilung von Audi vertrauen

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Auto
  4. Audi
  5. A4
  6. A4 B9
  7. Problem mit dem Schiebedach und dem Dachrollo