ForumA4 B8
  1. Startseite
  2. Forum
  3. Auto
  4. Audi
  5. A4
  6. A4 B8
  7. MMI 3G ohne Soundsystem - Klangcharakteristik am Serien-DSP-Verstärker ändern

MMI 3G ohne Soundsystem - Klangcharakteristik am Serien-DSP-Verstärker ändern

Audi A4 B8/8K
Themenstarteram 16. Juni 2014 um 9:28

Hallo Motor-Talker,

ich habe ein A4 B8 Avant (BJ2010) mit MMI 3G (nicht das "plus" vom Facelift) ohne Soundsystem - also ohne ASS und ohne Bose. D.h. ich habe eine (optische) MOST-Bus Leitung die hinten links im Kofferraum am DSP Verstärker ankommt. Von dort gehen dann die 4 (elektrische) Lautsprecherkabel weg (jeweils + und -, also insgesamt 8 Kabel), an die 8 passiven Lautsprecher (VL, VR, HL, HR mit jeweils Hochtöner und Tieftöner).

Die 8 Lautsprecher habe ich mittlerweile getauscht, gegen hochwertigere aus dem Zubehörmarkt (vorne 20cm Emphazer ECP28NEO-XT4 und hinten 16cm Focal PS165F). Die Hochtöner vorne wurden zudem im Spiegeldreieck montiert, so dass nun die Höhen wesentlich transparenter sind und die vielbesagt Bühne über dem Armaturenbrett entstanden ist.

Des weiteren habe ich im Hidden Menu des MMI die Pegel der Eingangssignale angehoben. Das hat den Effekt dass die serienmäßig programmierte Loudness Bass und Höhenanhebung des MMI nun stärker ist.

Nüchtern betrachtet ist das Ergebnis des Klangs mit diesen Maßnahmen von ursprünglich "mangelhaft" nun bei "gut" bis "befriedigend" angekommen - abhängig von der Musikrichtung. Rock kommt schon relativ gut rüber, da es hier keinen extremen Tiefbass gibt und der Kickbass ausreicht. Die Hose flattert und der Sitz vibriert :)

Wenn man allerdings mal etwas mehr Richtung Dance&Trance geht, dann klingt das eher schlecht.

Problem sind eher nicht die Lautsprecher und auch nicht die original Verstärkerausgangsleistung, sondern vielmehr die Originalprogrammierung des Audi-DSP im Verstärker in einer Einheit (K-Box) hinten links im Kofferraum. Der Bass wird werkseitig weg geschnitten (dazu habe ich schon Kurven in diversen Foren gesehen).

Jetzt gibt es ja viele Threads die sich mit dem Thema beschäftigen. Einmal kann man einen analogen Verstärker mit Bassanhebung oder auch einen DSP-Verstärker mit analogen Hi-Pegel-Eingängen zwischen K-Box und Lautsprecher klemmen und so über eine Bassanhebung der Bassabsenkung in der Originallangkurve entgegen wirken. Das ist eher günstige Lösung mit ca. €300 - €500 Investitionsvolumen, allerdings ist es natürlich nicht die eleganteste Lösung.

Andere Ansätze greifen das unverfälschte Signal Bereits am MOST-Bus ab und schicken es dann durch einen DSP-Verstärker aus dem Zubehörhandel. Das ist natürlich die bessere Lösung - aber mit über €1000 Investitionsvolumen auch nicht gerade billig.

Nun ist mir folgendes aufgefallen: Mit VCDS kann man sich mit dem Modul 5F (MMI) verbinden, dort die Kodierung (Fkt 07) auswählen und die Lange Kodierung bearbeiten. Es gibt dann die Möglichkeit verschieden Karosserie-Formen und Modelle auswählen, z.B. A4 Avant, A4 Limosine, A5, A6 Avant, A6 Limosine usw. - praktisch alle Modelle in denen das MMI verbaut ist. Wenn man hier nun z.B. den A8 auswählt, dann VCDS vom 5F-Modul trennt, das MMI neu startet über einen Reset, dann ist der Sound anschließend tatsächlich anders. D.h. also dass der Original-DSP-Verstärker verschiedene Klangkurven hinterlegt hat, die an jedes Model angepasst sind.

Ich habe alle Möglichkeiten durchprobiert, aber wirklich besser wird der Klang nicht, d.h. es dröhnt manchmal mehr manchmal weniger, da Audi wohl versucht hat die Resonanzfrequenzen für jedes Model "herauszurechnen". Am besten klingt am Ende also in meinem Fall immer noch die Originaleinstellung "A4 Avant".

Jetzt meine Fragen:

1) Hat schon einmal jemand versucht an dieser Stelle im VCDS eine Kodierung einzugeben, die keinem Model zugeordnet ist? Meine Hoffnung wäre dass der Audi-DSP dann auf eine Art Default-Kurve zurück geht, die im idealen Fall einfach "flat" ist und man somit dann die ideale Ausgangsbasis für die Klangveränderung per DSP hätte - ohne teuren MOST-Bus Adapter, bzw. vielleicht klingt "flat" auch schon viel besser, als die aktuellen Audi-DSP-Kurven?

Es kann natürlich auch sein, dass das Steuergerät a) eine unbekannte Kodierung nicht zulässt, oder b) im Fall einer unbekannten Kodierung einfach die erste auswählbare Kurve in der Liste her nimmt (z.B. A4 Limosine).

2) Noch eleganter wäre natürlich, wenn man die DSP Kurven im original Audi-DSP selbst verändern könnte. Ich habe mir einmal die einzelnen Dateien in einem MMI Update angeschaut. Aber selbsterklärend habe ich da natürlich keine EQ-Kurven gefunden. Hat von Euch schon einmal jemand etwas in diese Richtung unternommen?

Ist wahrscheinlich nicht ganz einfach das Thema... ;)

Beste Antwort im Thema

Hallo,

Ich habe das gleiche Problem wie Du in meinem A4/8k BJ 12/2010. in der Radiobox hinten links ist ein Quadverstärker-IC vom Typ: TDA7563 verbaut. Und von diesem IC hatte ich ein Datenblatt hochgeladen.

Datenblatt Quadverstärker Radiobox A4

Dort kannst Du genau sehen, welche Parameter (Bits) über den I²C Bus gesetzt werden können.

Aber wie Spürer schon schrieb, wirst Du da nichts machen können, wird nicht mit VSDS gehen. Ich denke, daß bestimmte Parameter immer beim Einschalten des Fahrzeues (Radiobox) gleich am Anfang über den diesen Bus in den IC geschrieben werden. Schau mal das Datenblatt genau an, vorallem die von mir mit roten Pfeilen gekennzeichneten Parameter.

Mittlerweile ist es so bei mir: machen kann ich dagegen nichts, ich muß einfach damit leben weil, vom Freudlichen kann ich auch nichts erwarten (Nach meheren Anfragen). Eines steht fest, Nie wieder Passiv Soundsysten mit Radio "Low". Klingt echt besch....!

Ich hoffe ich konnte Die helfen mit dem Datenblatt.

Viele Grüße

28 weitere Antworten
Ähnliche Themen
28 Antworten

Da die Klangeinstellungen / Klangparameter werden direkt als Datensatz ins Steuergerät geschrieben über die sog. Parametrierung. Daher ist ein Codieren oder Anpassen mittels VCDS nicht möglich.

Es wäre zwar möglich auf diese Parameterdaten zuzugreifen mit einem anderen Programm wie z.B. VCP - allerdings ohne passenden Login und auch passendem Parametersatz keine Chance.

Die Parameterdaten lassen sich nur online über das Softwareversionsmanagement SVM aufspielen. Und diese Parameterdaten liegen unveränderbar auf dem Server in Ingolstadt.

Hallo,

Ich habe das gleiche Problem wie Du in meinem A4/8k BJ 12/2010. in der Radiobox hinten links ist ein Quadverstärker-IC vom Typ: TDA7563 verbaut. Und von diesem IC hatte ich ein Datenblatt hochgeladen.

Datenblatt Quadverstärker Radiobox A4

Dort kannst Du genau sehen, welche Parameter (Bits) über den I²C Bus gesetzt werden können.

Aber wie Spürer schon schrieb, wirst Du da nichts machen können, wird nicht mit VSDS gehen. Ich denke, daß bestimmte Parameter immer beim Einschalten des Fahrzeues (Radiobox) gleich am Anfang über den diesen Bus in den IC geschrieben werden. Schau mal das Datenblatt genau an, vorallem die von mir mit roten Pfeilen gekennzeichneten Parameter.

Mittlerweile ist es so bei mir: machen kann ich dagegen nichts, ich muß einfach damit leben weil, vom Freudlichen kann ich auch nichts erwarten (Nach meheren Anfragen). Eines steht fest, Nie wieder Passiv Soundsysten mit Radio "Low". Klingt echt besch....!

Ich hoffe ich konnte Die helfen mit dem Datenblatt.

Viele Grüße

Themenstarteram 18. Juni 2014 um 11:47

Hallo Spürer, hallo Hermelin1003,

vielen Dank für die Infos.

Zusammenfassend können wir also sagen:

- die Parameter = Klangkurve kann zwar z.B. mit VCP verändert werden, aber wenn man nicht weiß, welches bit was bedeutet, hat man da leider keine Chance - und das ist leider hier der Fall

- am Verstärker selber läßt sich leider auch nichts machen: Wenn ich die Parameter richtig lese, läßt sich nur der Verstärker (kanalweise) aktivieren, oder deaktivieren - aber das Klangbild an sich, läßt sich nicht ändern

Alternativ könnte man sich jetzt noch einen Audi-Audio-Entwickler entführen und von dem das Ding mittels VCP umprogrammieren lassen. Aber der Aufwand ist mir dann doch zu groß und zu teuer ;)

Also gibt es letztendlich nur die beiden Möglichkeiten, die ich oben beschrieben hatte - mit oder ohne MOST-Bus Adapter, abhängig vom Budget.

Ist schon ein Armutszeugnis, was Audi bei einem €3000 teuren MMI abliefert - da klingt jeder €300 Einbauradio besser :(

(bei meiner alten C-Klasse von 1998 hatte ich solche Probleme nicht - einfach anderes Radio rein und gut)

Das Problem kenne ich nur allzu gut. Ärgere mich damit auch schon lange rum.

Ich habe bei der Installation meines Alpine DSPs eine Einmessung der orig. Frequenzen gemacht. So schlimm haben diese aber nicht ausgesehen wie vermutet. Siehe Anhang:

Die rote Linie ist die Audi Frequenz (MMI 3G Passivsound, Bass und Höhen auf 0, gemessen an beiden Frontkanälen).

Image
Themenstarteram 18. Juni 2014 um 16:21

Hi,

vielen Dank für die Kurven.

Aber was den Bass angeht, finde ich die Kurven schon sehr schlimm - und es hört sich auch schlimm an :(

Wie man auf den Bildern erkennen kann, bügelt der Alpine DSP bis auf 30 Hz runter ganz gut aus.

Damit sollte es klanglich schon deutlich besser werden. Welches Alpine DSP Modell hast Du denn genau?

Habe den PXE-H650. Quasi als Kompromiss, die MOST-Adapter sind mir auch viel zu teuer.

Ja das stimmt, im Bassbereich sieht es original nicht so toll aus. Danach aber ganz OK.

Hier noch eine Messung als ich vergessen hatte alles auf Null zu stellen (Bass und Höhen bei +2-3).

Image

Hallo NCS2011 und TePee,

habe eben nochmal das Datenblatt studiert, und habe dabei folgendes rausgefunden:

Rear/Frontlautsprecher Verstärkung

Bei IB1:

D4

Front Channel

Gain = 26dB (D4 = 0)

Gain = 12dB (D4 = 1)

D3

Rear Channel

Gain = 26dB (D3 = 0)

Gain = 12dB (D3 = 1)

Bei mir ist es so, daß die Hinteren Lautsprecher beim Einschalten des Radios immer leiser sind als die vordern Lautsprecher (obwohl Balanceknopf=0). Da liegt ja schon die Vermutung sehr nahe, daß bei IB1 / D3 beide auf 1 gesetzt sind. Bei Dir sind die hinteren Lautsprecher bestimmt auch hinten leiser als vorn(Bei Balance=0), oder?

und bei IB2:

D1

Right Channel Power amplifier working in standard mode (D1 = 0)

Power amplifier working in high efficiency mode (D1 = 1)

D0

Left Channel Power amplifier working in standard mode (D0 = 0)

Power amplifier working in high efficiency mode (D0 = 1)

Bei IB2 habe ich auch eine Vermutung. Und zwar sind Beim Standard Passiv Soundsystem beide, also D1 und D0 auf 0 gesetzt sind, also Standard-Mode (Radio "Low"?).

Ich könnte mir also vorstellen, wären bei IB2 D1 und D2 auf 1 gesetzt (Radio "High"?), daß der Klang, ohne Beschneidung bestimmter (nach tiefer) liegenden Frequenzen, um vieles besser wäre.

Als ich die Radiobox zerlegt hatte (daher wußte ich erst die IC-Bezeichnung), hatte ich nicht schlecht geguckt, wie extrem niedrig die Bestückungsdichte auf der Hauptplatine ist. Ich bin mir da auch ziemlich sicher, daß bei der Passiv-Soundsystem- Radiobox viel an Bauteilen (auch zum Nachteil des Klangbildes) gespart wurde.

Aber wie gesagt, nur eine Vermutung.

Ist schon ein Armutszeugnis der Ingolstädter wenn man bedenkt, wie viel heutzutage für solche Fahrzeuge hinblättern muß!!

 

Was wäre denn Eure Meinung dazu?

VG

Habe das Datenblatt auch schon intensiv studiert. Mir ist das mit dem High Efficiency Mode auch schon aufgefallen. Was es genau bringt, außer mehr Power, kann ich aber nicht beurteilen, da kenne ich mich nicht aus.

Und selbst wenn, wie switcht man um? Wer oder mit was könnte in das Ding rein?

Habe am WE eine E-Klasse W211 mit Navi klein und Standard Soundsystem gehört. Im Vergleich zum Audi unglaublich. Was für satte Bässe...

Hallo NCS2011,

Ich denke, es wird so sein wie Spürer weiter oben schon geschrieben hat. In den IC kann nichts ohne weiteres codiert werden weil, fest vorgegebener Parametersatz, der immer bei der Initialsierung die selben Bits über den Bus in den IC setzt oder es steht gar in der Firmware.

Nur über Audi/Login geht es, denke ich auch. Ist eben schade dass man der Sache eigentlich ziemlich hilflos gegenübersteht.

Aber mal was anderes, Du hast ja den A4 B8 Avant (BJ2010) mit MMI 3G. Ich habe den A4 B8 Limousine (auch BJ2010) mit MMI 3G Basic+. Ich hatte bei einem Bekannten, der auch so ein VCDS besitzt, schon mal versucht, das Hidden Menu freizuschalten. War mir nicht gelungen weil, Das STG 5F war nicht auffindbar. Habe dann mal gelesen, daß das Hiddenmenü mit MMI 3G Basic+ gar nicht mehr freizuschalten geht. Weißt Du etwas darüber?

VG

Eine andere Idee: Was wäre wenn man diese Radio-Unit auf externen Verstärker umcodieren würde? In vielen anderen Fällen (im VW-Konzern, bei BMW, usw.) hat man dadurch ein Flat-LS-Signal erhalten, mit dem man dann einen netten Sound aufbauen konnte.

Die Frage ist was dann passiert? Kommen dann die Flat-Signale nur noch über MOST (wie bei B&O) oder auch über die normalen LS-Ausgänge?

Das müsste mal jemand mit VCDS ausprobieren :) Man findet dazu nämlich überhaupt keine Infos im Netz.

@hermelin1003: das HiddenMenü ist bei jedem MMI3G freizuschalten! Auch hat ein jedes MMI3G ein Steuergerät 5F! Und bisher ist mir auch kein Fall bekannt, dass das HM nicht freizuschalten gewesen wäre... Hast du vielleicht gar kein MMI sondern Radio? Oder doch noch das MMI2G mit Stg 07?

Ich vermute, wenn auf ext. Verstärker umcodiert wird, liegt gar kein Signal mehr an, da das Signal über den MOST an den ext. Verstärker weitergeleitet wird...

Zitat:

Ich vermute, wenn auf ext. Verstärker umcodiert wird, liegt gar kein Signal mehr an, da das Signal über den MOST an den ext. Verstärker weitergeleitet wird...

Das befürchte ich auch. Aber man könnte es probieren: Einfach umcodieren und falls doch noch etwas aus den LS kommt, dann könnte es gut aussehen. Jemand mit VCDS und MMI 3G/Passivsystem!? Der TE scheint doch ein Kandidat zu sein... :)

@spürer,

Mal zu meinem Fahrzeug.:

- Audi A4 Limousine Ambition 2,0 TDI 105(143) KW(Ps), Baujahr 12/2010

Sonderausstattung:

unter anderem MMI® Navigation

Infotainment:

unter anderem:

Sprachdialogsystem für Navigationssystem mit DVD inklusive MMI

Audi music interface

MMI 3G basic plus

Handyvorbereitung (Bluetooth)

Vieleicht hatten wir das StG einfach nur übersehen, weil Du schreibst, daß sich bei allen das HM freischalten lassen muß. Ich glaube Dir das.

Mal sehen, vieleicht statte ich meinem VCDS-Mann nochmal einen Besuch ab für einen 2. Versuch. Aber eigentlich ist's egal, ich will Ihn demnächst sowieso verkaufen. Will mir einen A5 holen, aber diesmal mit einem ordentlichen Soundsystem.

Vielen Dank für Deine Infos.

Viele Grüße

Themenstarteram 23. Juni 2014 um 17:09

@Hermelin1003: Wenn Du den Drehknopf auf der Mittelkonsole in der horizontalen unterhalb des Schalthebels hast, dann hast Du schon mal ein MMI 3G. Das 3G und das 3G+ unterscheiden sich in der Anzahl der Knöpfe zur Funktionswahl: Das 3G hat 8 Stück (wenn ich das aus dem Kopf noch so weiß, also Navi, Info, Car Setup sind links und rechts sind Radio, Media, Name, Telefon). Das 3G+ hat glaube ich nur 4 Knöpfe. Und wird normalerweise auch erst im Facelift verbaut. Aber das Hidden Menu gibt es bei beiden MMIs.

Zur Freischatlung: "Um das Hidden-Menu aktivieren zu können, ist es notwendig das Bit "MMI 3g ist installiert" zu setzen, sonst funktioniert die Freischaltung über das 5F nicht!!" (das war glaube ich in der Zentralelektrik (Modul 09), oder bei den Instrumenten (17) ).

Und dann im Modul 5F:

"Adaptionskanal 6

Bit von 0 auf 1 setzen

Das Hidden-Menu lässt sich dann mit der Tastenkombination Setup + Car (beide Tasten zugleich drücken) öffnen, wobei man die Setup-Taste als erstes drückt und beide Tasten für mindestens 5 Sekunden gedrückt halten muss."

Anbei das Dokument (wo ich es her habe, weiß ich leider nicht mehr)

@TePee: Umkodieren ja - aber auf welche Werte? Beim MMI habe ich keine Option "externer Verstärker" gefunden... Oder habe ich etwas übersehen?

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Auto
  4. Audi
  5. A4
  6. A4 B8
  7. MMI 3G ohne Soundsystem - Klangcharakteristik am Serien-DSP-Verstärker ändern