ForumW205
  1. Startseite
  2. Forum
  3. Auto
  4. Mercedes
  5. C-Klasse
  6. W205
  7. Einbau- Erweiterung Audio 20 mit China RNS

Einbau- Erweiterung Audio 20 mit China RNS

Mercedes C-Klasse W205
Themenstarteram 6. Januar 2018 um 18:53

Heute mal als Info ein Abriss vom Einbau eines China RNS mit 9“ Zoll Display zur Erweiterung des Audio20 mit Multimediafähigkeiten.

Ja, ich habe es gewagt ;-)

Speziell war ich auf der Suche nach einem Gerät wo die originalen Funktionen wie FM-Tuner / USB / BT und Navi auch weiterhin funktionieren, sowie deren Anzeige im neuen Display als auch noch im KI dargestellt wird. Das war bei mir oberste Prio!

Ebenso sollte der Ton vom China-Teil (Video / Audio / BT / Navi / DNLA-Client) auch über das Werkssystem spielen!

Habe lange gesucht und bin fündig geworden. Wer nun denkt, das System ist mal schnell zwischen Frühstück und Mittag eingeworfen, der irrt gewaltig! Ich habe seit gestern Nachmittag gebastelt………

Was die Kollegen im I-Net nämlich nie zeigen, wo die beiden zusätzlichen Komponenten verbaut werden sollen.

Was hab ich überlegt, probiert verworfen, Kabelbäume aufgetrennt und geflucht! Letztendlich hat alles doch seinen Platz gefunden.

Ich wollte eigentlich alles im Handschuhfach unterbringen, einmal um an die zusätzliche Navi-Karte zum Update (jetzt noch Sygic) und an das Reset-Knöpfchen zu kommen….aber die Leitungslängen geben das nicht her.

Der Platz hinterm Audio20 war ja bei mir durch die Aufrüstung eines DSP durch das Systemkabel vom Axton-A580 eh schon eng, nun kam nochmal eine Kabelpeitsche dazu!

Das original Video-LVDS vom Display ist werksseitig verdammt kurz gehalten, dieses muss jedoch an die neue Zusatzbox, von dort geht es zum neuen Androiden-Display. Nach viel Bastelei um Umverlegen von Kabeln, konnte ich die Mediaeinheit unter dem Audio 20 verstecken.

Der kleine externe Verstärker wird in das mitgelieferte Quadlock-Kabel vom Audio20 eingeschliffen, sodass Audio über die Werksanlage mit wiedergegeben wird. Er hat nun seinen Platz seitlich hinter der Mittelkonsole gefunden und wurde Klappersicher verstaut.

Es gibt übrigens auch viele China RNS-Teile ohne Amp, da wird ein externer LS verbastelt, oder via FM Transmitter eingespeist, oder es geht gar kein Ton!

Das wollte ich nicht! Da habe ich lange recherchieren müssen!

Original FM-USB-CD-BT-Navi, geht alles wie vorher, Top-> Bild wird auch vollständig auf dem neuen Display dargestellt / skaliert!

Sonst bin ich für heute erstmal beeindruckt von der Sache! Touchdisplay geht flüssig, Navi läuft, Videos, Musik…..ist auch via Drehrücksteller bedienbar.

Ein Tip‘s aufs Display und ich bin in der neuen Oberfläche, zurück geht’s am einfachsten mit Tastendruck auf die Medialeiste in der Mittelkonsole, oder Fav.-Taste und Car-Setting auswählen.

Laut-Leise mittels Drehregler.

Touchpad und Lenkrad via Android Oberfläche geht noch nicht, vlt. eine mir noch verborgene Einstellung?

BT-Telefonie hab ich getestet.

Mikro ist unsichtbar am Center-LS versteckt, funktioniert soweit, jedoch hört mein Gegenüber mich etwas Dumpf der Ton im Auto selbst ist o.k. Das war mir aber schon klar, kannte schon aus dem W211, welchen ich ja auch umgebaut hatte.

Die GPS Antenne hab ich mit am Plastekasten hinter dem Display unter der LS Abdeckung angeklebt. Keine Probleme bei der Positionierung, Sat-Fix ist top! Start des Sygic in 0,nix….irre! Natürlich funktioniert die Anzeige nicht im KI, auch das war ja zu erwarten.

Die Antenne für WIFI-Access und DLNA Client wurde an der Beifahrerseite A-Holm platziert. Es werden viele W-Lan Netze gefunden.

DNLA selber habe ich noch nicht getestet, ebenso Mirror Link oder Spiegelung des Handys via USB Anschluss.

Der Support der China-Leute beim Kauf war Top.

Ich hatte ja Bammel die Mediabox in der Mitte zu versenken, aber via Mail wurde mir mitgeteilt, dass das Kartenupdate auch via USB-möglich ist. Davon habe ich nun nochmal 3 im Handschuhfach.

Ich wollte ja ein breiteres Display 10 oder-12“ mit Android 7, aber davon wurde mir bei meinem alten Baujahr 08/2014 abgeraten, da gab es wohl massig Probleme mit der Can-Anbindung und Android 7 ist wohl dermaßen aufgebläht, dass es bei gleichem Prozessor keinerlei Vorteile bringt.

Massig Apps und Schnickschnack will ich eh nicht installieren.

Das 9“ mit Android 4.4.4 soll wohl ohne Zicken laufen, wurde mir per Mail mitgeteilt. Na mal sehen.

Nun hab ich also noch Reserve Navis zur Verfügung :-)

DVD-Player / DVBT / Front & Rear Cam könnten noch angeschlossen werden, brauch ich aber nicht.

Das soll erstmal reichen, ich werde weiter testen und berichten, positives wie negatives!

Bild-1
Bild-2
Bild-3
+7
Ähnliche Themen
892 Antworten

Zitat:

@Riddik77 schrieb am 15. Juli 2020 um 18:33:21 Uhr:

Ich hab einen w 204

Ok, verstehe. Dann passt die Version für dich. Wenn du im w204 wie im w205 nur USB und kein Aux hast brauchst Du m.E. wie ich beim w205 einen Aux-In USB-Adapter/Interface, der dann sicherlich auch mitgeliefert wird. Ich habe leider gerade kein Bild davon. Vielleicht ist es beim w204 aber auch ganz anders. Onur hier aus dem Forum kann dir sicherlich gut Auskunft geben

 

Jo danke- vielleicht ist es ja auch nicht das korrekte bild der Anshlüsse....

@Riddik77 wenn du beim w204 kein aux oder mmi hast, wird das aux kabel einfach am kabelbaum direkt verbunden.du hast am kabelbaum einmal aux in und einmal aux out...einfach nur miteinander verbinden und übers display aux freischalten klicken das wars...die usb aux methode wie beim w205 wird bei ntg 4 oder ntg 4.5 nicht unterstüzt...

Hey, danke für die Antwort- meinst Du den Kabelbaum vom Benz oder den am Radio? Ich seh am Radio nämlich kein aux in.

Hallo Leute,

kürzlich eingebaut: Navifly N600 in einen 2015er S205 (hab mit CPU-Z die Auflösung geprüft - sind die angegebenen 1920x720)

Firmware: 1.8.2

Ich möchte mich mal kurz bei euch allen bedanken - habe bisher auf alle Fragen hier eine Antwort bekommen! Top Forum!

Einbau von dem Teil war auch problemlos möglich, nichts umstöpseln - einfach Plug N Play - trotz Hinweis von Navifly ich sollte es einen Fachmann machen lassen ;-)

Das einzige was etwas komplizierter war, war den breiten Stecker von der Head Unit unten nach oben zum Display zu bekommen. Hab dann einen Draht von der Center Lautsprecher Öffnung runter geschoben und dann den Stecker hochgezogen - ging dann letzendlich auch gut.

Trotzdem noch zwei Fragen:

  • Update auf 1.9.1: mir scheint es sind aufgrund der Größe von 1,3GB immer komplette Images - bedeutet ich kann direkt und ohne Zwischenupdate auf die 1.8.4 direkt auf die neueste Version updaten?
  • Update auf 1.9.1: bleiben Apps und Einstellungen vorhanden oder muss ich das alles neu machen?

Liebe Grüße tsmiler2 - und vielen Dank nochmals für eure Unterstützung.

p.s.: Funfact - das Paket hat laut DHL Sendungsverfolgung nur 45h von HongKong zu mir gebraucht...

W205 navifly n600 - während Einbau
W205 navifly n600 - nach Einbau

Die Updates sind kein Problem: Mann kann sogar von 1.5 auf 1.9.1 updaten, wenn man das muss.

Das schöne bei den KSW OTA Updates ist, es bleiben alle Apps und Daten erhalten. Ich lösche immer nur nach dem Update die China Nav App. Neuerdings oxidierte auch ein nicht installiertes IGO auf der root Ebene im Android. Ist das eine Raubkopie oder eine nette Dreingabe?

@tsmiler2 zum Thema "den breiten Stecker von der Head Unit unten nach oben zum Display" empfehle ich das Video von Flexx, das ich natürlich auch erst nach dem Einbau gesehen habe:

https://www.youtube.com/watch?v=MrvGz_UwbVg

ungefähr bei 6:40 min und nochmal bei 10:35 min.

Ich habe meine blutenden Finger betrachtet und dabei leise geweint.

@Riddik77 am kabelbaum vom neuen display...

Ist aber auf dem Bild nicht zu sehen, oder ?

Ihr könnt immer das neueste update installieren...falls es erwünscht ist, das beim updaten auch die werkeinstellung erfolgen soll,muss die update datei umbenannt werden...

Weiß jemand wie ich Split screen hinbekomme? Irgendwo hab ich's mal gelesen - find es aber nicht mehr.

Den "Taskmanager" öffnen und die gewünschte App in eine Hälfte ziehen.

Zitat:

@mazda323fbg-az-3 schrieb am 17. Juli 2020 um 13:47:40 Uhr:

Den "Taskmanager" öffnen und die gewünschte App in eine Hälfte ziehen.

Danke Mazda für den Tipp. Man muss im Taskmanager länger drauf drücken und erst dann die App verschieben. Das hatte ich bisher nicht getestet.

Nutze aktuell allerdings Android Auto über headunit reloaded. Funktioniert gut - damit bin erstmal zufrieden.

Android Auto

Hi Leut,

ich wird langsam irre. Ich hab immer noch das Problem das Android die Uhreinstellungen einfach nicht dauerhaft speichert. Egal was ich einstelle. Uhrzeit über Netzwerk, über OEM Radio, manuell, sobald die Zündung aus ist, ist die Uhrzeit wieder auf 12 Stundenformat eingestellt.

Das Problem wirkt sich auch auf das GPS Signal, das Suchen nach GPS dauert ewig, ausser ich stelle die Uhrzeit manuell auf das richtige Format, das läuft wieder GPS ohne Probleme.

Habe auch schon das neueste Update (1.9.1) eben mal eingespielt. Das Problem ist das selbe.

Vielleicht hat da noch jemand einen Rat.

@Mo-320 da stimmt was nicht...benutzt du einen gps splitter für oem? Oder hast du die gps antenne von android angeschlossen?

 

Vielleicht hilft dir ne neue mcu datei...mach mal bitte ein foto von systeminfo, damit ich dir die aktuelle mcu für dein display schicken kann...

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Auto
  4. Mercedes
  5. C-Klasse
  6. W205
  7. Einbau- Erweiterung Audio 20 mit China RNS