ForumTouran
  1. Startseite
  2. Forum
  3. Auto
  4. Volkswagen
  5. Touran
  6. Touran
  7. RNS 510 nach Bootlogo Wechsel komplett tot - Erfahrungsbericht bis zur Wiederbelebung

RNS 510 nach Bootlogo Wechsel komplett tot - Erfahrungsbericht bis zur Wiederbelebung

VW Touran 1 (1T)
Themenstarteram 9. Juni 2013 um 11:59

Nachdem ich mein RNS 510 (1T0 035 680 B / HW: H02 / SW: 0800 lt. Aufkleber - Update auf FW 1300 selber durchgeführt) durch das "problemlose" Wechseln des Bootlogos mittels des bekannten Webdienstes (http://www.netdata.be/iso/?) komplett tot bekommen habe, möchte ich hier meine Erfahrungen als Warnung (und zum Bessermachen) berichten.

Ich habe im letzten Jahr mein RNS 510 erfolgreich auf FW 1300 upgedated, seitdem kann ich 32GB SD-Karten problemlos nutzen. Mein Freundlicher wollte mir dieses Update mit der Aussage: "SD-Karten >4GB gehen laut VW auf ihrer Hardware sowieso nicht" nicht aufspielen, aber das ist eine andere Geschichte... Nachdem ich im Netz auf den problemlosen Wechsel des Bootlogos aufmerksam wurde, habe ich ein nettes Bild erstellt, hochgeladen, eine ISO erstellen lassen und diese auf CD gebrannt. In der FAQ der Seite wird sogar explizit erwähnt, dass bislang kein Fall bekannt ist, bei dem das RNS "gebricked" wurde. Also noch das youtube-Video genau angeschaut, gesehen, dass der Wechsel nur 5min. dauert und ab ins Auto, SETUP+EJECT+I gedrückt und CD rein.

Das kleine weiße Fenster erschien und der grüne Balken fing an zu laufen. Er stockte jedoch an einigen Stellen ziemlich lange und nach 15 min. war er erst bei 75%, sodass ich vermutete er kann die CD nicht richtig lesen. Nachdem ich bereits ausreichend Erfahrungen mit so heiklen Dingen wie BIOS-Updates bei Mainboards und auch mit RNS 510 Updates hatte, entschloss ich mich zum Abbruch per Reset (< + > und I). Ich dachte bislang, dass bis zum Zeitpunkt, wo auf dem RNS der Bildschirm mit den Update-Infos kommt und dann frägt, ob das Update durchgeführt oder abgebrochen werden soll, nur Daten von CD gelesen (und verfiziert) werden und noch nichts am RNS 510 geändert wird. Also sollte doch ein Reset bis dahin nichts kaputt machen können. Das RNS startete neu und es blinkte mehrmals nur kurzfristig ein weiss hinterleuchteter Bildschirm auf. Leider kam das RNS auch nach 10min. nicht mehr in den normalen Modus, sondern startete immer wieder neu und der Bildschirm wurde kurzfristig nur weiss. So bleib es dann auch .... RNS komplett tot :-(

Auch am nächsten Tag das gleiche. Weder wurden die Knöpfe hinterleuchtet, noch ging irgendetwas anderes. Auch die CD ließ sich nicht auswerfen. Das Laufwerk startete gar nicht. Auch Tipps aus dem Netz das RNS auszubauen und damit für >60min von Strom zu trennen brachten keine Änderung. Zum Freundliche brauchte ich nicht gehen, da erstens die Bootlogo-CD noch drin war und zweitens mir klar war, dass der nur einen sündhaft teuren Austausch anbieten würde.

Ich nahm daraufhin Kontakt mit dem Betreiber der Bootlogo-Webseite auf. Dieser antwortete auch freundlich und meinte dies sei das erste Mal in zwei Jahren, dass so ein Fehler auftrat. Er stellte den Kontakt zu einem RNS 510 Firmware-Experten her, der meinte man müsste ein Neuprogrammierung des internen Flashspeichers durchführen. Etwas ähnliches wurde hier beschrieben: http://vwnavi.com/.../...you-have-rns510-stuck-black-screen-print.html . Kurzfassung: Navi von unten öffnen, Mainboard ausbauen, richtigen Chip identifizieren, auslöten, mit einem passenden Image von einem anderen, baugleichen RNS 510 programmieren, Chip einlöten, Firmware neu drauf und per RNS Manager den (bisherigen) PIN neu setzen, da der Hash für den PIN durch das Image von einem anderen RNS ungültig wird. Da ich niemanden fand, der den notwendigen Adapter für den Flash-Speicher für einen EEPROM-Programmer hatte, habe ich mich dann dazu entschlossen das RNS 510 zu einer Navi-Reparaturwerkstatt in Essen einzuschicken. Diese haben die Arbeiten durchgeführt und mein RNS 510 läuft wieder wie vorher ;-) Ich bin jetzt mehrere Hundert Euro ärmer, dafür um eine Erfahrung reicher.

Vor der Reparatur habe ich noch hier im Forum die Beschreibung zur seriellen Schnittstelle des RNS 510 gefunden, über die dan einen Haufen Debug-Meldungen bekommt. Aber über einen entsprechenden Adapter habe ich gar keine Meldungen bekommen, also was das RNS komplett tot. Ich habe den Adapter nach der Reparatur nochmals getestet, dann bekam ich seitenweise Meldungen, also er funktioniert schon...

So, ist etwas lang geworden, aber ich hoffe dies lesen genug andere, die mit dem Gedanken spielen das Bootlogo zu ändern und es sich so einfach und problemlos vorstellen, wie ich. Ich möchte nicht generell die Schuld auf die Bootlogo Webseite schieben. Ich tippe eher darauf, dass mein Abbrechen des Updates per Reset zum Zeitpunkt, wenn der grüne Balken läuft, das RNS zerschossen hat. Von daher mahne und warne ich jeden das durchlaufen zu lassen, auch wenn es ewig dauert. Erst später dann kann man abbrechen und die CD auswerfen lassen. Auch bei Firmware Updates ist dies ein leichter Weg aus seinem RNS einen Briefbeschwerer zu machen. Die Bootlogo-CD werde ich trotzdem nicht mehr reinschieben. Eventuell passen auch die dort verwendeten Dateien nicht zu meinem RNS. Mir ist das Risiko (und die Kosten für einen Reparatur) zu groß, nur um beim Start kurz ein nettes Bild zu sehen. So nebenbei scheint es ein tolles Update-Konzept im RNS 510 zu sein, dass man es so komplett tot geflasht bekommt. Es sollte eine nicht-überschreibbare Firmware drauf sein, die auf jedenfall läuft und eine Neuprogrammierung zu lässt, egal, was mit dem Flash passiert ist. Bei den PC-Mainboard heisst das Not-CD bzw. USB-Stick... Bei einem >2000€ teuren Gerät sollte das drin sein.

Eventuell schildert Ihr hier eure Erfahrung mit Firmware-Updates und vorzeitigem Reset bzw. Bootlogo Wechsel. Gibt es ein sicheres Verfahren? Zum Beispiel die Bootlogo-Datei aus dem ISO in eine "richtige" Firmware-Update CD kopieren und damit das RNS updaten? Dauert zwar anstatt 5min. eine ganze Stunde, aber ich hatte >2 Monate kein RNS mehr.

Beste Antwort im Thema
Themenstarteram 9. Juni 2013 um 11:59

Nachdem ich mein RNS 510 (1T0 035 680 B / HW: H02 / SW: 0800 lt. Aufkleber - Update auf FW 1300 selber durchgeführt) durch das "problemlose" Wechseln des Bootlogos mittels des bekannten Webdienstes (http://www.netdata.be/iso/?) komplett tot bekommen habe, möchte ich hier meine Erfahrungen als Warnung (und zum Bessermachen) berichten.

Ich habe im letzten Jahr mein RNS 510 erfolgreich auf FW 1300 upgedated, seitdem kann ich 32GB SD-Karten problemlos nutzen. Mein Freundlicher wollte mir dieses Update mit der Aussage: "SD-Karten >4GB gehen laut VW auf ihrer Hardware sowieso nicht" nicht aufspielen, aber das ist eine andere Geschichte... Nachdem ich im Netz auf den problemlosen Wechsel des Bootlogos aufmerksam wurde, habe ich ein nettes Bild erstellt, hochgeladen, eine ISO erstellen lassen und diese auf CD gebrannt. In der FAQ der Seite wird sogar explizit erwähnt, dass bislang kein Fall bekannt ist, bei dem das RNS "gebricked" wurde. Also noch das youtube-Video genau angeschaut, gesehen, dass der Wechsel nur 5min. dauert und ab ins Auto, SETUP+EJECT+I gedrückt und CD rein.

Das kleine weiße Fenster erschien und der grüne Balken fing an zu laufen. Er stockte jedoch an einigen Stellen ziemlich lange und nach 15 min. war er erst bei 75%, sodass ich vermutete er kann die CD nicht richtig lesen. Nachdem ich bereits ausreichend Erfahrungen mit so heiklen Dingen wie BIOS-Updates bei Mainboards und auch mit RNS 510 Updates hatte, entschloss ich mich zum Abbruch per Reset (< + > und I). Ich dachte bislang, dass bis zum Zeitpunkt, wo auf dem RNS der Bildschirm mit den Update-Infos kommt und dann frägt, ob das Update durchgeführt oder abgebrochen werden soll, nur Daten von CD gelesen (und verfiziert) werden und noch nichts am RNS 510 geändert wird. Also sollte doch ein Reset bis dahin nichts kaputt machen können. Das RNS startete neu und es blinkte mehrmals nur kurzfristig ein weiss hinterleuchteter Bildschirm auf. Leider kam das RNS auch nach 10min. nicht mehr in den normalen Modus, sondern startete immer wieder neu und der Bildschirm wurde kurzfristig nur weiss. So bleib es dann auch .... RNS komplett tot :-(

Auch am nächsten Tag das gleiche. Weder wurden die Knöpfe hinterleuchtet, noch ging irgendetwas anderes. Auch die CD ließ sich nicht auswerfen. Das Laufwerk startete gar nicht. Auch Tipps aus dem Netz das RNS auszubauen und damit für >60min von Strom zu trennen brachten keine Änderung. Zum Freundliche brauchte ich nicht gehen, da erstens die Bootlogo-CD noch drin war und zweitens mir klar war, dass der nur einen sündhaft teuren Austausch anbieten würde.

Ich nahm daraufhin Kontakt mit dem Betreiber der Bootlogo-Webseite auf. Dieser antwortete auch freundlich und meinte dies sei das erste Mal in zwei Jahren, dass so ein Fehler auftrat. Er stellte den Kontakt zu einem RNS 510 Firmware-Experten her, der meinte man müsste ein Neuprogrammierung des internen Flashspeichers durchführen. Etwas ähnliches wurde hier beschrieben: http://vwnavi.com/.../...you-have-rns510-stuck-black-screen-print.html . Kurzfassung: Navi von unten öffnen, Mainboard ausbauen, richtigen Chip identifizieren, auslöten, mit einem passenden Image von einem anderen, baugleichen RNS 510 programmieren, Chip einlöten, Firmware neu drauf und per RNS Manager den (bisherigen) PIN neu setzen, da der Hash für den PIN durch das Image von einem anderen RNS ungültig wird. Da ich niemanden fand, der den notwendigen Adapter für den Flash-Speicher für einen EEPROM-Programmer hatte, habe ich mich dann dazu entschlossen das RNS 510 zu einer Navi-Reparaturwerkstatt in Essen einzuschicken. Diese haben die Arbeiten durchgeführt und mein RNS 510 läuft wieder wie vorher ;-) Ich bin jetzt mehrere Hundert Euro ärmer, dafür um eine Erfahrung reicher.

Vor der Reparatur habe ich noch hier im Forum die Beschreibung zur seriellen Schnittstelle des RNS 510 gefunden, über die dan einen Haufen Debug-Meldungen bekommt. Aber über einen entsprechenden Adapter habe ich gar keine Meldungen bekommen, also was das RNS komplett tot. Ich habe den Adapter nach der Reparatur nochmals getestet, dann bekam ich seitenweise Meldungen, also er funktioniert schon...

So, ist etwas lang geworden, aber ich hoffe dies lesen genug andere, die mit dem Gedanken spielen das Bootlogo zu ändern und es sich so einfach und problemlos vorstellen, wie ich. Ich möchte nicht generell die Schuld auf die Bootlogo Webseite schieben. Ich tippe eher darauf, dass mein Abbrechen des Updates per Reset zum Zeitpunkt, wenn der grüne Balken läuft, das RNS zerschossen hat. Von daher mahne und warne ich jeden das durchlaufen zu lassen, auch wenn es ewig dauert. Erst später dann kann man abbrechen und die CD auswerfen lassen. Auch bei Firmware Updates ist dies ein leichter Weg aus seinem RNS einen Briefbeschwerer zu machen. Die Bootlogo-CD werde ich trotzdem nicht mehr reinschieben. Eventuell passen auch die dort verwendeten Dateien nicht zu meinem RNS. Mir ist das Risiko (und die Kosten für einen Reparatur) zu groß, nur um beim Start kurz ein nettes Bild zu sehen. So nebenbei scheint es ein tolles Update-Konzept im RNS 510 zu sein, dass man es so komplett tot geflasht bekommt. Es sollte eine nicht-überschreibbare Firmware drauf sein, die auf jedenfall läuft und eine Neuprogrammierung zu lässt, egal, was mit dem Flash passiert ist. Bei den PC-Mainboard heisst das Not-CD bzw. USB-Stick... Bei einem >2000€ teuren Gerät sollte das drin sein.

Eventuell schildert Ihr hier eure Erfahrung mit Firmware-Updates und vorzeitigem Reset bzw. Bootlogo Wechsel. Gibt es ein sicheres Verfahren? Zum Beispiel die Bootlogo-Datei aus dem ISO in eine "richtige" Firmware-Update CD kopieren und damit das RNS updaten? Dauert zwar anstatt 5min. eine ganze Stunde, aber ich hatte >2 Monate kein RNS mehr.

36 weitere Antworten
Ähnliche Themen
36 Antworten
Themenstarteram 13. Juli 2017 um 21:11

Oha, schon so verzweifelt, dass du 3mal posten musstest? ;)

Ich schicke Dir gleich per PM den Namen der Firma, die mir damals helfen konnte.

Grüße,

Olli

Hallo,

 

Ich habe mit meinem RNS 510 ein Problem mit einem verzerrten bootlogo. Kann mir jemand sagen woran das liegt und wie ich das wieder in den normalzustand bekomme?

Manchmal Bootet er und zeigt das Bild, was dann etwas dauert bis er startet und manchmal startet gleich der Radio. Woran liegt das?

 

Wäre gut wenn mir jemand helfen könnte.

 

Schicke Bilder mit

Asset.JPG
Asset.JPG
Asset.JPG

Siehe anderen Thread/Antwort

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Auto
  4. Volkswagen
  5. Touran
  6. Touran
  7. RNS 510 nach Bootlogo Wechsel komplett tot - Erfahrungsbericht bis zur Wiederbelebung