ForumOn-Board-Diagnose
  1. Startseite
  2. Forum
  3. Wissen
  4. Fahrzeugtechnik
  5. On-Board-Diagnose
  6. OBD II Bluetooth ELM 327 Firmware-Version 2.1

OBD II Bluetooth ELM 327 Firmware-Version 2.1

Themenstarteram 5. November 2016 um 16:32

Hallo Leute,

ich habe jetzt schon 2 OBDII - Bluetooth Adaper bei Amazon gekauft.

Laut ELM 327 Identifier App unterstützen beide nur bis Version 1.4 Befehle.

Der erste Adapter meldet Version 2.1, in der Beschreibung wurde keine genannt, ich wusste von dem Problem da noch nichts.

Der zweite wurde als Version 2.1 beworben, meldet schon nur 1.5 und nur 1.4 Befehle gehen.

Der Carly Entwickler sagt, mit diesem Adapter geht es nicht (tut bei mir auch nicht).

Konkret welche Version er braucht hat er mir nicht mitgeteilt.

Torque geht prinzipiell, aber der Entwickler sagt auch mit den "Fake-Modellen" kann es Probleme geben.

Eine konkrete Aussage Firmware Version x.x wird gebraucht sonst geht das und das nicht wäre besser.

Vielleicht können ein paar Leute Adapter nennen bei denen sie die 2.1 Befehle z.B. mit ELM 327 Identifier App verifiziert haben.

Vorzugsweise sehr klein, weil der bei der A-Klasse in den Fußraum ragt.

Preiswert ist natürlich auch gut.

Der zweite Adapter sollte angeblich auch Bluetooth und Wifi können, Wifi ist aber keines zu finden.

Version 2.1, Bluetooth, Wifi, Klein und preiswert wäre das Optimum.

Ähnliche Themen
29 Antworten

Version 1.5 git es beim ELM327 nicht.

Du hast da wohl zwei Fake-Chips.

https://en.m.wikipedia.org/wiki/ELM327#Pirate_clones

Themenstarteram 5. November 2016 um 17:15

Was das "Fake" betrifft ist es wohl so, dass auch die Originale PIC-Mikrocontroller sind, die man einfach kaufen kann.

Man hat es halt noch nicht geschafft die neuste Firmware zu kopieren.

Ich hoffe wie gesagt auf Tipps mit verifizierter Version 2.1...

Weil es mich selbst auch interessiert hab ich mal bisschen gegoogelt...der ELM327 Markt ist wohl echt undurchdichtig.

Auf Anhieb fand ich nur das...

https://www.obd-2.de/.../...adapter-bt-obd-327-fuer-pc-android-symbian

Themenstarteram 5. November 2016 um 17:36

Ich bezweifle, dass alle bei denen Carly geht 150 Euro für einen Original 327 ausgeben.

Also müssen die Apps doch mit den alten Befehlen klar kommen.

Oder gibt es doch billigere mit mehr Befehlen???

Ein ELM 327 Chip kostet ~20 $ ... folglich werden sie gerne gefälscht und funktionieren dann nicht oder nicht richtig.

Themenstarteram 5. November 2016 um 19:00

Dann sollte es doch Adapter für weniger als 100 Euro geben können.

Dann ist auch die Frage ob man halt nicht mit den verfügbaren älteren Befehlen auch genug machen kann, oder klar ausgeben was nicht funktioniert.

Immer nur diese vagen Aussagen in dem Zusammenhang.

@IngoWolf ,

habe 3 Billig Elm welche alle funktionieren.

http://www.motor-talk.de/suche.html?...

Themenstarteram 5. November 2016 um 19:22

@conny-r : Womit? Carly Mercedes?

Gute OBD Adapter kosten ~30€ ...

Themenstarteram 5. November 2016 um 20:26

Vermutlich sind ~30€ Adapter aber nicht zwingend gut.

Unter Umständen die gleichen nur von anderem Händler.

In einem 30€ Adapter kann schwerlich ein original 20€ Chip sein.

Und wenn nicht ein besser gehackter?

Wenn sich laut Wikipedia nur die 1.0 Version kopieren ließ, woher sind dann die Version 1.4 Befehle in den Fakes?

Ich würde diesen hier empfehlen: http://www.ivini-tech.de/.../

Davon mal ab habe ich nie behauptet, dass alle 30€ Adapter gut sind ... Vielmehr kosten gute ~30€.

Es ist doch so...entweder ist es für billiges Geld ein Fake-ELM oder eben was super-proprietäres wo genau steht "für App XyZ" und es funktioniert halt weil es dafür getestet ist...so wie der weisse da oben im Link.

Das sind danm eben vom Microcontroller Maßschneiderungen für eine bestimmte App oder Software.

Die generische eierlegende Tittensau ELM327 kostet im Händlereinkauf schon 20 ocken also wie soll man für 30 Euro da noch Welan und Blauzahn reinpacken in kompakter Bauform und noch Geld dran verdienen??

Themenstarteram 5. November 2016 um 21:32

Ist das nicht alles CAN?

Wieso muss da für eine App was anders sein?

Das sollte alles mit der APP-Software lösbar sein.

Es gibt Hardware- und Softwareprotokolle...OSI-Layer lassen grüßen.

Timings, Taktflanken, Kollisionserkennung, uswuswusw...

Implementier erstmal das CAN-Protokoll...da gibt es wohl sehr viel Anomalien und der ELM327 kommt mit allen Abarten am allerbesten klar...

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Wissen
  4. Fahrzeugtechnik
  5. On-Board-Diagnose
  6. OBD II Bluetooth ELM 327 Firmware-Version 2.1