ForumW208
  1. Startseite
  2. Forum
  3. Auto
  4. Mercedes
  5. CLK & E-Klasse-Coupé
  6. W208
  7. Kommunikation Comand mit StarDiagnose

Kommunikation Comand mit StarDiagnose

Mercedes CLK 208 Cabrio
Themenstarteram 29. April 2021 um 12:51

Hi, eins vorweg, mir ist wohl der dümmste Fehler überhaupt passiert....:mad:

Ich habe letzten Abende damit verbracht einige Ausstattungen nachzurüsten, unter anderem SBS, PTS. Der Kabelbaum für Klimaautomatik und Automatikgetriebe liegen auch schon im Auto, davon ist aber noch nichts angeschlossen. Das Armaturenbrett wurde auch endlich gewechselt und das Designo hat wieder Einzug gefunden.

Sprachbediensystem oder Linguatronic und PTS (PDC) funktionieren auch super. Jedoch hat sich beim Testen ein großer Fehler eingeschlichen. Als ich alle Komponenten und insb. das SBS testen wollte, musste ich das Comand anklemmen.

(Mercedes schafft es wirklich kaum einen Stecker 2 mal zu verbauen. Immer haben diese kleine Veränderungen wie Nasen usw., damit diese ja nicht vertauscht werden können)

Zufälligerweise ist aber der Heizungsstecker vom Bedienteil 1zu1 der gleiche wie der C2 Stecker am Comand (der mit dem grauen Bügel) und diese liegen nur wenige Zentimeter auseinander (wenn der Mitteltunnel raus ist). Ihr könnt euch denken was passiert ist. Heizungsstecker ins Comand und alle D2B Komponenten zeigten Fehler (kein D2B Gerät wurde mehr erkannt). Ansonsten funktionierte das Comand aber noch.

Zufälligerweise hatte ich noch ein Comand liegen und habe es diesmal richtig angeschlossen -> ALLES KLAPPT!:)

Nur jetzt zum negativen Punkt: In der SD wird kein einziges Steuergerät der Gruppe "Information und Kommunikation" angezeigt, sprich weder Comand, Tel, SBS, Cd-Wechsler, Heizung usw. Alle Steuergeräte fehlen in der SD beim Kurztest. Zugreifen kann ich auf die Steuergeräte auch nicht.

An Stecker A Pin2 des Comands liegt die K-Leitung an, welche direkt an die OBD1 Dose Pin 34? geht (kann auch ein anderer gewesen sein). Jedenfalls hat die Leitung keine Unterbrechung und auch KL. 30 und KL. 15 liegen am Comand an.

Im angehängten Bild seht ihr den C2 des Comands und den Heizungsstecker gegenüber gestellt und wo 12V+ draufgegeben wurden (ohne Gewähr, hab das nur schnell aus dem Schaltplan abgelesen)

Hat einer eine Idee? ich hab irgendwie den Innenraum Can in Verdacht, wobei der mir beim EZS auslesen keinen Fehler angezeigt hatte.

C2
Ähnliche Themen
7 Antworten

Hallo dacsan.

..."und alle D2B Komponenten zeigten Fehler (kein D2B Gerät wurde mehr erkannt).

Ansonsten funktionierte das Comand aber noch".

Bedeutet das,

das Du nach dem "Unfall" mit SD das alte Comand noch erreichen

konntest, das neue Comand jedoch nicht (bzw. noch nie) ? :confused:

 

Gruß, mike. :)

Themenstarteram 29. April 2021 um 15:52

Zitat:

@V8CLK430 schrieb am 29. April 2021 um 14:35:53 Uhr:

Hallo dacsan.

..."und alle D2B Komponenten zeigten Fehler (kein D2B Gerät wurde mehr erkannt).

Ansonsten funktionierte das Comand aber noch".

Bedeutet das,

das Du nach dem "Unfall" mit SD das alte Comand noch erreichen

konntest, das neue Comand jedoch nicht (bzw. noch nie) ? :confused:

 

Gruß, mike. :)

Das alte Comand funktioniert noch, bis auf alle D2B Komponenten. Es ist aber nicht erreichbar über SD.

 

Mit dem neuen Comand funktionieren auch alle D2B Komponenten, aber es ist auch nicht über SD erreichbar.

 

Probeweise habe ich eben mal das KI gewechselt. Keine Besserung. Genauso habe ich von einem anderen Fahrzeug MSG, EIS und Wegfahrsperre genommen.

Auch keine Besserung:rolleyes:

 

Die auf dem Bild zu erkennenden Steuergeräte sind alle nicht erreichbar. Nicht irritierten, meiner ist ein 208.435.

 

Auf dem Bild erkennt man oben 208.347 - das ist die probeweise gesteckte Einheit vom Schlachter.

.jpg

Halli Hallo,

ich antworte immer gerne öffentlich, damit alle was davon haben, wobei mein Input zu dieser Sache leider verschwindend Gering ist.

An Deiner Gegenüberstellung siehst Du ja, wo Du am Comand ne Spannung angelegt hast ;) Da hast Dir wohl das Comand geschossen. Du schreibst ja aber auch, dass ein anderes Comand funktioniert. Das ist schon mal prima.

Gesteuert werden die Geräte im D2B Ring über C und D2B. C war ja nicht gesteckt (dafür die Heizung) und D2B ist ein Lichtwellenleiter, da passiert also auch nix.

Deshalbn habe ich die Vermutung, Dass Du Dir irgendwie die Codierung geschossen hast. Dein Auto ist also "ohne Radio" so meine Vermutung. Wahrscheinlich kannst Du auch jetzt wieder die Uhrzeit im KI einstellen oder?

Wenn dem so ist, dann in SD wieder die richtoige Ausstattung codieren. Weiß die Schritte leider nicht auswendig, ist zu lange her...

Vielleicht ein Lösungsansatz... Viel Erfolg!

Themenstarteram 30. April 2021 um 14:46

Zitat:

@hotw schrieb am 30. April 2021 um 11:59:25 Uhr:

Halli Hallo,

ich antworte immer gerne öffentlich, damit alle was davon haben, wobei mein Input zu dieser Sache leider verschwindend Gering ist.

An Deiner Gegenüberstellung siehst Du ja, wo Du am Comand ne Spannung angelegt hast ;) Da hast Dir wohl das Comand geschossen. Du schreibst ja aber auch, dass ein anderes Comand funktioniert. Das ist schon mal prima.

Gesteuert werden die Geräte im D2B Ring über C und D2B. C war ja nicht gesteckt (dafür die Heizung) und D2B ist ein Lichtwellenleiter, da passiert also auch nix.

Deshalbn habe ich die Vermutung, Dass Du Dir irgendwie die Codierung geschossen hast. Dein Auto ist also "ohne Radio" so meine Vermutung. Wahrscheinlich kannst Du auch jetzt wieder die Uhrzeit im KI einstellen oder?

Wenn dem so ist, dann in SD wieder die richtoige Ausstattung codieren. Weiß die Schritte leider nicht auswendig, ist zu lange her...

Vielleicht ein Lösungsansatz... Viel Erfolg!

Guter Ansatz, da werde ich gleich mal im KI nachschauen, wenn ich zuhause bin. Ausstattungen habe ich schon mal codiert, aus dem Kopf heraus weiß ich aber auch nicht mehr wie genau es geht. Werde mich heute Abend damit beschäftigen.

 

Sobald ich was genaueres weiß, werde ich Rückmeldung geben:)

 

 

 

Das Comand hat in der runden Diag-Dose einen anderen Steckplatz für die K-Leitung als das normale Radio. Hat die Diagnose am Comand jemals funktioniert? Ich musste beim Nachrüsten des Comands die Pins in der Diag-Dose umpinnen.

Themenstarteram 1. Mai 2021 um 0:55

Zitat:

@Head_on_Toast schrieb am 30. April 2021 um 22:36:33 Uhr:

Das Comand hat in der runden Diag-Dose einen anderen Steckplatz für die K-Leitung als das normale Radio. Hat die Diagnose am Comand jemals funktioniert? Ich musste beim Nachrüsten des Comands die Pins in der Diag-Dose umpinnen.

Comand ist auf Pin 34 in der OBD1 Dose. Habe es auch überprüft und Widerstand gemessen. Comand war in dem Fahrzeug seit Anfang an drin und SD hat auch sonst immer funktioniert.

Zum Testen kam ich heute leider nicht. Mir ist aber aufgefallen, dass die Schaltpläne aus der SD bzw. WIS teilweise vollkommen falsch sind. Okay, bei mir ergibt sich noch das Problem, dass ich einen Zwischenmopf habe. Ich muss also teilweise bei Vormopf oder Mopf schauen, egal ob ich nach meiner Fahrgestellnummer gehe - das bekommt die SD einfach nicht hin. Aber selbst dann werden teilweise ganz andere Leitungsfarben angegeben, was das Suchen echt schwierig macht. Selbst Pinbelegungen sind teilweise vollkommen anders.

Bspw. bei dem nachgerüsteten, originalen PDC. Da soll angeblich die K-Leitung laut Schaltplan auf Pin28 OBD1 gehen. Laut SD ist es aber Pin 14. Absolutes Durcheinander....:rolleyes:

Themenstarteram 16. Mai 2021 um 9:30

Zitat:

@hotw schrieb am 30. April 2021 um 11:59:25 Uhr:

Deshalb habe ich die Vermutung, Dass Du Dir irgendwie die Codierung geschossen hast. Dein Auto ist also "ohne Radio" so meine Vermutung. Wahrscheinlich kannst Du auch jetzt wieder die Uhrzeit im KI einstellen oder?

Wenn dem so ist, dann in SD wieder die richtoige Ausstattung codieren. Weiß die Schritte leider nicht auswendig, ist zu lange her...

Leider kam ich gestern erst wieder zum testen, weil das KI neue Leiterbahnen und Leuchtmittel bekommen hat. Die Uhrzeit lässt sich nicht im KI einstellen, aber diese Funktion lässt sich unabhängig vom Radio im KI separat per SD einstellen.

Zu dem Thema "Ausstattung codieren":

Mir ist eingefallen, dass ich sämtliche nachgerüstete Ausstattungen nie codieren musste. Zu den nachgerüsteten zahlen EDW, Memorysitze beidseitig usw., welche aber auch nicht direkt an OBD1 angeschlossen werden.

Aber auch nachgerüstete Ausstattungen, welche direkt an OBD1 angepinnt werden (PTS/PDC) funktionieren ohne ein "codieren" per SD und sind auslesbar.

Selbst wenn man eine D2B Komponente nachrüstet, funktioniert diese direkt (CD-Wechsler, Telefon, Linguatronic). Diese Geräte kann man direkt im Steuergerät Comand hinzufügen, was aber kein muss ist.

In SD gibt es ja die Funktion "Ausstattung hinzufügen nach Nachrüstung" (sinngemäßer Wortlaut), da komme ich aber nicht rein, weil meine SD ohne Onlinezugang ist.

Ich behaupte aber jetzt mal, dass ein "hinzufügen per SD" gar nicht notwendig ist, da (s.o.) PTS auch so funktioniert ohne das es speziell codiert wurde. Die SD liest ja direkt per K-Leitung die Steuergeräte aus und die des Comands ist bei mir intakt.

Auch der Canbus hat 120 Ohm und die Spannung stimmt auch für High und Low.

Somit kommen folgende Fragen/Thesen auf:

Es gibt Steuergeräte, die direkt per K-Leitung an OBD1 angeschlossen sind. Es gibt aber auch Steuergeräte, die keine K-Leitung haben wie das Sitzsteuergerät. Hier kann die Kommunikation ja nur über Canbus laufen. Letztere Steuergeräte müssen ja dann über einen zentralen Knotenpunkt laufen(ähnlich VAG mit dem Canbus-Steuergerät, bei MB gibt es ja nur den "manuellen" Verteiler im BF-Fußraum), welcher dann wiederum per K-Leitung an der OBD1 angeschlossen ist. Kann einer diese These bestätigen?

Beim Auslesen ist mir aufgefallen, dass ich auch nicht auf die Heizung zugreifen kann. Keine Ahnung, ob das überhaupt jemals ging :confused: (was soll es auch da zu prüfen geben, ist ja alles manuell).

Ich habe nur Heizung, keine Klima. In SD tauchen nur die Begriffe TAU (Temperaturautomatik) und KLA (Klimaautomatik) auf. Wäre aber die Heizung nicht abgekürzt mit HAU?

 

 

 

 

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Auto
  4. Mercedes
  5. CLK & E-Klasse-Coupé
  6. W208
  7. Kommunikation Comand mit StarDiagnose