ForumLupo
  1. Startseite
  2. Forum
  3. Auto
  4. Volkswagen
  5. Lupo
  6. ABS Steuergerät codieren

ABS Steuergerät codieren

VW Lupo 6X/6E
Themenstarteram 12. November 2017 um 10:02

Hallo zusammen,

mein Lupo (Typ AYZ) hat mittlerweile 372.000 km runter und hat nach Aufleuchten der ABS und Bremswarnlampe und mehrmaligem Piepen die Fahrbereitschaft eingestellt.

Da ich Zugriff auf ein megamacs42 Motortester habe, konnte ich rausbekommen, dass das ABS-Steuergerät (6E0907379B) defekt war.

Glücklicherweise hatte ich genauso ein Teil zur Verfügung und habe es eingebaut.

Der Lupo läuft wieder prima, aber jetzt leuchtet die ESP-Lampe durchgängig auf.

Als Fehlercode bekomme ich bei ABS:

Fehlercode 778 Lenkwinkelsensor Funktion fehlerhaft

und bei Motor:

Fehlercode 18057 CAN-Bus Antrieb Kommunikation mit ABS-Steuergerät fehlt

Meine Recherchen haben ergeben, dass nach Austausch des ABS-Steuergeräts ein Nullabgleich des Lenkwinkelsensors erfolgen muss. Das ist nicht so wild, aber vorher muss, soweit ich das im Augenblick überschaue, noch das Steuergerät codiert werden. Leider habe ich dafür keine Anleitung gefunden.

Meine Frage ist:

hat jemand das schon mal gemacht und kann beschreiben, wie das geht?

Tschüss

Walter

 

Ähnliche Themen
19 Antworten

Zitat:

@hanitux schrieb am 12. November 2017 um 10:02:36 Uhr:

...

Als Fehlercode bekomme ich bei ABS:

Fehlercode 778 Lenkwinkelsensor Funktion fehlerhaft

und bei Motor:

Fehlercode 18057 CAN-Bus Antrieb Kommunikation mit ABS-Steuergerät fehlt

Meine Recherchen haben ergeben, dass nach Austausch des ABS-Steuergeräts ein Nullabgleich des Lenkwinkelsensors erfolgen muss. Das ist nicht so wild, aber vorher muss, soweit ich das im Augenblick überschaue, noch das Steuergerät codiert werden. Leider habe ich dafür keine Anleitung gefunden.

Bei gleicher Teilenummer sollte m.E. auch die Codierung gleich sein.

Sonst müsste eigentlich der Fehlercode 1044 (Steuergerät Codierung fehlt/fehlerhaft) auftauchen.

Hallo,

wenn die Kommunikation mit dem CAN-Bus fehlt, wie die Fehlermeldung ja mitteilt, kann es auch eine Unterbrechung einer der Signal-Leitungen, CAN-high bzw. CAN-low sein.

Kann auch die K-Leitung sein. Es gibt viele Lupos welche in der Diagnose alle drei Leitungen benutzen. Steuergeräte werde über CAN ausgelesen, andere über die K-Leitung.

Die K-Leitung ist eine VAG-Spezifikation. Einige Lupos benutzen auch alle Leitungen. Kann man den Stromlaufplänen entnehmen. Dies kann auch zur Fehlermeldung - Steuergerät defekt - führen.

Schau alle Steckverbindungen in den Steckern und Buchsen nach.

Gruß Hans

Themenstarteram 13. November 2017 um 12:42

Hallo,

in dem Reperaturleitfaden, den ich mir zwischenzeitlich besorgt habe, steht, dass man das ABS-Steuergerät J104 codieren muss, wenn man ein neues Steuergerät aus dem Ersatzteilbereich eingebaut hat. Meins ist zwar gebraucht, aber die beiden Fehlermeldungen lassen doch vermuten, dass die Kommunikation zwischen dem Motor- und dem ABS-Steuergerät nicht in Ordnung ist. Außerdem ist für mich nachvollziehbar, dass der Geber für den Lenkwinkel (G85) neu justiert werden muss, wenn z.B. das ABS-Steuergerät ausgetauscht wird.

Leider steht in der VAG-Rep.anl. immer nur:

Fahrzeugdiagnose-, Meß- und Informationssystem VAS 5051 in der "Geführten Fehlersuche" durchführen.

Der Dialog bei meinem Motortester ist anders geführt. Wenn ich auf Codieren gehe, warnt er mich vorher, dass der Vorgang auf keinen Fall unterbrochen werden darf und über die Einstellung des Lenkwinkelsensors finde ich gar nichts. Irgendwie trau ich mich nicht weiter, da ich möglicherweise die Login- oder Codierung-Codes nicht kenne und alles nur noch schlimmer mache.

Die ABS-Hydraulikeinheit ist eine Mark 30 IE und hat anscheinend die Codierung 05623, wie ich irgendwo aufgeschnappt habe. Ob das bei mir stimmt, weiß ich nicht.

Tschüss

Walter

Hallo,

wie Du ebenfalls erkannt hast, ist eine Kommunikation mit dem CAN-Bus nicht möglich. Demzufolge wird das Steuergerät nicht erkannt, es ist nicht existent.

Ergo muss der Fehler in den Steuergeräten liegen oder aber in der Peripherie oder auch Spannungsversorgung etc.

Es kann aber je nach Motormodell, Baujahr und Ausstattung nur die K-Leitung als Diagnoseleitung vorhanden sein. Dann gibt's auch keine Verbindung, wenn nicht das richtige Protokoll verwendet wird.

Der AYZ hat sowohl die K-Leitung als auch Can-low und Can-high als Diagnoseleitungen zur Verfügung.

Wird das ABS-Steuergerät beim AYZ durch die Can-Leitungen oder die K-Leitung überwacht ?. Müsste ich noch nach sehen.

Ist beim Lupo häufiger anzutreffen, dass einige Steuergerät über die K-Leitung und andere über die Can-Leitungen überwacht werden. Wohl bemerkt in einem Fahrzeug.

Wenn die Kommunikation hergestellt ist, dann kann man erst weiter sehen. Ich vermute irgend wo eine Leitungsunterbrechung oder Spannungsausfall auf einer Leitung.

Es wäre die Frage: Hat das Fahrzeug Can-low und Can-high Ausgänge oder benutzt dieses Fahrzeug noch die K-Leitung mit dem VW-eigenen Protokoll KW1281 zur Überwachung ABS. Oder sogar beide. Es gibt VW-Protokolle ( KW2000 ) die sowohl die CAN-Leitungen als auch die K-Leitung benutzen. Hierzu ist aber noch eine bestimmte Hardware erforderlich.

Genau die Verdrahtung etc. kontrollieren. Die Sicherung SB15 ist ok ? Die Sicherung SB8 ebenfalls ? Der Bremslichtschalter ist ok und richtig eingestellt ? Die Sicherungen SA15 und SA16 sind in Ordnung.....sind Streifensicherungen im Batterie-Kasten auf der Batterie ( Zur Kontrolle, Kasten abbauen und rum drehen, dann sieht man sie )

Wenn der AYZ weitere Zusätze zur ABS wie, ESP, ADS und EDS hat kommen natürlich weitere Sicherungen hinzu.

Stelle zuerst sicher, dass das Diagnosegerät mit der Software und dem Diagnoseprotokoll kommunizieren kann.

Gruß Hans

Themenstarteram 13. November 2017 um 16:53

Hallo,

so, ich hab mir jetzt ein Herz gefasst und die Codierung des ABS-Steuergerätes durchgeführt. Hat alles gut geklappt und die CAN-Bus Fehlermeldung ist weg.

Jetzt nervt nur noch die noch nicht durchgeführte Justierung des Lenkwinkelsensors (Fehlercode 778).

Keine Ahnung, wie das mit meinem Gutmann-Tester geht. Ich hab alle Menüs durchgeschaut und finde einfach nichts.

Tschüss

Walter

Hallo Walter,

prima, dann hast Du ja ein Problem weniger. Bezüglich des Lenkwinkelsensors ( Geber ) kann Dir " talker1111" sicher weiter helfen.

Gruß Hans

Fehlercode 778 - Geber für Lenkwinkel - G85 - Ob das nun heißt das der Geber ausgefallen ist oder nur neu justiert werden muss ? Das weiß ganz sicher Jürgen, talker1111.

Die Anleitung im folgenden Video sollte auch für den Lupo klappen:

https://www.youtube.com/watch?v=Y-WzmhHH9G0

Folgende Codierung ist anzuwenden:

1. Steuergerät 03 wählen

2. Funktion 16 für Zugriffsberechtigung auswählen

3. Zugriffsberechtigungscode eingeben: 40168

4. Funktion 4 für Grundeinstellung

5. Kanal 60 Nullabgleich Geber für Lenkwinkel auswählen (G85)

6. EIN/AUS/WEITER klicken

7. Start klicken

8. Lenkrad gerade, mit 5 km/h kurz geradeaus fahren

9. Anhalten, Lenkrad ganz nach rechts und dann ganz nach links bewegen

 

 

Themenstarteram 14. November 2017 um 11:14

Hallo Hans und Jürgen,

vielen Dank für die tolle Unterstützung. Die Anleitung hatte ich schon gefunden. Leider ist die Justierung mit meinem alten Gutmann-Tester (mega macs 42) nicht möglich. Ohne Tester ist man mit dem Lupo 3L ja aufgeschmissen. Bis jetzt habe ich immer alles prima hinbekommen (Fehlerauslesen, Parameter, Getriebegrundeinstellung etc.) und sogar anscheinend die Codierung des ABS-Steuergerätes. Vielleicht müsste man mal ein Update machen, jedenfalls finde ich unter Grundeinstellung nichts zum Abgleich des Lenkwinkelsensors.

Weil ich jetzt keine Lust habe, mir das VCDS-System anzuschaffen, werde ich die Einstellung machen lassen. Bin mal gespannt, was die freie Werkstatt meines Vertrauens dafür nimmt. Bei VW soll die Prozedur anscheinend ca. 55 € kosten.

Zitat:

@hanitux schrieb am 13. November 2017 um 16:53:28 Uhr:

...

ich hab mir jetzt ein Herz gefasst und die Codierung des ABS-Steuergerätes durchgeführt. Hat alles gut geklappt und die CAN-Bus Fehlermeldung ist weg.

..

Hallo Walter,

hat das mit der Codierung 05623 denn geklappt oder welche musstest Du eingeben ?

Themenstarteram 14. November 2017 um 12:56

die Codierung stand auf 10771 und unten drunter stand Werkstattcodierung 11111.

Dann habe ich selber gar nichts eingegeben und auf weiter gedrückt und das wars.

Ich vermute mal, dass die Trennung des ABS-Steckers schon reicht, um die Kommunikation über den CAN-Bus zu unterbrechen. Und dann muss wieder neu codiert werden.

Schlimm waren vorher die ganzen Warnhinweise ungefähr wie bei einer Narkosebelehrung, wenn man operiert werden muss. Wenn man bedenkt, dass die ABS-Pumpe selbständig Druck aufbaut und die Hinterräder abbremsen kann, wenn das ESP denkt, dass das sinnvoll ist...

Macht schon Sinn, dass da nicht jeder Hobbybastler planlos dran rumfummeln kann ohne auf die Risiken hingewiesen worden zu sein. Naja hat ja anscheinend geklappt.

Themenstarteram 22. November 2017 um 12:56

Hallo,

so ein Mist, die freie Werkstatt konnte mit dem ihr zur Verfügung stehendem Tester auch nichts finden, um bei dem Lupo 3L den Lenkwinkelsensor zu justieren. Da es anscheinend nur in einer Vertragswerkstatt oder mit dem VCDS-System geht, werde ich jetzt erst mal versuchen, es selber hinzubekommen.

Tschüss

Walter

Themenstarteram 23. November 2017 um 13:26

Hallo,

so jetzt hab ich mir die aktuelle VCDS-Version 17.8 und einen paassenden ODB2-Stecker besorgt und siehe da, mit dem alten Laptop meiner Tochter und den Infos von Jürgen konnte ich den Lenkwinkel einstellen und jetzt ist die gelbe ESP-Warnlampe aus.

Was will man mehr. Schönen Dank noch mal für die prima Unterstützung und

Tschüss

Walter

Hallo, ich habe auch das Problem mit dem Fehler 778. Er kam nach wechseln des Wischerschalters. Muss der Fehler vor dem Kalibrieren gelöscht werden? Das klappt bei mir nicht. Ich war schon in zwei Werkstätten, die sagen der G85 muss neu.

Dann schau doch erstmal, was im MWB 004 Feld 1 vom ABS-Steuergerät bei Geradeausstellung für ein Wert steht.

Wenn da nicht 0° sondern 360° steht, hast Du den Sensor falsch aufgesetzt. Evtl. stand das Lenkrad nach dem Ersetzen des Wischerschalters um eine Umdrehung nach links oder rechts.

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Auto
  4. Volkswagen
  5. Lupo
  6. ABS Steuergerät codieren