ForumVectra B
  1. Startseite
  2. Forum
  3. Auto
  4. Opel
  5. Vectra
  6. Vectra B
  7. Automatik Steuergerät kaputt? Was tun?

Automatik Steuergerät kaputt? Was tun?

Opel Vectra B

Liebes Forum,

ich habe folgendes Problem mit meinem Vectra B Caravan, BJ 2000, 2.2 147 PS (Z22SE) Automatik, ca. 185.000 km gelaufen:

Vorgeschichte: Das Auto hat vor 2 Wochen neuen TÜV bekommen, dafür musste aber Mittel- und Endschalldämpfer erneuert werden sowie eine Rostsanierung an Teilen der Längsträger vorgenommen werden. Hat zusammen knapp vierstellig gekostet, aber das Auto ist aus der Familie, sauber und sehr gut ausgestattet, so dass ich ihn eigentlich gerne weiter fahren möchte. Hat zudem die perfekte Größe und Übersichtlichkeit :-)

Eine Woche nach dem TÜV hatte ich morgens nach dem Losfahren plötzlich kaum Leistung. Es leuchteten die TC und Motorelektronik (Auto mit Schraubenschlüssel)-Lampen. Mittags habe ich das Auto dann zur Werkstatt gebracht, da leuchtete nur noch die Motorelektronik-Lampe. Leistung war wieder (fast?) normal. Ist seitdem so geblieben.

Ergebnis bei der Werkstatt - Fehlerspeicher:

GMPT-E 2

P0700 Getriebe Steuersystem

P1700 Getriebe Steuersystem

ABS/ASR 5.3

4260 CAN-Botschaft Getriebe-Steuergerät Keine Kommunikation

Laut Werkstatt ist es damit ein Problem mit dem Getriebe-Steuergerät, das wohl bekannt ist (u.a. von früheren Polizeiautos). Könnte nur eine Opel-Vertragswerkstatt tauschen bzw. jedenfalls könnte nur die ein neues Steuergerät anlernen.

Die beiden Opel-Autohäuser hier im Umkreis bieten mir jeweils nur einen Termin im Januar und haben vorsorglich schon mehrfach den Begriff "wirtschaftlicher Totalschaden" fallen gelassen.

Ich habe zu dem Problem in Forum und Internet leider nichts gefunden. Meine Frage wäre: Kennt das Problem jemand? Ist es vielleicht eine Kleinigkeit oder gibt es zumindest denkbare Ursachen, die man selbst beheben könnte und es damit mal probieren? Kann es irgendetwas mit der Reparatur des Auspuffs oder den Schweißarbeiten zu tun haben (Werkstatt hat natürlich Spannungsschutz verwendet)? Gibt es Werkstätten, die auf sowas spezialisiert sind und mir evtl. das Steuergerät reparieren? Und zuletzt - kann ich damit evtl. einfach weiterfahren, solange die Leistung stimmt?

Viele Dank für jegliche Hinweise oder Hilfe

MB-Tex

Ähnliche Themen
23 Antworten

AGR reinigen und vielleicht das Getrieböl wechseln....Lambasonde in Ordnung???

Ich habe schon an vielen Fahrzeugen im LKW + PKW Bereich gebrutzelt, nur selten die Batterien abgeklemmt und noch nie einen Spannungsschutz oder so genutzt. Unter anderem auch an 2 Vectra B und gejuckt hat es keinen.

Auf deinem Steuergerät ist eine Nummer und mit dieser würde ich mich an eine der darauf spezialisierten Firmen wenden. Die findest am einfachsten per Google, oder auch hier im Forum. Dort kannst dann nach den Preisen fragen und für dich beantworten, ob es sich (für dich) noch rechnet. Eventuell findest du auch im Netz ein brauchbares gebrauchtes Steuergerät und kannst es dir von deinem FOH anlernen lassen.

Falls das Auto relativ normal läuft und nur der Schraubenschlüssel leuchtet, solltest du ohne Probleme fahren können.

Wurde dein Steuergeräte Stecker kontrolliert? Wenn der, warum auch immer, korrodiert ist, kannst STRG wechseln wie du willst.

Bei einem Termin in ca 3 Wochen solltest eventuell eine etwas längere Anfahrt zu einem weiter entfernten FOH in Erwägung ziehen.

Es muss auch keiner mit Glaspalast sein.

 

@ Herby

Zitat:

4260 CAN-Botschaft Getriebe-Steuergerät Keine Kommunikation

Hast du das nicht gelesen?

Hier hilft weder ein AGR reinigen, noch 1000 Liter Öl etwas.;)

Zitat:

@herby01011 schrieb am 10. Dezember 2017 um 14:17:59 Uhr:

AGR reinigen und vielleicht das Getrieböl wechseln....Lambasonde in Ordnung???

Vielen Dank für die Antwort! Das sind ja beides Sachen, die im weitesten Sinn mit dem Abgassystem zu tun haben. Wegen des Auftretens einige Tage nach dem neuen Auspuff (Mittel- und Endtopf) hatte ich auch überlegt, ob es damit etwas zu tun haben kann. Es ergibt sich aber nicht direkt aus den Fehlercodes oder? Darf ich fragen, ob das eine allgemeine Empfehlung aufgrund des beschriebenen Problems (zunächst Leistungsverlust ist) oder ob ein Problem mit dem Abgassystem sich auf die Automatikgetriebe-Steuerung auswirken und die genannten Fehlercodes produzieren kann?

Ganz herzlichen Dank für die ausführlichen Hinweise auch Dir! Ich verstehe Dich so, dass der Fehler "4260 CAN-Botschaft Getriebe-Steuergerät Keine Kommunikation" unmittelbar mit dem Steuergerät selbst zu tun haben muss und nicht sozusagen von der "Peripherie" (vom Stecker mal abgesehen) ausgelöst werden kann, richtig?

Dann würde ich jetzt zunächst den Stecker testen und dann wie vorgeschlagen im Internet jemanden suchen, der das Steuergerät selbst reparieren kann. Vielleicht frage ich vorab beim FOH nochmal nach den Kosten, aber die schienen mir nicht sehr interessiert und sprachen wie gesagt schon vom wirtschaftlichen Totalschaden.

Zitat:

@schrotti_999 schrieb am 10. Dezember 2017 um 16:23:33 Uhr:

Ich habe schon an vielen Fahrzeugen im LKW + PKW Bereich gebrutzelt, nur selten die Batterien abgeklemmt und noch nie einen Spannungsschutz oder so genutzt. Unter anderem auch an 2 Vectra B und gejuckt hat es keinen.

Auf deinem Steuergerät ist eine Nummer und mit dieser würde ich mich an eine der darauf spezialisierten Firmen wenden. Die findest am einfachsten per Google, oder auch hier im Forum. Dort kannst dann nach den Preisen fragen und für dich beantworten, ob es sich (für dich) noch rechnet. Eventuell findest du auch im Netz ein brauchbares gebrauchtes Steuergerät und kannst es dir von deinem FOH anlernen lassen.

Falls das Auto relativ normal läuft und nur der Schraubenschlüssel leuchtet, solltest du ohne Probleme fahren können.

Wurde dein Steuergeräte Stecker kontrolliert? Wenn der, warum auch immer, korrodiert ist, kannst STRG wechseln wie du willst.

Bei einem Termin in ca 3 Wochen solltest eventuell eine etwas längere Anfahrt zu einem weiter entfernten FOH in Erwägung ziehen.

Es muss auch keiner mit Glaspalast sein.

 

@ Herby

Zitat:

@schrotti_999 schrieb am 10. Dezember 2017 um 16:23:33 Uhr:

Zitat:

4260 CAN-Botschaft Getriebe-Steuergerät Keine Kommunikation

Hast du das nicht gelesen?

Hier hilft weder ein AGR reinigen, noch 1000 Liter Öl etwas.;)

Zitat:

@MB-Tex schrieb am 10. Dezember 2017 um 20:09:21 Uhr:

Ich verstehe Dich so, dass der Fehler "4260 CAN-Botschaft Getriebe-Steuergerät Keine Kommunikation" unmittelbar mit dem Steuergerät selbst zu tun haben muss und nicht sozusagen von der "Peripherie" (vom Stecker mal abgesehen) ausgelöst werden kann, richtig?

Die Stecker sind generell in Verdacht, aber die sind ja schnell überprüft. Selbstverständlich könnte es auch ein Kabel sein, aber da diese in dem Bereich nur höchstselten streiken, würde ich mich damit nicht aufhalten.

Zitat:

Vielleicht frage ich vorab beim FOH nochmal nach den Kosten, aber die schienen mir nicht sehr interessiert und sprachen wie gesagt schon vom wirtschaftlichen Totalschaden.

Die Reparatur wird der FOH kaum organisieren, da er dabei nix verdienen kann, also kannst du dir die Frage danach eigentlich sparen. Ein neues STRG kommt viel zu teuer und diesbezüglich hat der FOH absolut Recht mit dem wirtschaftlichen Totalschaden.

Mittags habe ich das Auto dann zur Werkstatt gebracht, da leuchtete nur noch die Motorelektronik-Lampe. Leistung war wieder (fast?) normal. Ist seitdem so geblieben.

 

 

Also...ist das auslesen auch nicht das wahre...Ich hatte ja das gleiche Problem und die Werkstatt wollte das Steuergerät erneuern...LEUTE...denkt doch mal mechanisch....

Die Fehlermeldungen sind eine Sache,der Fehler selbst eine andere...wenn 5 kaputt ist,zeigt das auslesen 1-2-3-4-5-kaputt an...stimmt aber nicht...bei mir hatte ich das gleiche Problem und hatte beim Vecci das AGR gereinigt und die Lambasonde getauscht...und...

kein Fehler mehr und alle Lampen aus..die Mechatronic zeigt mehr fehler an als es in wirklichkeit ist.

Meine Meinung...und mit 64 Jahren rede ich aus Erfahrung.Auslesen gut und schön,doch Fehlermeldung...??????

LG

Hallo. Meine Ehrfahrung mit solchen Fehlern gerade in verbindung mit dem Abs Block Fehlern ist. Du solltest den Abs block tauschen.

Warum? Ich hab auch erst mit den anderen Teilen bekonnen( Steuergerät, Sensoren, Magnetventile etc.) keine besserung.

Die Ursache war der verschlissene Abs-Block der dann über die Steuergeräte die Motorleistung drosselte. Ich hatte Glück und konnte für viel Geld einen neuen Block kaufen und seit dem zieht er wieder frisch durch.

Bevor Du nun ein neuen Block kaufst, Stelle sicher, dass Stecker verkabelung und alles was drann hängt, Kontakt hat. oft waren es nur offene Kontakte.

Viel Glück und gedult. Aber es lohnt sich ....

Und nicht schrotten vor verzweiflung, ich kauf den sonst und stell den erstmal weg. Meiner Meinung nach sind das Tolle Autos :-)

Liest denn keiner den Eröffnungspost? :confused:

Das stünde TC + Motorelektronik Leuchte und danach noch die Fehler.

So mies sind dann die Fehlerprogramme auch wieder nicht, daß bei einem ABS Fehler ( der eine eigene Warnlampe hätte) die MKL brennt. Dazu kommen die Fehler für Getriebe, bzw CAN Bus.

Also lasst mal das ABS in Ruhe, denn dem fehlt hier ja nix!

@ TE

Dein Fahrzeugprofil ist mal wieder leer, oder zumindest der berühmte Haken nicht gesetzt.

Handelt es sich um einen Kombi? Denn die Kabelprobleme zur Heckklappe sind für alle Fehler gut.

Themenstarteram 12. Dezember 2017 um 9:42

Guten Morgen allerseits und noch einmal vielen Dank für alle Antworten.

@ schrotti_999: Ja, ist ein Kombi und die Heckklappe ist auch in regem Gebrauch, da der Wagen nicht nur (fast) täglich fährt, sondern auch als "Kinderwagengarage" herhalten muss. Kann es daran liegen (gehen da nicht nur die Kabel für die Beleuchtung durch?)?

Die TC-Lampe ist wie gesagt nach einem halben Tag wieder ausgegangen und die Motorleistung ist seitdem auch wieder normal. Die Lampe für Motorelektronik leuchtet halt weiterhin. Die o.g. Fehlercodes wurden ausgelesen, nachdem die TC-Lampe wieder aus war. Ich frage mich also auch, ob ich mit dem Wagen einfach weiterfahren kann. In einem anderen Thread habe ich gelesen, bei leuchtender Motorelektronik-Lampe würde ein anderes Gemisch eingespritzt und das würde den Kat gefährden. Stimmt das so generell, auch wenn der Motor scheinbar normal läuft?

Insgesamt sind das nun ziemlich viele verschiedene Vorschläge und ich überlege, womit ich anfangen soll:

1. Ich verschaffe mir Zugang zum Getriebe-Steuergerät, schaue mir die Steckverbindung an, reinige ggf. (womit eigentlich - alte Zahnbürste und Kontaktspray?) und gucke, was passiert. Ich muss dazu sagen, dass ich eigentlich kein Autobastler bin. Ich kann aber mit Werkzeug umgehen und bin auch z.B. in der Lage, elektronische Bauteile auszutauschen bzw. zu löten. Ich habe mir auch dieses 4000-Seiten Werkstatthandbuch-PDF, so dass ich zumindest rausfinden müsste, wo die Teile überhaupt sind und wie ich sie ggf. ausbaue. Habe allerdings keine Garage und komme nicht unters Auto ...

2. Wenn 1. nichts ändert: Beim ABS-Steuergerät ebenfalls die Kontakte prüfen?

3. Dann: AGR-Ventil reinigen? Hat das echt Einfluss auf das Getriebe-Steuergerät? Wie gesagt, Abgasanlage ab Mittelschalldämpfer wurde eine Woche vorher erneuert, daher ist es zumindest nicht ausgeschlossen, dass in dem Bereich irgendetwas ausgelöst wurde.

4. Sonst doch mal zu Opel fahren und schauen, ob die mir irgendwie weiterhelfen können, ohne dass es vielstellig wird?

Danke und Gruß

MB-Tex

4. Sonst doch mal zu Opel fahren und schauen, ob die mir irgendwie weiterhelfen können, ohne dass es vielstellig wird?

 

Danke und Gruß

MB-Tex

 

Dann lieber eine freihe Werkstatt.....Opel-Häuser sind meist zu teuer und außer auslesen können die garnichts.Versuche mal unsere Vorschläge,die nix kosten oder nur sehr wenig....das kanste alles selber machen

lg

Zitat:

@MB-Tex schrieb am 12. Dezember 2017 um 09:42:10 Uhr:

Ja, ist ein Kombi und die Heckklappe ist auch in regem Gebrauch, . . . . Kann es daran liegen (gehen da nicht nur die Kabel für die Beleuchtung durch?)?

Ja und ja.

Vor allem beim Kombi machen immer wieder die Kabel in BEIDEN Kabeldurchführungen Probleme. Also Gummidinger abziehen und die Kabel auf Bruchstellen und/oder blanke Kabel kontrollieren, denn wenn es dort zu Berührungen kommt, fängt die komplette Elektronik zum Spinnen an.

Zitat:

Die Lampe für Motorelektronik leuchtet halt weiterhin. . . . Ich frage mich also auch, ob ich mit dem Wagen einfach weiterfahren kann. In einem anderen Thread habe ich gelesen, bei leuchtender Motorelektronik-Lampe würde ein anderes Gemisch eingespritzt und das würde den Kat gefährden. Stimmt das so generell, auch wenn der Motor scheinbar normal läuft?

Ich bin ca 2 Wochen mit dem gelben "Mistvieh" gefahren und passiert ist nix. Meines Wissens ist beim Vectra im Normalfall (so wie bei dir) nur die Drehzahl begrenzt.

Zitat:

Insgesamt sind das nun ziemlich viele verschiedene Vorschläge und ich überlege, womit ich anfangen soll:

1. Kabel zur Heckklappe

2. Stecker Steuergerät UND generelle Kontrolle der Kabel im Motorraum. Es gab zwischendrin immer wieder Vectras die massive Kabelprobleme hatten. Ich hatte diesbezüglich Null Ärger. Auch nicht beim Kombi.

3. Steuergerät ausbauen und einschicken. Vorher würde ich das wiewas ect. mit der reparierenden Firma abklären.

Zitat:

Wenn 1. nichts ändert: Beim ABS-Steuergerät ebenfalls die Kontakte prüfen?

Du kannst dir ja auch eine neue Batterie kaufen. Das wäre genauso sinnvoll. :confused:

Zitat:

AGR-Ventil reinigen?

Wenn du es unbedingt reinigen willst. Bei mir hat das nix gebracht und es musste NEU. Allerdings hatte ich die passenden FC´s.

Zitat:

Hat das echt Einfluss auf das Getriebe-Steuergerät?

In etwa soviel wie neue Reifen. Also definitiv Nein.

Zitat:

Wie gesagt, Abgasanlage ab Mittelschalldämpfer wurde eine Woche vorher erneuert, daher ist es zumindest nicht ausgeschlossen, dass in dem Bereich irgendetwas ausgelöst wurde.

Das einzige was halbwegs in der Nähe des Auspuffs ist, wäre die Lambdasonde. Die hätte allerdings auch wieder einen eigenen Fehlercode.

Zitat:

4. Sonst doch mal zu Opel fahren und . . . .

Da warst du doch schon und kennst deren Diagnose. :rolleyes:

Und nun ist gut mit Theorie. An die Arbeit Amigo. ;)

 

@ Herby:

Er hat einen FC vom Getriebesteuergerät. Eine Freie ist da schnell mit ihrem Latein am Ende.

Liebe Leute,

ich habe heute morgen endlich Zeit gefunden, Eure Ratschläge (teilweise) umzusetzen. Ergebnis:

1. Die Kabel in der Durchführung an der Heckklappe links sind gebrochen (bzw. die Ummantelung). Siehe Bild. Auf der rechten Seite ist bei mir nur ein dickeres Kabel (schwarz ummantelt) durchgeführt, das äußerlich unbeschädigt ist. Also linke Seite auf Verdacht tauchen?

2. Beim Abklemmen der Batterie ist mir aufgefallen, dass auf dem Automatikgetriebe etwas Flüssigkeit steht, siehe Bild. Hat viel geregnet letzte Nacht, aber ist das normal?

3. Ich komme ans Steuergerät nicht ran bzw. weiß auch gar nicht genau, wo das sitzt. Laut Anleitung (Euroservice Werkstatthandbuch Vectra B) soll ich den Handschuhkasten und die Fußraumverkleidung rechts ausbauen, um da ranzukommen. Handschuhkasten war kein Problem (4 Schrauben). Frage: Was ist die Fußraumverkleidung? Ausbau geht angeblich mit 3 Clipsen. Die Mittelkonsole hat 3 Clipse auf der Beifahrerseite und darunter 3 Schrauben, geht dann aber noch längst nicht ab. Ich vermute, da muss vorher noch was anderes ausgebaut werden. Sagt mir die Anleitung aber nichts zu. Daher: Kann mir jemand sagen, was der einfachste Weg ist, an das Getriebe-Steuergerät ranzukommen?

Vielen Dank und schönen Sonntag!

MB-Tex

Img-20171217-105355
Img-20171217-104715
Img-20171217-105311

So wie ich dein Foto interpretiere sind deine Kabel in Ordnung und nur die Isolierung ist im Eimer.

Wenn das so ist, würde ich nur Nachisolieren. Das ist zwar fummelig und hält nicht ewig, aber ein Austausch wäre wohl entweder teuer, oder kaum noch neu zu bekommen.

Aus der Reparaturanleitung hab ich den Ort des Getriebe STG auch nicht ganz herausgefunden und zur Innenverkleidung hab ich nur folgendes Klick gefunden.

Flüssigkeit (Wasser) auf dem Getriebe sollte uninteressant sein. Noch dazu bei dem momentanen Wetter. :(

Zitat:

 

Aus der Reparaturanleitung hab ich den Ort des Getriebe STG auch nicht ganz herausgefunden und zur Innenverkleidung hab ich nur folgendes Klick gefunden.

Ne, das ist die A-Säule, auf Fahrerseite. Ich muss hinter die Fußraumverkleidung auf Beifahrerseite, ich vermute also innen links wenn man auf dem Beifahrersitz sitzt. Das Problem ist, dass das Teil in die Mittelkonsole übergeht, die sich bis ganz nach hinten durchzieht.

Sehr seltsam, dass das in der Anleitung nicht erklärt wird. Ich finde im Internet auch kein Bild von dem Steuergerät in eingebautem Zustand.

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Auto
  4. Opel
  5. Vectra
  6. Vectra B
  7. Automatik Steuergerät kaputt? Was tun?