ForumToyota
  1. Startseite
  2. Forum
  3. Auto
  4. Toyota
  5. Toyota Previa Frage

Toyota Previa Frage

Themenstarteram 8. Febuar 2008 um 10:31

Hallo zusammen, seit geraumer Zeit hab ich in meinem Toyota Previa (7-Sitzer/Baujahr 2001) vorne die Motorkontrollleute an.

Nach dem Werkstattbesuch war ich um eine Info reicher. Hinten rechts war der ABS Sensor defekt und wurde durch einen Bekannten vor meiner Haustür kurzer Hand getauscht. Der Bekannte ist KFZ Meister und vom Fach. Nun sagt dieser das man die Anzeige nullen bzw. auch dirket updaten kann wenn es dafür ein Update gibt und dann die Anzeige zurücksetzen oder Nullen muß damit das Licht verschwindet.

Der Haken ist nun das das Update oder Nullen jede Menge Geld kosten soll was ich nicht ganz nachvollziehen kann. Diese Software wird doch aus dem Intranet der Firma runtergeladen und uber den Universellen Anschluss seit Januar 2001 überall in den Autos vorhanden aufgespielt, oder?

Was soll daran so teuer sein? Kann man das auch selbst machen?

Universelle Software die entsprechende Funktionalitäten haben soll hab ich schon gesehen.

Einen PC kann man besorgen. Den Adapter eventuell kaufen. Dann sollte es ja gehen, oder?

Da ich aus dem Berufszweig der Informatik bin hab ich keine Problem mit der Technik sondern mit der Preisvorstellung seiten´s Toyota.

Hat da einer Infos, Anleitungen, Fotos und /oder andere nützliche Informationen in Schrift und Bild damit ich auch morhen noch beruhigt in meinem Toyota sitzen kann?

Gruß - inkaman

Ähnliche Themen
35 Antworten

Kenne den Previa nicht im Detail, aber generell geht's um den OBD2 Standard. Dabei ist zu beachten, dass sich aus dem Standard nur Mindestanforderungen ergeben. Eine bestimmte Anzahl an emissionsrelevanten Parametern muss überwacht und über eine spezifierte Schnittstelle ausgelesen werden können. Bei allem, was darüber hinausgeht, haben die Hersteller völlig freie Hand, können also ohne weiteres proprietäre Fehlercodes oder Protokolle, und tun das auch.

Vermuten würde ich, dass univ. OBD2 Software nicht mit Toyota ABS Steuergeräten spricht.

Themenstarteram 8. Febuar 2008 um 11:06

Hallo, danke für die Info.

1. Das würde ja bedeuten das der ABS Sensor nicht die rote Kontrollleuchte ausgelöst hat?!

2. Desweiteren hab ich jetzt herausgehört das man das theoretisch versuchen kann, aber aufgrund der je nach Hersteller eingestellten Spezifikationen die durch so eine Software nicht berücksichtigt werden kann die Gefahr besteht mir eher Schaden zuzufügen?

Gruß - inkaman

1. Hm, wie kommst du darauf?

2. Schäden würde ich für unwahrscheinlich halten. In der Regel ist es so, dass univ. OBD2 Soft halt nur die vorgeschriebenen abgasrelevanten Fehlercodes kennt (Katüberwachung usw.). Bei allem was darüber hinausgeht (Klimaanlage, ABS, Airbags etc.), kann halt jeder Hersteller sein eigenes Süppchen kochen. Es gibt zwar von Drittanbietern auch Software und Geräte, die diese herstellerspezifischen Sachen teilweise beherrschen, aber da da normalerweise Lizenzgebühren oder eine Menge reverse engineering hinter steckt, wird man da kostenlos wahrscheinlich wenig finden.

 

Mal ganz davon abgesehen...hast du mal probiert, die Batterie 5 Minuten abzuklemmen? (Radio-Code nicht vergessen, falls vorhanden)

Themenstarteram 8. Febuar 2008 um 12:33

1. Habe Deinen letzten Satz falsch interpretiert!

2. Software hab ich gelesen gibt es zum zurücksetzen auch für den Toyota. Nennt sich "Version 2.0 MoDIAG express für alle AGV-Interface ". Ist Freeware.

Der Tipp mit der Batterie ist ein Versuch wert. Werde das so bald ich kann ausprobieren!

Anbei ein Foto von meinem Previa. (rechts oben) :-)

 

Gruß - inkaman

Themenstarteram 18. Febuar 2008 um 8:45

Ich bin jetzt zum Händler gefahren und der hat mittels dem passenden Diagnosegerät herausgelesen das was mit dem Kat oder der Lambdasonde nicht ok wäre. Zunächst hat er aber auch ein Softwareupdate für 80 Euro vorgeschlagen. Damit könnte schon der Fehler behoben sein. Quasi ein Update wie bei Windoof ... hm wer aber sagt mir das da auch neue Software hochgeladen wird und der mich net verarscht um mal eben ein wenig Kohle zu machen. Er meinte nämlich auch das wenn es das nicht bringt einer Reperatur von mindestens 250 Euro und höher ansteht.

Ich soll übrigens den Wagen am Vortag abends bei Ihm hinstellen damit der auskühlt. Aber der wird den Wagen doch net in die Garage schieben, oder?

Hat man Chanchen sich so ein Softwareupdate anzugucken? Muß der Wagen zwingend kalt sein? Wird der Board Chip einfach ausgebaut und extern beschrieben? Wie läuft so ein Update eigendlich ab?

Alles Fragen die mich doch mal interessieren.

Hallo

kann mir nicht vorstellen das auf einmal ein Software update bei diesem (etwas älteren )Modell bewirken soll...ich tippe auf Lambdasonde oder Luftmengenmesser;)

den Fehlercode auszulesen muss aber kein Fehler sein

Fehlercodes Toyota und hier auch mal reinsehen

 

mfg Andy

Zitat:

Original geschrieben von inkaman

Ich bin jetzt zum Händler gefahren und der hat mittels dem passenden Diagnosegerät herausgelesen das was mit dem Kat oder der Lambdasonde nicht ok wäre. Zunächst hat er aber auch ein Softwareupdate für 80 Euro vorgeschlagen.

Weisst du zufällig, welcher Fehler das genau war? Im Grunde genommen könnte ich mir nur vorstellen, dass ein SW Update was bringt, falls der Previa zwei Lambdasonden hat und man mit dem Update die zulässigen Grenzen der zweiten Sonde (die den Kat überwacht) erweitert. Das setzt natürlich voraus, dass die Nach-Kat Sonde den Fehler verursacht hat.

Für die Sache mit dem kalten Motor gibt's zwei mögliche Erklärungen: Erstens werden die Lambdasonden erst dann vom Steuergerät ausgewertet sobald der Motor Betriebstemp erreicht hat, weil der Kat vorher keine Funktion hat. Vielleicht will man da einen kompletten Aufwärmzyklus fahren um das zu testen. Zweitens verbrennt man sich an Kat/Lambdasonde die Finger wenn das Auto vorher gefahren wurde. ;)

Was den Inhalt/Ablauf des Updates angeht, in der Regel hat der Händler Unterlagen zu den Änderungen und eingespielt wird's über den Diagnosestecker. Kein Hersteller würde einen Händler im Steuergerät rumlöten lassen.

Zitat:

Original geschrieben von inkaman

 

1. Das würde ja bedeuten das der ABS Sensor nicht die rote Kontrollleuchte ausgelöst hat?!

Hallo, du hast im ersten post von einer Motorkontrollleuchte geschrieben. Diese ist aber nicht rot sondern gelb.

Also, was genau zeigt er denn an?

Und lass dich nicht verarschen. Ich kann mir nähmlich nicht vorstellen, dass so ein update bei einem defekt hilft.

Themenstarteram 18. Febuar 2008 um 15:53

Die Leuchte die in der Anzeigetafel an war (weil die ja nach dem Auslesen genullt wurde) hatte einen Motor als Zeichen und war eine Mischung aus orange und gelb. Haut mich nicht ich kanns net mehr genau sagen. Ihr habt mich verunsichert. Man oh man Wochenlang guckt man da drauf und dann ist die 2 Tage aus und man weiß die Farbe nicht mehr. Tsss..... wie auch immer es war auf jeden Fall ein Motor als Symbol zu sehen.

Über die zwei Fehlernummern weiß ich leider nix. Der Werkstattfutzi hat die auslesen lassen, mir gesagt was die laut Diagnosegerät wohl bedeuten würden und hat die Nr´n dem Meister weitergegeben. Der hat dann gemeint das wir um es nicht gleich zu teuer zu machen es erst mal mit einem Softwareupdate versuchen sollten. Falls das nicht hilft wären halt weitere Maßnahmen nötig die allerdings wesenrtlich teurer werden würden.

Na mal gucken. Ich lass erst mal das Update machen und dann gucken wir weiter.

 

 

Themenstarteram 18. Febuar 2008 um 15:57

Zitat:

Original geschrieben von baloo

Zitat:

Original geschrieben von inkaman

Ich bin jetzt zum Händler gefahren und der hat mittels dem passenden Diagnosegerät herausgelesen das was mit dem Kat oder der Lambdasonde nicht ok wäre. Zunächst hat er aber auch ein Softwareupdate für 80 Euro vorgeschlagen.

Weisst du zufällig, welcher Fehler das genau war? Im Grunde genommen könnte ich mir nur vorstellen, dass ein SW Update was bringt, falls der Previa zwei Lambdasonden hat und man mit dem Update die zulässigen Grenzen der zweiten Sonde (die den Kat überwacht) erweitert. Das setzt natürlich voraus, dass die Nach-Kat Sonde den Fehler verursacht hat.

Für die Sache mit dem kalten Motor gibt's zwei mögliche Erklärungen: Erstens werden die Lambdasonden erst dann vom Steuergerät ausgewertet sobald der Motor Betriebstemp erreicht hat, weil der Kat vorher keine Funktion hat. Vielleicht will man da einen kompletten Aufwärmzyklus fahren um das zu testen. Zweitens verbrennt man sich an Kat/Lambdasonde die Finger wenn das Auto vorher gefahren wurde. ;)

Was den Inhalt/Ablauf des Updates angeht, in der Regel hat der Händler Unterlagen zu den Änderungen und eingespielt wird's über den Diagnosestecker. Kein Hersteller würde einen Händler im Steuergerät rumlöten lassen.

Ob der Wagen zwei Lambdasonden hat weiß ich nicht. Müßte das mal erfragen. Die Fehlercode´s fingen glaube ich mit ner "9" am Anfang an. Genau weiß ich das aber nicht mehr.

Gruß - inkaman

hallo,

habe den selben fehler- (motorbock orange) wird angezeigt. habe schon ne neue lambdasonde ( previa hat 2)-neue software. mal ist die anzeige einen sehr langen zeitraum aus, mal einen kuerzeren. spar dir dein geld beider werkstatt und... fehler auslesen. bei mir geht meist bei längeren fahrten- so ab 200-300 km - an

von diesem fehler höhrt man oft.

einfach kurz batterie abklemmen und wieder anschliessen- und schon hat es sich.

die anzeige geht auch schon mal von alleine wieder aus- aber wann ? weiss niemand.

da ist irgendwo in der gesamten elektronik evtl. etwas korridiert ( gibt es ja auch bei

wischwasseranzeige..... usw. usw. )

habe jetzt 130 tsd. drauf, werde mir nun neue zündkerzen einbauen-vielleicht, wer weiss? ist es weg ?

also- spar die den weg zur werkstatt - zumal die jetzt euro-preise nehmen, wie frueher in dm.

Themenstarteram 2. März 2008 um 19:00

Hallo, danke für den Tipp, allerdings ist es schon passiert und ich habe bisher Ruhe gehabt.

Das ganze hat 76 Euro gekostet. Wie auch immer ich hoffe ich hab jetzt Ruhe davor.

Gruß - inkaman

Hallo,

habe das gleiche Problem mit dem Motor-Leuchte.

Geht nie von allein weg. Nach kurzem Batterie ab- un an-schliessen geht die Leuchte für ca. 150 bis 200 km aus.

Frage:

Hat es was gebracht?

Danke

Themenstarteram 31. Mai 2008 um 18:43

Hallo, ja es hat was gebracht.

Hab bis jetzt keine Probleme mehr damit *freu*

Gruß - inkaman

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Auto
  4. Toyota
  5. Toyota Previa Frage