ForumW203
  1. Startseite
  2. Forum
  3. Auto
  4. Mercedes
  5. C-Klasse
  6. W203
  7. Motorsteuergerät Typen

Motorsteuergerät Typen

Mercedes C-Klasse S203
Themenstarteram 22. Januar 2019 um 9:22

Hallo,

ich hab da mal eine Frage, auf die ich bisher im Forum keine Antwort gefunden.

In meinem S203 180K (5/2002) ist das Motorsteuergerät durch die übliche "Kabelbaumdusche" mit Öl abgesoffen.

Das gute Stück wurde bereits in enem Meisterbetreib ohne Stern gesäubert, aber die Fehler verschwinden nicht.

Der Kabelbaum ist neu und die diversen Schläuche sollen auch alle dicht sein ...

Jetzt steht der Tausch des Steuergeräts als nächste Möglichkeit aus.

Meine Idee wäre, ein gebrauchtes zu kaufen und dann das originale zu klonen.

Nun finde ich leider Steuergeräte mit der Teilenummer A2711534979 nicht.

Deshalb meine Frage: ist es möglich in ein Gerät zu klonen, dass sich in den letzten vier Stellen der Teilenummer unterscheidet - oder kann man das so programmieren, dass es passt.

Natürlich ohne irgendwelche Probleme (Wegfahrsperre oder so).

Dank schon mal.

Carsten

Ähnliche Themen
12 Antworten

Soweit ich weis kann das nur Mercedes. Kannste die alten Daten denn noch auslesen ?

Welcher Fehler soll denn da anliegen?

Themenstarteram 22. Januar 2019 um 19:18

@Rene_0815; Ich kann da leider garnix. Nur es gibt da eine Firma in Essen, die behauptet das zu können. :D

@db_fuchs: Also bezüglich der Fehlercodes kann ich eine ganze Menge anbieten.

Zuletzt hatte ich:

P0138, P0141, P0136, P0170, P2022, P2038, P0258

für mich sehen die Fehlermeldungen nach Injektor und falsch geregelter Lamdasonde aus. Also Lamda und / oder Injektor defekt

Themenstarteram 22. Januar 2019 um 19:31

Lambda wurde als Erstes ersetzt ...

sind die Injektoren geprüft?

Themenstarteram 22. Januar 2019 um 20:25

Rene, Danke für Deine Antworten. Die Prüfung der Injektoren werde ich noch veranlassen.

Ich bin leider kein KFZ-Fachmann und deshalb auf kompetente Hilfe angwiesen.

Habe bisher schon einige Theorien gehört und bin etwas ratlos.

Ich habe aber auch keine Lust zum Experimentier-Feld meiner Werkstatt zu werden.

Zuerst habe sie die Lambdasonde getauscht. Dann haben wir gemeinsam die bekannte Ölleckage des M271 im Kabelbaum und ein veröltes Steuergerät gefunden. Der Kabelbaum wurde getauscht. Das Steuergerät wurde gereinigt. Für den Tausch des Kabelbaums wurde der Kompressor ausgebaut. Ich glaube allerdings nicht, dass die drei Luftschläuche und das Ventil am Konpressor ersetzt wurden. Das sollte man dann doch machen - oder? Meine Frage nach einer Dichtigkeitsprüfung wegen möglichher Nebenluft wurde positiv ("ham gemacht - nix") beantwortet. Die Werkstatt würde gern das Steuergerät tauschen oder erstmal prüfen lassen. Irgendwie erscheint mir das nach Stochern im Nebel.

Hier wäre noch die Historie der OBD-Fehlercodes:

*Lambdasonde getauscht*

02.12.2018

P0170 Kraftstoffgemisch Fehlfunktion (Bank 1)

P201C Selbstanpassung der Gemischbildung

P2038 Kreis Einspritzungsreduktion-Drucksensor - Signalbereich/Funktion

P2058 Kreis Einspritzungsminderer (Bank 2, Modul 2) - Eingang hoch

10.12.2018

P0136 Lambdasonde Schaltkreis Fehlfunktion (Bank 1 Sensor 2)

P2029 Mit Kraftstoff beheizter Heizer - ausgeschaltet/blockiert

P2038 Kreis Einspritzungsreduktion-Drucksensor - Signalbereich/Funktion

23.12.2018

P0170 Kraftstoffgemisch Fehlfunktion (Bank 1)

P0172 Gemisch zu fett (Bank 1)

P201C Selbstanpassung der Gemischbildung

P2058 Kreis Einspritzungsminderer (Bank 2, Modul 2) - Eingang hoch

*Kabelbaum getauscht* Starter verreckt!!!

24.12.2018

P0170 Kraftstoffgemisch Fehlfunktion (Bank 1)

P2058 Kreis Einspritzungsminderer (Bank 2, Modul 2) - Eingang hoch

*Steuergerät gereinigt*

09.01.2019

P0170 Kraftstoffgemisch Fehlfunktion (Bank 1)

P0172 Gemisch zu fett (Bank 1)

P0140 Lambdasonde Schaltkreis keine Aktivität detektiert (Bank 1 Sensor 2)

P201C Selbstanpassung der Gemischbildung

P2038 Kreis Einspritzungsreduktion-Drucksensor - Signalbereich/Funktion

P2058 Kreis Einspritzungsminderer (Bank 2, Modul 2) - Eingang hoch

11.01.2019

P0170 Kraftstoffgemisch Fehlfunktion (Bank 1)

P0172 Gemisch zu fett (Bank 1)

P201C Selbstanpassung der Gemischbildung

P2038 Kreis Einspritzungsreduktion-Drucksensor - Signalbereich/Funktion

P2058 Kreis Einspritzungsminderer (Bank 2, Modul 2) - Eingang hoch

14.01.2019

P0138 Lambdasonde Schaltkreis zu hohe Spannung (Bank 1 Sensor 2)

P0170 Kraftstoffgemisch Fehlfunktion (Bank 1)

P0172 Gemisch zu fett (Bank 1)

P0136 Lambdasonde Schaltkreis Fehlfunktion (Bank 1 Sensor 2)

P201C Selbstanpassung der Gemischbildung

P2038 Kreis Einspritzungsreduktion-Drucksensor - Signalbereich/Funktion

P2058 Kreis Einspritzungsminderer (Bank 2, Modul 2) - Eingang hoch

Bin für jeden Ratschlag dankbar.

VG, C.

Welche lamdasonde wurde denn gewechselt?

Themenstarteram 22. Januar 2019 um 23:24

Vorkat.

Hallo Heffa,

ich fahre zwar einen S211 200K Mopf Bj. 2007, aber da sich die Maschinen zum größten Teil gleichen, schreibe ich hier ins 203er Forum.

Es handelt sich um den Fehlercode P2058. Und da ich hier schon seit geraumer Zeit Beiträge suche, die meine Problematik am ehesten beschreiben, habe ich auch in den 203er und 209er Foren gesucht. So bin ich zu Deinem Beitrag gekommen.

Hier nun eine kurze Beschreibung meines Problems:

Nachdem ich wiederholt die gelbe MKL in meinem KI leuchten sehen durfte und mir ein Bekannter per App und Dongle den P0170 (Kraftstoffgemisch Fehlfunktion (Bank 1)) ausgelesen und gelöscht hatte, habe ich nach diesem Fehlercode hier bei MT gesucht. Die Hinweise erwähnten die Nachkat-Sonde. Also haben ich diese tauschen wollen. Dabei habe ich Öl in der Koppelstelle des Motorkabelbaums zur Nachkat-Sonde gefunden. Eine erneute Suche im Forum ergab, dass Daimler da einen fetten Bock konstruiert hat, und sich Öl über die Nockenwellenmagnete in die Elektrik ergießt. Tolle Leute bei Daimler! Vielleicht sind die Konstrukteure auch gar nicht schuldig, sondern die Controller, die immer alles billig(er) machen, damit die Rendite stimmt?!?! Gerade von Daimler habe ich nicht erwartet, dass der Kunde die hausgemachten Fehler auf eigene Kosten ausbügeln muss. Okay, lassen wir das, ist ein bisschen off-topic! Aber ein bitterer Nachgeschmack bleibt.

Zurück zum Problem:

Nachdem ich die NW-Magnete getauscht und die Ölstoppkabel eingebaut habe, habe ich noch mehrere Male die Koppelstelle zur Nachkat-Sonde gereinigt bis der Rest Öl aus dem Kabelbaum sozusagen durchkapilliert ist und es dort trocken blieb.

Der Ärger hörte nicht auf, die MKL kam wieder. Der Verbrauch war übrigens auch seitdem die MKL leuchtet, um ca. 1,5l bis 2 l/100km gestiegen. Gemisch ist wohl viel zu fett.

Ich bin dann zum Freundlichen und habe per SD checken lassen. P2058 wurde gefunden. Ich habe dann die Vorkat-Sonde getauscht. Leider ohne Erfolg. Die Spannung der Sonde bleibt ziemlich statisch bei knapp über einem Volt stehen, laut erneuter SD bei 1034,6 mV. Ich weiß leider nicht, wie man die Ursache dafür finden kann. Auch interessiert mich der funktionale Zusammenhang.

Es gibt hier Empfehlungen, die Teilast-Entlüftungsschläuche zu kontrollieren. Vielleicht sollte ich das machen, obwohl meine Mercedes-Werkstatt mir sagte, dass die Schläuche i. O. sind.

Meine Fragen: Wurde(n) der/die Fehler bei Dir gefunden? Was war(en) die Lösung(en)?

Ich hoffe, Du kannst mir die richtigen Hinweise geben.

Vorab schon mal vielen Dank! :)

Themenstarteram 1. Oktober 2019 um 21:10

Hallo Friedhelm,

sorry, dass ich erst jetzt antworte. Ich habe mittlerweile aufgegeben und meinen S203 gegen einen S205 getauscht.

Eine Verbesserung bei hat tatsächlich eine Reparatur im Bereich der Teillastentlüftung gebracht. Ich bin leider kein Fachmann. Irgendeine Membrane im Bereich des Kompressors an einem Ventil war defekt. Es waren also nicht die Schläuche, sondern etwas das dran hing. Der Namen hab ich leider vergessen/verdrängt.

Ich hatte zwar auch Öl im Steuergerät, aber letztlich hat es ihm nicht geschadet. Öffnen, spülen und durchmessen.

Danach tauchten aber andere Probleme auf, sodass ich letztendlich genug hatte und den Wagen nur noch los werden wollte. Ca. 2000€ Reparaturen in 12 Monaten und Aussicht auf mehr war genug.

Leider fürchte ich, hilft das nicht viel weiter.

Viele Grüße,

Carsten

Hallo Carsten,

schönen Dank für Deine Antwort. Ich habe gestern auf Verdacht sämtliche Teile für die Teillastentlüftung geordert. Diese Teile wurden im Zusammenhang mit dem besagten Fehler sehr oft erwähnt, und somit hoffe ich, dass ich nach Tausch dieser Teile wieder einen rund laufenden Motor habe.

Das Steuergerät hängt ja am Lufi-Kasten. Diesen werde ich nach dem Ausbau über Nacht kopfüber lagern und schauen, ob da evtl. Öl aus dem St.-Gerät rauskommt.

Ich bin auch schon ziemlich enttäuscht von diesem Motor. Ich hatte ihn mit 89.000 km auf der Uhr gekauft, und bei 105.000 km riß mir die Steuerkette. Alle Ventile krumm, toll !! Das waren mal eben 4.000 Euronen :mad:

Und nun dieser Ärger mit dem viel zu fetten Gemisch und den ständigen Lambdasondenfehlern, obwohl die Sonden nur in den seltensten Fällen kaputt gehen. Bei Daimler scheint ja nicht nur die Konstruktion, sondern auch die Diagnose noch Raum zur Verbesserung zu haben

Nach fünf Jahren will ich den Wagen auch bald verkaufen und bin auf der Suche nach einem S212 mit 6-Zyl. Otto. Ich bilde mir ein, dass diese Maschinen robuster sind, als die 4-Zyl. Maschinen.

Mal sehen....

Viele Grüße,

Friedhelm

 

Deine Antwort
Ähnliche Themen