ForumOn-Board-Diagnose
  1. Startseite
  2. Forum
  3. Wissen
  4. Fahrzeugtechnik
  5. On-Board-Diagnose
  6. Fehler Code P0420 Audi A3 8P

Fehler Code P0420 Audi A3 8P

Hallo,

Mein Audi A3 8P mit dem 1,6 BSE Motor setzt einen Fehler Code der meist nach längerer Fahrt, z.b Autobahn kommt.

Woran kann das liegen? Die abgasuntersuchung wurde vor wenigen Tagen problemlos bestanden.

Laufleistung ist 164tkm.

Mfg

Dsc-3887
Ähnliche Themen
30 Antworten

neue Lambda Sonde wird fällig

Ist es die vor kat Sonde oder die zweite?

Bank 1 sollte die vor dem KAT sein.

Diese Codes sind ein Ergebnis der Kat-Überwachung. Die wird aktiviert, wenn so 5 min im Closed-Loop-Betrieb gefahren wurde. Das kannst du dir über die Readiness-Codes anschauen. Dann Bit 0 für die Kat-Überwachung.

16804 und P0420 drücken dann erstmal nur aus, dass eine Auffälligkeit rund um die Kat-Reinigungswirkung bei der Kat-Überwachung bemerkt wurde. Dafür braucht es:

* Signal der Vorkatsonde

* Signal der Nachkatsonde

Dein Diagnosesystem (Welches verwendest du da?) kann aber noch die herstellerspezifischen Subcodes auswerten. "Kurzschluss nach Plus sporadisch". Das drückt erstmal Kontaktfehler aus. Damit kommen dann unplausible Eingangsdaten beim Motorsteuergerät an.

Weitere Diagnose: Die Lambdasondensignale am MSG gemessen kannst du dir ja auch mal auf ein Oszi legen und anschauen als Analog-Messsignal. Oder über Service ID 05h via OBD2 auswerten (dort hat man die digitale Interpretation des Steuergerätes).

* Kabel und Stecker beider Lambdasonden auf ganzer Länge gründlich checken: Marderspuren? Isolierung aufgescheuert? Kabel direkt an der Sonde beschädigt? Durch Bodenkontakte angerissen/abgerissen?

* Zündung aus: Stecker der Lambdasonden auseinander, innen nach Korrosion oder Schmodder suchen. Steckerverriegelung noch intakt? Steckerdichtung noch ok? Steckkontakte wieder schön sauber machen. Paarmal zusammenstecken und trennen, damit sich auch dadurch die Kontakte reinigen. Dann Stecker mit Kabelbinder sichern. Wer Isolierungsfehler findet: halt neu isolieren. :-)

* Auch mal einen Bindfaden an den Lambdasondenkabeln festmachen, nach innen legen, während der Fahrt daran wackeln -> Ändern sich die Analogmess-Signale?

So erstmal den Fehler direkt am Auto genauer untersuchen, bevor es ans Teilelotto geht. Und dafür brauchst du die echten Lamdasondensignale am MSG.

Zitat:

@hadez16 schrieb am 28. Februar 2017 um 09:53:50 Uhr:

Bank 1 sollte die vor dem KAT sein.

Bank 1 sagt nix aus über Vorkat oder Nachkat. Sondern eben nur Bank 1.

Sein R4-Motor hat eh nur eine Zylinderbank.

Vorkat wäre da Bank 1, Sonde 1.

Nachkat wäre Bank 1, Sonde 2.

Der DTC sagt aus, dass bei der Kat-Überwachung auf Bank 1 (also der einzig verfügbaren an seinem R4-Motor) die Auffälligkeit erkannt wurde. Über Vorkat- oder Nachkat sagt es nichts aus.

Wer aber sonst keine weiteren DTCs hat und keinen komischen Motorlauf kann hauptsächlich an der ganzen Leitung zwischen MSG und Nachkatsonde (Monitorsonde zur Überwachung der Kat-Reinigungswirkung) suchen, wo es den sporadischen Kurzschluss nach Plus gibt.

Vielen Dank für die ausführlichen antworten. Mein Diagnose Programm ist die carport Software.

Ach carport, na dann ist auch denkbar, dass die Texte irreführend gewählt sind. Das wird man sehen, wenn man mal die Detaildiagnosen gemacht hat und sich die Lambdasondensignale aufs Oszi gezogen hat. Darin müsste man ja als nächsten Schritt mal die Plusschlüsse wirklich messen können.

Diese Seite drückt in knapper Form aus, wie versch. Hersteller den P0420 generell darstellen:

http://www.dtcsearch.com/P0420/

Mehr als ein erster Hinweis in eine bestimmte Richtung ist es an sich nicht.

Und den Hinweis fand ich noch gut:

https://community.dieselschrauber.de/viewtopic.php?t=28364

Ist fast das gleiche wie hier:

http://www.obd-codes.com/p0420

Nur den Teilelotto-Tipp "neue Lambdasonde" - den fand ich verwegen, wenn es in dem Gesamtsystem so viele Fehlermöglichkeiten gibt.

Was bestimmt noch gut ist als Diagnose: mal sanft gegen den Kat klopfen, ob der Körper bröckelig oder lose ist. Die ältesten 8P sind jetzt um 13 Jahre, auch das kann dann schon mal vorkommen. Man muss das halt jetzt systematisch weiter angehen.

Die AU hat er letzte Woche problemlos bestanden.

Mir fällt da noch ein: Der Motor hat einen erhöhten Ölverbrauch. Die Zündkerze an Zylinder 4 weist nach ein paar tausend Kilometern starke Ölasche Ablagerungen auf. Momentan ist aber eine neue Zündkerze im Einsatz, der Fehler kommt aber trotzdem.

Kann man mit Carport die Lambdasonden Signale auch darstellen bzw. im Messwertblock auslesen.

Dann mach es doch mal konkret: was für eine AU: eine richtige mit Rüsselmessung? Oder so eine Pseudo-AU mit nur Auslesen des Motorsteuergerätes? Naja, und die Rüssel-AU ist eben nur ein kleines Funzeln in einen dunklen Raum. Die Pseudo-AU mit ganz kleiner Funzel.

Zitat:

Mir fällt da noch ein: Der Motor hat einen erhöhten Ölverbrauch. Die Zündkerze an Zylinder 4 weist nach ein paar tausend Kilometern starke Ölasche Ablagerungen auf. Momentan ist aber eine neue Zündkerze im Einsatz, der Fehler kommt aber trotzdem.

Dann kommt das Öl auch durch in den Abgastrakt und beschädigt die Sonden und den Kat. Die neue Kerze ist also keine Lösung. Sondern das Ölleck muss da am Zylinder weg (Ventilschaftdichtungen, Ventilsitze, Kolbenringe sind da die Kandidaten => Kompressionsmessung kann Aufschluss bringen). Und auch die neue Zündkerze wird bald wieder belegt sein, dann Fehlzündungen veursachen und noch Kraftstoff durchlassen. Auch schlecht für alles dahinter.

Zitat:

Kann man mit Carport die Lambdasonden Signale auch darstellen bzw. im Messwertblock auslesen.

Ja, na klar. Zum Nase bohren wurde das nicht gemacht. :-)

Unter Systemstatus und in den Messwertblöcken/Echtzeitdaten.

https://forum.carport-diagnose.de/.../page-2

Grafische Darstellung - sollte auch gehen:

https://carport-diagnose.de/.../060-emu-addr-01-plot-de.png

https://www.shareware.de/.../carport-screenshot-546ab4f9562a0.jpeg

Wieso kaufst du das denn, wenn du es nicht nutzen kannst oder verstehst? Ein Blick ins Handbuch reicht doch, dann müsste man das sehen.

Die AU war beim tüv über obd. Kompression ist auf dem Zylinder voll da.

Ich schau gleich mal nach der Verkabelung der beiden Sonden.

Kann der Fehler auch durch den ölverbrauch auftreten?

Zitat:

Kann der Fehler auch durch den ölverbrauch auftreten?

Kommt drauf an:

* Wenn die Ursache der Meldung wirklich ein Plusschluss an einer Leitung der Sonde sein sollte: dann nicht. Das Öl kann keinen elektrischen Plusschluss verursachen.

* Wenn hingegen die Öldämpfe das Monitorsondensignal nur so aussehen lassen, dass es auf dem Signal wie ein Plusschluss aussieht, während die Leitung völlig intakt ist: dann ja.

Zitat:

@MrX schrieb am 28. Februar 2017 um 13:29:33 Uhr:

...

Ich schau gleich mal nach der Verkabelung der beiden Sonden.

...

Vlt. war mal ein Marder zu Besuch?

Hab beide Sonden mal ausgebaut und überprüft. Stecker und Verkabelung ist in Ordnung.

Hab mal Fotos von den beiden gemacht

Dsc-3896
Dsc-3893
Deine Antwort
Ähnliche Themen