ForumOn-Board-Diagnose
  1. Startseite
  2. Forum
  3. Wissen
  4. Fahrzeugtechnik
  5. On-Board-Diagnose
  6. OBD-DIAG 3001 KL/KKL & VAG-COM 3.113 finden Motor nicht

OBD-DIAG 3001 KL/KKL & VAG-COM 3.113 finden Motor nicht

Themenstarteram 27. Dezember 2006 um 16:18

Ich habe mir zur Fehlerdiagnose meines Autos (Superb 3U 2.8 V6 Comfort 5-Gang Hand Bj. 2003) das Interface 3001 von obd-diag.de (Stange Distribution) bestellt und ausprobiert. Leider werden das Motorsteuergerät (01) und die ZV (35) nicht gefunden. Aber gerade Motor samt Kats wären mir wichtig.

Mit einem seriellen Interface (RS232) eines Freundes funktioniert es, wodurch die Steuergeräte schon mal als Fehlerquelle wegfallen. Die Software war in beiden Fällen VAG-COM 3.113.

Ich habe auch die neusten Treiber für den integrierten FTDI-Chip verwendet und mit den Bitraten herumgespielt. Leider nix.

Laut Stange Distribution liegt es an VAG-COM, was bei 99% funktioniert und das eine Prozent (ich) hat eben Pech. Von VAG-COM ist wenig Hilfe zu erwarten, weil die kaum ihre alte Shareware supporten werden.

Kurz: Diese Steuergeräte kann ich ansprechen:

03 Bremselektronik

08 Klimaanlage

15 Airbag

17 Schalttafeleinsatz

19 CAN-Schnittstelle

37 Navigation

46 Zentrales Komfortsystem

55 Leuchtweitenregulierung

56 Radio

diese zwei nicht:

01 Motorelektronik

35 Zentralverriegelung

Vielleicht hat ja noch jemand ne Idee…

Ähnliche Themen
59 Antworten

Hallo,

ich verweise mal auf folgenden Thread.

Dabei tippe ich auch mal auf ein Optokoppler-Interface.

Habe gerade mal auf der Anbieter-Seite nachgesehen.

Für runde 35 Euro kann es nur so sein.

Im Vergleich zu einem vollständigen Interface (ca. 350 Euro) musst Du da einfach Abstriche machen können.

Beste Grüße,

Mel.

Re: OBD-DIAG 3001 KL/KKL & VAG-COM 3.113 finden Motor nicht

 

Zitat:

Original geschrieben von SuperbLPG

...von obd-diag.de (Stange Distribution)

Ich hasse es das der Kerl den gleichen Nachnamen wie ich hat... :mad:

Zitat:

Original geschrieben von SuperbLPG

Leider werden das Motorsteuergerät (01) und die ZV (35) nicht gefunden.

ZV (35) hast du nicht, die ist im Komfortsteuergerät (46) integriert.

Zitat:

Original geschrieben von SuperbLPG

Laut Stange Distribution liegt es an VAG-COM, was bei 99% funktioniert und das eine Prozent (ich) hat eben Pech. Von VAG-COM ist wenig Hilfe zu erwarten, weil die kaum ihre alte Shareware supporten werden.

Die Sharewareversion wird schon betreut (supported), aber der Werte Herr Folker Stange schiebt wie fast alle Fremdhardware-Hersteller gern die Schuld auf den Softwarehersteller, der "Kunde" steht dazwischen und ist der Arsch.

VAG-COM hat absolut kein Problem mit den 2.8l VR6 Motoren im Superb/Passat/Golf/Jetta - daher kann ich dir garantieren das die Software NICHT Schuld ist, eher könnte der Fehler schon beim Fahrzeug oder eben der Hardware liegen.

Dein Interface basiert zwar nicht auf Optokopplern wie Mel fälschlich annimmt, aber ist alles in allem was die Diagnose an VAG Modellen angeht alles andere als so perfekt wie es der Hersteller/Vertreiber angibt. Wie er selbst in seinem eigenen Forum schreibt ist ja seine Hardware eigentlich auch gar nicht für die Arbeit mit VAG-COM ausgelegt sondern primär für OBD-2/EOBD, demnach wäre die VAG-COM Kompatibilität (für ältere Versionen) ja nur ein Bonus für den Kunden.

Vorschlag, sag uns wo du wohnst und wir schauen mal das wir jemanden finden der ordentliche VAG-COM Hardware hat und dann kannst du mal schauen was da geht und was nicht.

Themenstarteram 28. Dezember 2006 um 7:45

Erstmal vielen Dank für die Antworten!

Das klingt schon wesentlich netter und lösungsorientierter als im Stange Forum. Wenn jemand so hilfsbereit wäre, sich das Problem mal anzuschauen, dann kann ich relativ schnell in Mittelsachsen (L, MEI, MTL, DL, TO, RG usw.), Ostsachsen (DD, HY, BZ usw.), Südbrandenburg (CB, OSL usw.) und Berlin sein.

Zur Info noch mal: mit RS232-Interface lässt sich der Motor auslesen.

- Was würde dann bei dem Termin herauskommen?

- Kann man mit einem „großen“ VAG-COM die Antwortzeiten bzw. die richtigen Einstellungen für das Interface 3001 herausbekommen?

- Gibt es noch andere Hersteller von USB-Interfacen, diesmal gleich mit OBD2? CAN brauche ich für meine Kiste nicht. Mit Original VAG-COM habe ich schon geliebäugelt, ist aber bei objektiver Betrachtung und dem geringen Einsatzspektrum etwas zu viel des Guten.

-Der Motor ist ein "richtiger" V6 mit zwei Zylinderköpfen, welcher bei Audi verwendet wurde (A4, A6, A8) - kein VR6.

Noch einige Worte zu Stange Dis.:

Dort wurde aufgrund meiner Ansicht der Beitrag gelöscht. Dabei hatte ich dort nur die selbe Tatsache wie Theresias zu bedenken gegeben.

Erstens wird das Interface 3001 in Verbindung mit VAG-COM beworben und kann außer mit VAG-COM mit nichts anderem funktionieren:

„PKWs des VW Konzerns (VAG) ab ca. Bj 1993 sind für die Diagnose mit der beliebten Software VAG.com diagnostizierbar.“

„softwarekompatibel zu VAG.com 311/403 (KL und KKL-fähig).“

Dann wird noch ein einfaches Upgrade auf OBD2 in Aussicht gestellt:

„Dieses Interface ist über die USB Schnittstelle update- und upgradebar. Eine nachhaltige Wertsicherung ist hierdurch gegeben. Der Anwender kann über eine PC-Software später Module einspielen und so auf volle OBD2 Funktionalität modulweise aufrüsten.“

Auch das funktioniert auf Nachfrage so nicht. Man muss das Interface einschicken und für das Upgrade (15-34€) + Versand bezahlen.

Quelle: Auszug aus OBD-DIAG® 3001 KL / KKL Interface auf www.obd-diag.de 28.12.2006

Lapidare Antwort, daran ist VAG-COM Schuld bzw. das Steuergerät (zu kurzes Timeout) und das Upgrade nutzt sowieso niemand und Ich soll auf OBD2 ausweichen. Außerdem wurde mehrfach betont, dass man mit der Software von VAG-COM nichts zu tun haben möchte. Auf Nachfrage wurde mir auch keine Alternative angeboten.

Daraufhin habe ich auf die Lücke hingewiesen, welche beim Kunden entsteht, der weder von Stange noch von VAG-COM Hilfe erwarten kann, wobei er bei Stange Geld bezahlt hat.

Ich bin mir auch bewusst, dass man für ca. 40 € nicht die Welt erwarten kann. Aber wie gesagt, ein billigeres Interface (rotes Klarplastikgehäuse) mit RS232 hat ja auch alles gemacht und die Werbung klingt anders.

Bleibt unterm Strich: ein teilfunktionsfähiges Interface fürs volle Geld und keine Hilfe - Ich mag ein Einzelfall sein.

Zitat:

Original geschrieben von SuperbLPG

Das klingt schon wesentlich netter und lösungsorientierter als im Stange Forum. Wenn jemand so hilfsbereit wäre, sich das Problem mal anzuschauen, dann kann ich relativ schnell in Mittelsachsen (L, MEI, MTL, DL, TO, RG usw.), Ostsachsen (DD, HY, BZ usw.), Südbrandenburg (CB, OSL usw.) und Berlin sein.

Ich könnte dir pauschal Magdeburg anbieten (würds mir auch gern mal selbst anschauen was bei dir faul ist), bei Gelegenheit bin ich aber auch mal in Leipzig bzw. in Torgau kenne ich auch noch jemanden der in Frage käme.

Zitat:

Original geschrieben von SuperbLPG

- Was würde dann bei dem Termin herauskommen?

Klarzustellen wo das Problem liegt. Fahrzeug, Interfacehardware oder Software (was ich zwar ausschließe, dir aber trotzdem gern zeigen würde).

Zitat:

Original geschrieben von SuperbLPG

- Kann man mit einem „großen“ VAG-COM die Antwortzeiten bzw. die richtigen Einstellungen für das Interface 3001 herausbekommen?

Das Problem ist i.d.R. nicht die passenden Daten herauszubekommen, sondern das die günstigere Hardware die passenden Rahmenbedingungen gar nicht bereitstellen kann. Man kann aber auch schauen was passt und dahingehend nochmal mit deiner Hardware gegenprüfen.

Zitat:

Original geschrieben von SuperbLPG

- Gibt es noch andere Hersteller von USB-Interfacen, diesmal gleich mit OBD2? CAN brauche ich für meine Kiste nicht. Mit Original VAG-COM habe ich schon geliebäugelt, ist aber bei objektiver Betrachtung und dem geringen Einsatzspektrum etwas zu viel des Guten.

OBD-2 bringt dir nicht viel, du hast nur einen Bruchteil der Messwerte zur Verfügung und auch die Abtastrate (sprich wie schnell die Daten vom Steuergerät zum Diagnosegerät kommen) ist deutlich schlechter. Hersteller gibt es viele, aber ob sich dies lohnt ist eine ganz andere Frage. Warte erstmal ab was im Test/Vergleich rauskommt - entweder hast du dann bereits eine Lösung oder es wird sich eine finden.

Zitat:

Original geschrieben von SuperbLPG

-Der Motor ist ein "richtiger" V6 mit zwei Zylinderköpfen, welcher bei Audi verwendet wurde (A4, A6, A8) - kein VR6.

Der AMX der bei dir verbaut wurde kam neben dem Superb bei alle Modellen mit Längseinbau zum Einsatz (A4, A6, A8 und Passat) - von der Bauart her kein echter VR6 sondern ein V6 da hast du allerdings recht.

Zitat:

Original geschrieben von SuperbLPG

Noch einige Worte zu Stange Dis.:

Dort wurde aufgrund meiner Ansicht der Beitrag gelöscht. Dabei hatte ich dort nur die selbe Tatsache wie Theresias zu bedenken gegeben.

Lapidare Antwort, daran ist VAG-COM Schuld bzw. das Steuergerät (zu kurzes Timeout) und das Upgrade nutzt sowieso niemand und Ich soll auf OBD2 ausweichen.

...der Timeout hat damit nichts zu tun, schon eher das Timing - und was da geht und nicht geht ist durch die Hardware begrenzt nicht durch die Software. ;)

Zitat:

Original geschrieben von SuperbLPG

Bleibt unterm Strich: ein teilfunktionsfähiges Interface fürs volle Geld und keine Hilfe - Ich mag ein Einzelfall sein.

Du bist kein Einzelfall, auch deine Erfahrung mit gelöschten Beiträgen kam von anderer Seite bereits und man geht dort mit Kritik am Produkt sehr rigoros um.

Themenstarteram 28. Dezember 2006 um 20:06

Nochmal herzlichen Dank, ich würde dann mal warten bis wir mal mit Leipzig übereinkommen. Hast Du schon einen Termin für deinen nächsten Sachsentrip?

Außerdem habe ich im Stange-Forum noch jemand mit dem gleichen Problem gefunden. Er kommt aus der Nähe und wir werden uns wohl mal treffen und einen Kreuzcheck machen.

Gern geschehen. Ich hab lange dort nicht ins Forum geschaut weil schon beim letzten mal nur Murks dabei war und das hat sich nicht geändert. Hier mal ein paar Beispiele...

 

Zitat:

Original geschrieben von ertronik

Also, wenn ich das hier so verfolge, dann würde ich als erstes vermuten, daß die VAG.COM an der ganze Sache Schuld ist. Dieses Programm ist nicht von VAG geschrieben und vielleicht kannte der Programmierer einfach diese speziellen Funktionen nicht.

VAG-COM wird in der Tat nicht von VW/Audi hergestellt, ebenso werden es aber auch die VAS-505x Tester nicht sowie alle anderen Geräte auf dem Markt. Was bei den VAS-505x Testern passiert ist das diese auf Basis der VW/Audi Spezifikation entwickelt/produziert werden. VAG-COM ist, so benennt es der Softwarehersteller, ein Emulator dieser Originaltester und basiert eben auf diesem - soll heißen indirekt kann man davon ausgehen das es genau das gleiche macht wie dieser.

Die hier fraglichen Funktionen/Befehle zur Initialisierung der Kommunikation sind jedoch Protokoll korrekt in die Software implementiert, sonst würdest auch keine Verbindung zu anderen Steuergeräten aufgebaut werden können, soll heißen der Verbindungsaufbau hat nichts mit "speziellen Funktionen" zu tun.

Zitat:

Original geschrieben von ertronik

Am Interface kann es nicht liegen, da dieses die Daten 1:1 durchschickt, es wird weder irgendwas verändert nich hinzugefügt.

Fremdanbieterhardware, die nicht explizit für VAG-COM und nach den Spezifikationen des Softwareherstellers hat sehr oft dieses Problem, besonders interessant ist in dem Fall auch das solche Fehler mit der Originalhardware nicht auftreten - kann es dann wirklich an der Software liegen?!

Fremdhardware muss die Kommunikation 1:1 durchleiten, dabei müssen aber z.B. die Pegel angepasst werden und es muss sicher gestellt werden das das Timing dabei nicht verfälscht wird - so ganz 1:1 ist es also nicht. Was nun aber oft passiert ist das Fremdhardware Konzept bedingt diese 1:1 Umwandlung zwar erfüllt aber dabei die Pegel unsauber werden bzw. das Timing versaut wird und dann ist eben doch die Hardware schuld.

Zitat:

Original geschrieben von Folker

Mit USB 1.1 gibt es immer Probleme - schon mehrfach hier im Forum gepostet - Das kann schon eine Ursache sein (kann Baudrate nicht synchronisieren). Ggf. eine 2.0 PCMCIA-Karte benutzen

Die verwendeten FTDI Bauteile laufen explizit mit USB 1.1, obige Aussage ist also völlig sinnfrei...

P.S.: Im Falle der OBD-DIAG Hardware ist es übrigens i.d.R. das Timing das vermurkst wird durch die Hardware bzw. deren Einstellungen - aber das ist eine Sache um die sich der Hersteller kümmer soll. Nur bietet dieser ja für sein VAG-COM kompatibles Produkt explizit keine VAG-COM bezogene Kundebetreuung an. ;)

Themenstarteram 28. Dezember 2006 um 22:13

Das ist Blasphemie ;-)

Bei der Gelegenheit fällt mir ein, dass es mir und auch meiner Werkstatt nie gelungen ist, den Gurtwarner wegzucodieren. Die Codes eurer wirklich tollen Sammlung zeigten keine Wirkung - Schonmal zur Vorbereitung auf ein mögliches Treffen.

Zitat:

Original geschrieben von SuperbLPG

Bei der Gelegenheit fällt mir ein, dass es mir und auch meiner Werkstatt nie gelungen ist, den Gurtwarner wegzucodieren.

Interessant, bei allen mir bekannten Superbs hat es bisher problemlos funktioniert. Auch das würde ich mir gern mal selbst anschauen...

Herr Stange Theresias ...

es würde mich interessieren, wieviel sie schon von RossTec usw bezahlt bekommen haben.

Die Hardware ihres Namensvetters ist von den Bauteilen absolut das gleiche ... Ross verlangt halt die "dongelung" des Interfaces.

FAKT ist jedoch, dass BEIDE Interfaces GLEICHWERTIG sind !

Gerne bin ich bereit den Vergleich mit GLEICHER Umgebung anzutretren !

Zitat:

GLEICHWERTIG

Warum funktionieren diese Interfaces dann nicht mit den Treibern die mit VAG-COM geliefert werden?

-Uwe-

Zitat:

Original geschrieben von cobra_2004

Die Hardware ihres Namensvetters ist von den Bauteilen absolut das gleiche ... Ross verlangt halt die "dongelung" des Interfaces.

Interessant, der AGV3000 den ich das letzte mal bei einem Fall ähnlicher Problemsuche am Wickel hatte, hat einen eigenen Interpreter Chip mit eigener Software der vom Bauteil her meines Wissens nicht identisch ist mit den Ross-Tech Interfaces - soweit ich das beim Öffnen beider mal verglichen habe.

Zitat:

Original geschrieben von cobra_2004

FAKT ist jedoch, dass BEIDE Interfaces GLEICHWERTIG sind !

Wenn das so wäre müsste doch alles funktionieren? Wieso tut es das dann nicht? Mit dem Schutz einer Software hat das nichts zu tun denn andere Fremdanbieter bekommen das ja auch hin ohne Urheberrechte zu verletzen oder Kooperationen mit dem Softwarehersteller einzugehen. ;)

Zitat:

Original geschrieben von cobra_2004

Gerne bin ich bereit den Vergleich mit GLEICHER Umgebung anzutretren !

Na dann mal los!

Ich würde anbieten das wir uns alle einfach bei SuperbLPG treffen, er hat derzeit das Problem und kann gleichzeitig als neutraler Zeuge fungieren. Wir nutzen seinen PC/Laptop mit der von ihm installierten Software in Standardeinstellung, ich bring mal ein paar Interfaces (auch von anderen Fremdanbietern) mit und ihr macht das gleiche mit den AGV's. Dann testen wir mit VAG-COM 311, 409 und auch der aktuellen 607, denn da die AGV Hardware ja gleichwertig ist müsste sie ja mit der 607 zumindest als Shareware (also ohne Donglefreischaltung) funktionieren.

Alternativ schick mir doch mal auf offiziellem Weg ein Exemplar das deiner/eurer Meinung nach "gleichwertig" ist und dann schauen wir mal wie das ganze aufgebaut ist und wie gleichwertig das ganze nun wirklich ist.

Meine Adresse findet sich im Impressum meiner Webseite und ist jedermann zugänglich im Gegensatz dazu wissen wir noch nicht wer genau du bist. ;)

P.S.: Ich warte immernoch auf deinen Beweis den du hier beschrieben hast...

http://www.motor-talk.de/showthread.php?...

uwe ..

mit welchen Treibern ?

Die Treiber, die auch die "FIRMWARE" ändern wollen ? von einem "dummen" Interface, das die Daten 1:1 an die Software weitergiebt ?

lg

Die Treiber aendern keine Firmware. Ja, fuer unsere intelligente Interfaces gibt es selbstverstaendlich firmware updates. Die kommen aber von VAG-COM, nicht von den Treiber. Und die selben Treiber funktioniern auch mit unserem originalem TWIN-USB Interface welches ueberhaput keine intelligenz hatte:

http://www.ross-tech.com/vag-com/old-interfaces/twin-usb.html

-Uwe-

Zitat:

Original geschrieben von Theresias

Na dann mal los!

Ich würde anbieten das wir uns alle einfach bei SuperbLPG treffen, er hat derzeit das Problem und kann gleichzeitig als neutraler Zeuge fungieren. Wir nutzen seinen PC/Laptop mit der von ihm installierten Software in Standardeinstellung, ich bring mal ein paar Interfaces (auch von anderen Fremdanbietern) mit und ihr macht das gleiche mit den AGV's. Dann testen wir mit VAG-COM 311, 409 und auch der aktuellen 607, denn da die AGV Hardware ja gleichwertig ist müsste sie ja mit der 607 zumindest als Shareware (also ohne Donglefreischaltung) funktionieren.

=> tja ... ich bin aus Österreich :-(

Zitat:

Original geschrieben von Theresias

Alternativ schick mir doch mal auf offiziellem Weg ein Exemplar das deiner/eurer Meinung nach "gleichwertig" ist und dann schauen wir mal wie das ganze aufgebaut ist und wie gleichwertig das ganze nun wirklich ist.

=> gleichwertig ... WAS verstehst du darunter ?

Zitat:

Original geschrieben von Theresias

Meine Adresse findet sich im Impressum meiner Webseite und ist jedermann zugänglich im Gegensatz dazu wissen wir noch nicht wer genau du bist. ;)

ICH bin ein Computer Freak der auch gerne an Autos "bastelt"

Ähnliche Themen
  1. Startseite
  2. Forum
  3. Wissen
  4. Fahrzeugtechnik
  5. On-Board-Diagnose
  6. OBD-DIAG 3001 KL/KKL & VAG-COM 3.113 finden Motor nicht