ForumOn-Board-Diagnose
  1. Startseite
  2. Forum
  3. Wissen
  4. Fahrzeugtechnik
  5. On-Board-Diagnose
  6. [Audi A6 (4A)] Eine Bitte an Besitzer von Audi C4 2,5 TDI und VAG-COM

[Audi A6 (4A)] Eine Bitte an Besitzer von Audi C4 2,5 TDI und VAG-COM

Themenstarteram 9. Juni 2004 um 22:27

Eine Bitte an Besitzer von Audi C4 2,5 TDI und VAG-COM

 

hallo,

habe da eine bitte an alle die einen Audi C4 2,5 TDI ( AEL-Motor ) und die Software VAG-COM besitzen.

Ich benötige zwei Temperaturwerte wegen überprüfung meines Ansauglufttemperaturgebers G42.

in "Messwertblock lesen" gehen

Es ist zum einen der Wert in der AnzeigeGruppe 000 , Feld Nr 8 ( ein wert zwischen ca 155 und 243 ).

Die Wertetabelle ist als Bilddatei angehängt.

Der zweite Wert ist in der AnzeigeGruppe 07 Feld Nr 2 ( dort wird die Ansaugtemperatur in Grad angegeben).

Zum vergleich benötige ich noch die zur Prüfzeit herschende Außentemperatur.

Als hinweiß: Möglichst bei kalten Motor Messung duchführen um verfälschung durch die Motorabwärme zu vermeiden.

 

Zur erklärung:

mein Problem besteht darin das beide temperaturanzeigen stark von einander abweichen.

Dies könnte unter umständen als Ursache für die mangelnde Leistung des Fahrzeugs und den erheblichen hohen dieselverbrauch ( um 10 - 11 liter ) gedeutet werden.

So ist bei einer Außentemperatur von 19 Grad ein wert von 170 in Gruppe 000 Feld 8 abzulesen, was ca 33-35 Grad entsprechen würde. Jedoch steht in Gruppe 07 Feld 2 ein wert von 17,1 Grad was ziemlich genau der Wert der Außentemperatur wäre.

Ich würde gern ein paar referenzwerte von anderen Fahrzeugen einsehen um dieses Missverhältnis besser beurteilen zu können.

Von VAG/ Audi bekam ich null-nada-nix an Hilfe oder erklärungen. Alle zuckten nur hilflos mit der schulter als ab ich sie chinesisch rückwärts etwas gefragt hätte.

Jedenfall möchte ich nicht auf blauen Dunst einfach den Luftmengenmesser mit dem integrierten G42 Fühler austauschen , da dieser weit über 450 Euro kostet.

bin über jede Hilfe und Unterstützung sehr dankbar.

 

Gruß Krissi

Ähnliche Themen
11 Antworten

Würden dir die Sollwerte für den Motor helfen?

Themenstarteram 10. Juni 2004 um 20:03

hallo,

@ Theresias

habe sämtliche Reparaturhandbücher von VAG zu dem Auto / Motor. Die Sollwerte sind mir auch bestens bekannt.

Nur dort steht leider nicht alles drin. ( zb was ist wenn die beiden Werte unterschiedlich sind ... und welcher wert vom Steuergerät als Stellgröße benutzt wird , auch Kennlinien fehlen nahezu zu allen Bauteilen um eine direkte Bauteilanalyse durchzuführen).

 

Auch ist es sehr schwierig etwas über die Software im Steuergerät in erfahrung zu bekommen.

Audi selbst hüllt sich in schweigen und gibt keinerlei Info´s heraus.

Habe auch software zum Analysieren / beschreiben der Chip´s ( Tunersoftware ) nur leider kann man dort auch nicht erkennen woher und welcher Wert zu welchem Ereignis zugeordnet wird.

Habe bis dato fast alles was zu allgemeinem Infos zu bekommen ist über TDI -Funktion und wirkprinzip, Steuergeräte -aufbau und Logikschaltungen und Schema von der Software gelesen und weiß zwar in der Theorie einiges nur speziell auf ein bestimmtes Fahrzeug kommt man ohne bestimmte Werte-Tabellen einfach nicht weiter.

 

Danke trotzdem für die gebotene Hilfe

gruß krissi

Hallo Krissi,

Ich habe es ohne Labeldatei geloggt, konnte für die 4A0-Serie 2.5er TDI noch keins ausfindig machen bzw. hatte noch keine Zeit ein Label selbst zu erstellen.

Angezeigte Außentemperatur in Instrumententafel:

exakt 19,0 Grad! Glück gehabt, daß es angefangen hat zu regnen, heute Mittag war es erheblich wärmer :)

 

hier die Referenz, kommst du damit klar?

Gruss

Themenstarteram 10. Juni 2004 um 23:03

hallo Goldhuhn,

ja klar kann ich damit etwas anfangen.

Und danke noch mal dafür ... :)

Übrigens hast du auch eine stark abweichende Temperaturanzeige wie ich sie habe.

160 = ca 35-37 Grad Ansaugtemperatur

Im Vergleich zu angezeigten 24,3 /realen 19,0 eine abweichung von mehr als 10 Grad /15 Grad .

19,0 zu 24,3 stimmt hier auch wie bei mir schon ehr überein.

naja mal sehen ob ich hier noch ein paar Werte bekommen kann, damit etwas mehr dazu sagen kann.

 

PS: unten kannste meine erstellte Labeldatei für den 2,5 TDI mit AEL Motor runterladen

(Wichtig !! Mußt nur die TXT-Dateiendung in LBL umbenennen !! )

 

Gruß krissi

Hallo Krissi,

komm doch einfach mal bei mir vorbei und ließ dir die Werte aus meinem Fahrzeug aus die du brauchst!

Da ich der Meinung bin das meiner so läuft wie er soll!

LG Faruk

Danke Krissi,

ich habe deine Labeldatei integriert, funktioniert bestens, jetzt kann ich mit den Messwertblöcken endlich was anfangen. Ich werde mir zusätzlich alles in Logfiles speichern, um bei auftretenden Problemen Vergleichswerte zu haben.

Zu deinem Problem (eigentlich jetzt auch meins): Lass uns mal überlegen, woher diese Abweichung kommen kann:

1. VAG-COM schliesse ich aus, da wohl die ausgelesenen Messwerte 1:1 aus dem Steuergerät übernommen und direkt angezeigt werden. Ich denke nicht, daß da noch ein Umrechnungsfaktor verwendet wird.

2. Vielleicht stimmt deine Beschreibung zum Digitalwert nicht? Wo hast du die her?

3. Softwarefehler im Steuergerät, d.h. die Umrechnung zur Ermittlung vom Widerstandswert (Temperatursensor Analog) zum Digitalwert ist fehlerhaft. Oder es wurde bewusst über 30% beaufschlagt, weil irgendwas nicht 100% funktionierte? Naja, nur Vermutungen und weit hergeholt! Aber alles schon erlebt, in der Softwarebranche.

4. Falls der Fühler im Luftmengenmesser ein PT100 Element ist, dann sollte man andere Digitalwerte z.B. Ansaugtemperatur im Frischluftgebläse als Vergleichswert auftreiben, oder evtl. die Ansaugtemperatur Ladeluftkühler.

Der Fühler im Luftmengenmesser ist auf jeden Fall in Ordnung, sonst wäre die Analogtemperatur im Messwerteblock 7 fehlerhaft.

Gruss

Normale Messwertgruppen geben neben dem eigentlichen Wert eine Art Definition mit, dies trifft aber nicht auf die Messwertgruppe 000 zu, dort werden nur Werte übermittelt, die dann von VAG-COM 1:1 darstellt, d.h. der ehler liegt entweder in der VAG-Dokumentation, oder in der Firmware.

Themenstarteram 21. Juni 2004 um 21:36

hallo,

@ Theresias

habe diese Fehler eigentlich schon ausgeschlossen.

Alle 5 werte die ich bisher gesammelt habe haben eine sehr große spreizung ähnlich wie bei mir.

Bei Audi-Werkstätten wurde mir die richtigkeit der Werte in den VAG-Leitfäden bestätigt ( ebenso von audi selbst ).

Zum anderen habe ich meine eigenen Werte mal mit verschieden Auslesegeräten gemessen.

VAG 1551 / VAG 1552 ; CSW - C1553 , VAG-COM Profiversion . einem Bosch Universaltester und CARTEC-Diagnose-Box.

Jedesmal kamen nahezu die selben Werte heraus.

Auch der austausch meines Steuergerätes brachte keine Änderung ( mit älterer Firmware ).Ein anderer Luftmengenmesser mit G42 Fühler brachte ähnliche vergleichbare Werte wie bereits erwähnt.

Jedenfalls bin ich immer noch ratlos wie sich die sache erklären lässt.

Eine Antwort bezüglich dieser Problematik habe ich von einem Programmierer und Entwickler des Steuergerätes bis heute noch nicht erhalten. Auch eine Firma die Steuergeräte repariert und instantsetzt hat bis heute noch nicht geantwortet.

Werde noch eine paar Tage abwarten und nochmals nachhaken.

Gruß krissi

Themenstarteram 21. Juni 2004 um 22:06

Hallo Goldhuhn,

 

Zitat:

Original geschrieben von Goldhuhn

Danke Krissi,

ich habe deine Labeldatei integriert, funktioniert bestens, jetzt kann ich mit den Messwertblöcken endlich was anfangen. Ich werde mir zusätzlich alles in Logfiles speichern, um bei auftretenden Problemen Vergleichswerte zu haben.

=> wenigstens hab ich jemand damit glücklich gemacht :)

 

Zu deinem Problem (eigentlich jetzt auch meins): Lass uns mal überlegen, woher diese Abweichung kommen kann:

1. VAG-COM schliesse ich aus, da wohl die ausgelesenen Messwerte 1:1 aus dem Steuergerät übernommen und direkt angezeigt werden. Ich denke nicht, daß da noch ein Umrechnungsfaktor verwendet wird.

=> denke ich auch

2. Vielleicht stimmt deine Beschreibung zum Digitalwert nicht? Wo hast du die her?

=> ist aus einem original Reparaturleitfaden von Audi für den Audi 100/A6 mit AEL Motor

3. Softwarefehler im Steuergerät, d.h. die Umrechnung zur Ermittlung vom Widerstandswert (Temperatursensor Analog) zum Digitalwert ist fehlerhaft. Oder es wurde bewusst über 30% beaufschlagt, weil irgendwas nicht 100% funktionierte? Naja, nur Vermutungen und weit hergeholt! Aber alles schon erlebt, in der Softwarebranche.

=> warte immer noch auf meine anfrage bei einem Programmierer dieses Steuergrätes/ Software , mal sehen was dieser als erklärung abgiebt. Audi selbst ist bis dato 100% unfähig etwas zu antworten oder zu erkären

4. Falls der Fühler im Luftmengenmesser ein PT100 Element ist, dann sollte man andere Digitalwerte z.B. Ansaugtemperatur im Frischluftgebläse als Vergleichswert auftreiben, oder evtl. die Ansaugtemperatur Ladeluftkühler.

=> leider hat der AEL -Motor nur einen Temperatursensor ( der G42 ) zur bestimmung der Ansauglufttemperatur, die nachfolge Modelle haben mehrere Fühler integriert. Auch eine oOriginal Temperaturkurve für diesen Fühler ist anscheinend nirgends aufzutreiben. Werde mal selbst ermitteln ob es ein PTC oder NTC ist und mit welchen Werten

 

Der Fühler im Luftmengenmesser ist auf jeden Fall in Ordnung, sonst wäre die Analogtemperatur im Messwerteblock 7 fehlerhaft.

=> denke ich auch, da der wert nahezu identisch mit der realen außentemperatur ist. Außerdem habe bis jetzt keine infos wie welcher Temperaturwert im Steuergerät verarbeitet wird

 

Gruss

Gruß krissi

Hallo Krissi,

ich habe mal nachgeschaut:

Im SSP145 Seite 26 wird beschrieben, daß der G42 ein NTC-Widerstand ist. Ich habe auch eine allgemein übliche Kennlinie im KFZ-Bereich des NTC´s gefunden. Hier wird in der Tabelle der Bereich für die Ansaugluft von -40 bis +80 Celsius angegeben.

Zum Vergleich:

In der Tabelle wird die Umgebungsluft mit einem Messbereich -40 bis +60 Celsius dargestellt, das ich bestätigen kann. Wenn ich nämlich über VAG-COM das Kombiinstrument anspreche, wird am Anfang ein möglich verwertbarer Messbereich von -40 bis +60 für die Aussentemperatur im Kombiinstrument angezeigt.

Ich habe hier mal die Analog- und Digitalwerte einiger Temperaturfühler aus der Klimatronik ausgelesen. Hast du die Möglichkeit nachzuschauen, ob wenigstens diese Digitalwerte mit der Audi Reparaturanleitung übereinstimmen?

Fahrzeughimmel

Kanal 56 Analog 26 Grad

Kanal 02 Digitalwert 122

Schalttafel

Kanal 57 Analog 22 Grad

Kanal 03 Digitalwert 136

Frischluftansaugkanal

Kanal 58 Analog 20 Grad

Kanal 04 Digitalwert 099

Außenfühler

Kanal 59 Analog 17 Grad

Kanal 05 Digitalwert 106

Frischluftgebläse

Kanal 60 Analog 19 Grad

Kanal 07 Digitalwert 101

Übrigens habe ich heute nochmal unter anderen Wetterbedingungen VAG-COM drangehängt:

Außentemperatur 17 Grad (Kombiinstrument) und kein Sonnenschein, somit kein Hitzestau unter der Haube und der Wagen wurde heute noch nicht bewegt.

Ergebnis: eine recht hohe Genauigkeit der Temperaturwerte im Messwerteblock 7,

hab nochmal ein Screenshot drangehängt.

Gruss Goldhuhn

Themenstarteram 22. Juni 2004 um 20:56

hallo goldhuhn,

nach den Kanalnummer zu urteilen hast du die werte direkt aus der Bedieneinheit von der Klimatronic genommen.

Dazu habe ich leide keine Referenzwerte bezüglich der Digitalwerte. ( habe bisher auch vergeblich im Internet danach gesucht , auch Audi gibt diesbezüglich kaum Hilfestellung ).

Das einzigste was ich habe sind die laut Reparaturleitfaden passenden Ohm-Werte und Temperaturwerte. Die müßte man selbst mit dem Voltmeter nachmessen und vergleichen.

Gruß krissi

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Wissen
  4. Fahrzeugtechnik
  5. On-Board-Diagnose
  6. [Audi A6 (4A)] Eine Bitte an Besitzer von Audi C4 2,5 TDI und VAG-COM