ForumOmega & Senator
  1. Startseite
  2. Forum
  3. Auto
  4. Opel
  5. Omega & Senator
  6. Omega B - X20XEV - Problem mit NWS, P0340 / Software Update

Omega B - X20XEV - Problem mit NWS, P0340 / Software Update

Opel Omega B
Themenstarteram 21. März 2012 um 18:46

Hallo zusammen,

 

 

 

Seit einiger Zeit leuchtet die MKL auf ( Fehler NWS P0340 ).

 

 

Wir haben dann ein NWS aus dem Zubehör eingebaut mit neuem Kabelsatz, hat nichts gebracht. 

Omega B 2.0 16V - X20XEV - 10/1996  

Dann wurde ein original GM Sensor verbaut. 

Jetzt leuchtet die MKL nur noch sporadisch.  

Wenn die Leuchte nicht an ist läuft er ganz normal, mit Leuchte zieht er schlecht.  

Man hat mir gesagt, dass ein Software Update eventuell Abhilfe schaffen kann.  

Die erste Version ist anscheinend zu empfindlich bezüglich der MKL .

 

Wer kann mir sagen welche Software Version ich habe (mit OP Com ausgelesen ).

 

Keyword 2027 protocol   

Keyword #1: 6B 

Keyword #2: 8F

Normal timing parameter set.

VIN: W0L000026V1106211

vehicleManufacturerECUHardwareNumber 90491975 NU

systemSupplierECUHardwareNumber: 2516E 

systemSupplierECUSoftwareNumber: 21d21e24e 

systemSupplierECUSoftwareVersionNumber: 0420 

exhaustRegulationOrTypeApprovalNumber: S96001 

systemNameOrEngineType: X20XEV 

RepairShopCodeOrTesterSerialNumber: Not programmed

ProgrammingDate: FFFFFFFF

Identifier: 0206  

CalibrationDate: 565S9020 

CalibrationEquipmentSoftwareNumber: 25900300

Ähnliche Themen
13 Antworten

Wir sind hier größtenteils im Nachtmodus unterwegs.

Das ist für die Augen auf Dauer nicht so belastend.

 

Wer da an der Schrifftfarbe dreht, braucht sich dann aber evtl. auch nicht über mangelnde Reaktionen zu wundern.

Klick doch bitte mal unten auf den Bleistifftstummel und ändere dann die Schriftfarbe noch mal.

 

Umschaltung vom Tag zum Nachmodus ganz unten am Bildrand....;)

 

 

Ziemlich-unleserlich-das-ganze
Themenstarteram 21. März 2012 um 19:11

Okay habe es geändert :)

Zitat:

Original geschrieben von kurtberlin

Wir sind hier größtenteils im Nachtmodus unterwegs.

Das ist für die Augen auf Dauer nicht so belastend.

Wer da an der Schrifftfarbe dreht, braucht sich dann aber evtl. auch nicht über mangelnde Reaktionen zu wundern.

Klick doch bitte mal unten auf den Bleistifftstummel und ändere dann die Schriftfarbe noch mal.

Umschaltung vom Tag zum Nachmodus ganz unten am Bildrand....;)

Hallo!

 

mein Sohnhatte vor ca.3 Wochen den Fall,das Er sollte  bei einem Bekannten den NW-Sensor erneuert hatte(Vectra B-2,0 16V).

der Bekannte hatte den Sensor bei ATP(15 Euro) bestellt,Ergebniß -MKL bleibt an,mit P0340!

Er mich dann angerufen,ich ihm die Spannungswerte gesagt,Er gemessen und später noch einmal zurückgerufen,das die

Spannungen am Sensor da sind!

ich ihm gesagt,schaue doch mal nach dem Zahnriemen,wie er steht!

dann kam der Rückruf später der ZR war total locker,Er ihn richtig nachgestellt,angelassen

und die MKL blieb an,mit dem `neuen`Sensor !

den alten Sensor wieder verbaut und die MKL blieb aus!

Der Bekannte hatte den Vectra erst 2 Wochen.

 

mfg

Na ja, kann man wenigstens lesen.:p

 

Ja, ich gehe mal davon aus daß du hier noch nicht viel reingelesen hast.:rolleyes:

 

Da hättest du den Herren -die sich über deinen Motorkabelsatz hergemacht haben- nämlich fix was auf die Finger gehauen, wenn die deinen intakten Kaberlsatz zerschnibbeln und so für oft viel Ärger in der Zukunft sorgen..

 

Es gibt die genau passenden Nockenwellensensoren nämlich immer noch zu kaufen.!!!!!!!!!!

Da war blos jemand zu faul den richtigen zu besorgen.

 

Klick mal bei mir im Fußtext auf das Thema Nockenwellensensor und lies das PDF dazu.

 

Oft ist der KWS nämlich der Fehlerauslösende und der FC wird nur falsch zugeordnet.

 

Such dir dazu mit Hilfe der Suche mal Infos unter dem Stichwort "Kreuzprobe".

Damit kann man nämlich die wirkliche Ursache genau herausfinden.

 

Das SW Update ist 96/97 eingeführt worden, weil der NWS -durch Schwingungen des Zahnriemens- auch solche Fehler verursacht hat. Gleichzeitig dabei sind noch der Leerlaufregler und Lambdasondenbereich sowie der Luftmassenmesser mit neuen Grenzwerten versehen worden.

Bei der Simtec ab Mj.98 trat der Fehler nicht mehr auf.

 

Ist also auf jeden Fall nicht verkehrt es mal machen zu lassen.

 

Bei ca. 70 -100 Einzelupdates der gesammten Motorenpalette von 94-03 ist es fast unmöglich die neuesten Versionen für die einzelnen Steuergeräte zu kennen und sie via OBD zu erkennen.

Dafür hat der FOH das TECH2 und die neueste Version vom TIS.

Damit kann er es genau kontrollieren und gegebenen Falles updaten.

 

Themenstarteram 21. März 2012 um 21:14

Hallo,

die Zahnriemenspannung wurde kontrolliert.

Trotzdem danke für den Hinweis :)

Grüße

 

Themenstarteram 21. März 2012 um 21:17

Als erstes bedanke ich mich für die ausführliche Antwort.

Habe jetzt mal nachgelesen.

Mache morgen den Kreuztest und berichte dann.

Grüße

 

Ja, bin schon gespannt was du zu Tage förderst.

Themenstarteram 21. März 2012 um 22:17

okay Kurt, ist natürlich bescheuert von mir,war wohl etwas verwirrt

von den Berichten über NWS - KWS, usw... :)

Habe es gelöscht.

Noch eine Frage zum NWS Kabel vom Steuergerät.

Als der Stecker gewechselt wurde habe ich gesehen, dass das Kabel

im inneren (auch 20cm hinter dem Stecker) oxidiert / silbermatt aussah.

Habe schon beim FOH und im Elektrozubehör nach abgeschirmten Kabel

gefragt, aber haben nichts.

Dachte schon daran wenn alles andere nicht hilft, das gesamte Kabel bis

zum Steuergerät zu wechseln.

Macht dass Sinn und wo bekomme ich Kabel?

Macht keinen Sinn.

Wichtig ist nur daß die Impedanz und Schirmung der Leitung vernünftig erhalten und nicht unterbrochen ist.

Die Leitung kannst du ja auch (wie im PDF beschrieben) gekürzt wieder direkt mit dem Originalstecker verbinden.

 

Ohne diesen Mumpitz mit der Adapterleitung.

Hallo zusammen,

habe das gleiche Problem, MKL an Fehler im Stg. Nockenwellensensor.

Diesen habe ich getauscht, neuer Stecker, erst Kabel eingekrimt Fehler noch vorhanden, dann Pins auf Originalen Kabelbaum gekrimpt Fehler immer noch da. KW Sensor abgezogen Motor geht aus kein Fehlereintrag deswegen.

Kann man die Versorgungsspannung am Stecker messen? Wie groß ist die? Kann man das Sensorsignal messen?

Was könnte es noch sein.

Gruß Kawa

Hallo.

Hab bei meinem X20XEV auch das Problem mit MKL und Nockenwellensensor gehabt.Hatte vor einem Jahr einen von ATP bestellt mußte den aber Tauschen weil bei mir ein Siemens drin war wegen dem Stecker,diesen dann eingebaut und Funktioniert einwandfrei.

Tja, bei dem Nockenwellensensor ist halt Markenware die erste Wahl. Siemens, VDO, Hella...

Habe ich auch schon mal Lehrgeld bezahlt... Beim zweiten mal gleich Markenware gekauft und

keine Probleme gehabt. Kabel wegen Steckeranschluss umzubauen ist für mich ein Nogo!

H

Hallo,

ist zwar schon ein Älteres Thema, aber ich habe dasselbe Problem wie Kawa.

Fehler P0340

Vectra B 2.0 16V (Xev)aus 1997

NWS (Hella) getauscht, Fehlercode 2 Sekunden nach Motorstart wieder da. Lässt sich löschen.

Kabel vom NWS gelöst, Fehler P0340 lässt sich nicht löschen. Vermute deshalb das es kein Problem mit dem Kabel gibt. Wurde aber bereits eine Adapterleitung verbaut. Habe diese gelöst und gelötet (vorsichtshalber), keine Verbesserung.

Während des Motorlaufs den KWS gelöst, Motor geht sofort aus, wieder Code P0340, kein weiterer.

Ohne KWS startet er erst garnicht.

Kann mir fast nicht vorstellen das ein neuer Hella Sensor kaputt ist. Zahnriemenspannung ist vorhanden.

Hat jemand evtl eine Idee dazu?

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Auto
  4. Opel
  5. Omega & Senator
  6. Omega B - X20XEV - Problem mit NWS, P0340 / Software Update