ForumOn-Board-Diagnose
  1. Startseite
  2. Forum
  3. Wissen
  4. Fahrzeugtechnik
  5. On-Board-Diagnose
  6. AL319 kann sich nicht mit meinem Peugeot 206 verbinden

AL319 kann sich nicht mit meinem Peugeot 206 verbinden

Themenstarteram 23. September 2017 um 18:47

Hallo,

ich habe gerade mehrfach ersucht einen AL319 mit meinem 2000er Peugeot 206 1.4l TU3JP KFX Magent Magnelli zu verbinden. Nach der Liste auf

http://www.obd-2.de/obd-2-fahrzeugliste.html

sollte das Fahrzeug schon OBD II haben. Buchse hat es natürlich auch. Leider meldet das Gerät nur, dass er sich nicht verbinden kann.

Verkäufer des AL319 habe ich schon angeschrieben, kann mir jemand der Profis hier vielleicht einen Tipp geben.

Viele Grüße,

Jürgen

Ähnliche Themen
12 Antworten

* Kabel prüfen zur Versorgung des Diagnostic Link Connectors

* Spannung auf Pin16?

* Masse auf 4/5?

* Kabel an Pin 7 und 15?

* Sonst irgendwas?

* Zündung angehabt? (Ist wichtig!) Mal im Leerlauf probiert?

Funktion Autolink AL319 prüfen: mit 12V, ggf. an anderem Auto.

Andere Diagnose-Lösung an diesem 206 prüfen.

Dann wieder berichten.

Und hier:

https://www.blafusel.de/obd/obd2_scanned.php

sind etliche 206 von 2000, die auch nicht gingen. Dann müsste man mal in die Tiefe gehen. Motorsteuergerät, Firmware-Version, konkrete Verkabelung in diesem Auto.

TU3JP (KFX) 1360 cm³ 55 kW (75 PS) 1998–2001 - das MUSS also kein OBD2 oder EOBD gewesen sein. Sondern kann auch noch was altes sein. Die Peugeot-Markenwerkstatt sollte das beim Anstecken mit Sicherheit sagen können, wenn die ihre Diagnoselösung richtig im Griff haben.

Sag mal ne Region, Diagnose-Lösungen für OBD2 haben hier ja alle genug.

Themenstarteram 24. September 2017 um 9:43

Hallo,

vielen Dank für die ausführliche Antwort.

* Kabel prüfen zur Versorgung des Diagnostic Link Connectors

* Spannung auf Pin16?

* Masse auf 4/5?

Hieran wird es wohl nicht liegen. Der AL319 wird ja über die Buchse versorgt und das Gerät springt an.

* Kabel an Pin 7 und 15?

Du meinst, dass an der Buchse einfach Kabel fehlen, muss ich man schauen.

* Zündung angehabt? (Ist wichtig!) Mal im Leerlauf probiert?

Ich habe es nur mit Zündung probiert, diese war auch schon lange genug an, dass das Steuergerät initialisiert war. Motor war aus. Das mit dem Motor muss ich noch probieren.

Das mit einem anderen Fahrzeug würde ich auch gerne probieren, alleine mir fehlt ein Testmodel. Ich mache im wesentlichen nur Old- und Youngtimer, der Peugeot ist das modernste meiner 5 Fahrzeuge. Nächstes Wochenende finde ich vielleicht einen ein paar Jahre jüngeren Peugeot.

Der Link

https://www.blafusel.de/obd/obd2_scanned.php

ist sehr interessant. Dort wird in der Tat von einem 206 aus 2001 berichtet, der den gleichen Fehler zeigt. Leider werden dort keine Details angegeben. Der 2001 sollte nämlich ein Boschsystem haben, während ich noch das italienische habe, das aber nach meinen Link bereits OBD II haben sollte.

Ich wohne in Rastatt, wenn also jemand in der Nähe ist.

Viele Grüße,

Jürgen

Na bitte, Versorgungsspannung auf dem DLC ist schon mal da.

Zitat:

Du meinst, dass an der Buchse einfach Kabel fehlen, muss ich man schauen.

Vor OBD2 hat jeder Hersteller die Pins im DLC frei bestückt, es musste ja nur die eigene Diagnoselösung damit klarkommen. Die Hersteller-Diagnose-Lösungen haben über einen Multiplexer einfach alle Pins durchgeprüft, alles außer 4, 5, (beides Masse) und 16 (Batterie-Plus).

Mit OBD2 MUSSTE die K-Leitung zum Motorsteuergerät dann auf Pin 7 sein. Und nur dort schaut der AL319, wenn er auf ISO-9141 testet. Die Lösung kann also so einfach sein, den richtigen Pin rauszubekommen, der zum Motorsteuergerät geht und den in Pin 7 umzupinnen. Es gibt bestimmt auch krasse Adapter für so einen Kleinkram, aber wofür, wenn die Alternative so einfach ist.

Jemand (auch das Werk) kann da den Draht anders aufgepinnt haben, oder eine Nase hat die Leitung zu Pin 7 durchgezwickt. Schaut man hinten an das Pinout im Auto (welches Kabel, welche Farbe auf welcher Pin-Position) und nimmt man mal nen Oszi und schaut auf die Signale, sieht man doch, was da Phase ist.

Oder jemand kann das MSG in deinem Auto mal getauscht haben. Dann hat es ggf. keine OBD2-fähige Firmware oder ist eine andere Sub-Variante.

Rastatt ist leider für mich viel zu weit weg, vielleicht passt es ja für jemand anderen.

Themenstarteram 25. September 2017 um 10:20

Hallo,

die Geschichte mit dem Pin 7 muss ich checken. Nachträglich geändert wurde nichts, ich habe das Fahrzeug neu erworben.

Mittlerweile hat der Verkäufer des AL319 geantwortet er meint das Baujahr 2000 sei eine Grauzone, das Gerät kann, muss aber nicht funktionieren.

Ich kann auch mal mit dem Oszi alle Pins gegen Masse messen.

Einen richtigen Schaltplan habe ich leider auch nicht. Der im Etzold ist definitiv fehlerhaft und leider stehen dort auch keine Kabelfarben sondern nur Kabelnummern, die ich auf den Kabeln aber nicht finde.

Viele Grüße,

Jürgen

206 als Neuwagen - ist schon mal ne gute Grundlage!

Oszi messen: jepp, so wird das gut, wenn man weiß, wonach man sucht! Und dann schau erstmal wo überhaupt was dran ist und wo die hingehen.

Etzold hat immer nur einen Näherungs-General-Schaltplan (für bestimmte Varianten), aber nur selten das echte, wahre im konkreten Auto. Richtige Schaltpläne der Autohersteller haben für ein Modell schnell mal um 2000 Seiten (mit den ganzen Varianten). Ja, zweitausend. Da ist logisch, dass Etzold die Vielfalt gar nicht erfassen kann.

Erfahrung: Den wirklich echten Ist-Schaltplan ermittelt man dann immer erst am Auto. :D Und muss sich den für den gerade interessierenden Teil selbst erstellen.

Die "Kabelnummern" sind keine Kabelnummern, sondern Pin-Nummern in den den Steckern (jeder Stecker hat eine verbindliche Nummerierung der Pins). Manchmal sind die Pin-Nummern winzig klein in den Steckern eingegossen, oft ergeben sie sich logisch, wenn man man das generelle Muster vergleicht.

Themenstarteram 25. September 2017 um 13:17

Zitat:

Die "Kabelnummern" sind keine Kabelnummern, sondern Pin-Nummern in den den Steckern (jeder Stecker hat eine verbindliche Nummerierung der Pins). Manchmal sind die Pin-Nummern winzig klein in den Steckern eingegossen, oft ergeben sie sich logisch, wenn man man das generelle Muster vergleicht.

Hallo,

nein der Plan hat wirklich Kabelnummern, die Pin-Nummer steht auch dabei. Während die Pin-Nummer in dem vernümftigen Bereich ist, gehen die Kabelnummern in die Tausender, sind also 4 stellig. Ist in der Legende von Etzold auch so erklärt. Nur kann ich mit den Nummern wenig anfangen, auf den Kabeln sind nur verschwommene Punkte, deren Codierung ich aber nicht kenne. Viele Kabel haben auch nur Grundfarben, sprich sie sind weiß, gelb etc.

Viele Grüße,

Jürgen

Themenstarteram 26. September 2017 um 12:36

Hallo,

ich komme gerade vom Fahrzeug. Zuerst habe ich den AL319 nochmals bei laufendem Motor probiert. Das alte Bild, es kommt zu keinem Verbindungsaufbau. Danach habe ich mit dem Oszilloskop die Buchse im Fahrzeug bei Zündung vermessen. Wobei ein Oszilloskop eigentlich nicht nötig gewesen wäre, ich habe nur verschiedene DC-Level gefunden.

Im einzelnen habe ich an den Pins der Buchse folgende Spannungen gegen Masse gemessen:

1. +12 V

2. 0

3. +10 V

4. 0

5. 0

6. 0

7. +10 V

8. 0

9. +2 V

10. 0

11. +10 V

12 +8 V

13. 0

14. 0

15. +10 V

16. +12 V

Wie gesagt, Samstag habe ich einen ähnlichen Peugeot da, der aber ein paar Jahre jünger ist. Dort werde ich den AL319 nochmal probieren.

Viele Grüße

Jürgen

Pinout: 7 und 15 sind zumindest mal belegt. Da dürfte das Motorsteuergerät drauf sein.

4+5 sind Masse

16 ist Plus

1, 3, 9, 11, 12 sind weitere Steuergeräte, z.B. Klimaanlage, ABS, Servolenkung, Airbags

ggf. ist auch ein Motordrehzahl mit drauf.

Mit deinem Oszi musst du wohl feiner messen (Zeitauflösung höher), so sieht K-Line aus:

ISO K-line (ISO 9141 and ISO 14230)

http://kevinpt.github.io/ripyl/rst/protocols.html

 

Wenn der AL319 bei dem anderen Fahrzeug klappt, dann hilft dir für den 206 ein iCarsoft i970. Der kann das PSA-Protokoll und kommt sogar auf alle Steuergeräte.

Wenn der AL319 bei dem anderen, jüngeren Fahrzeug auch nicht klappt, naja, dann ist die konkrete Instanz AL319 unter Verdacht, nicht zu funktionieren.

Themenstarteram 28. September 2017 um 10:14

Zitat:

Mit deinem Oszi musst du wohl feiner messen (Zeitauflösung höher), so sieht K-Line aus:

ISO K-line (ISO 9141 and ISO 14230)

http://kevinpt.github.io/ripyl/rst/protocols.html

Hallo,

Vielen Dank für die Hilfe!

Eigentlich hatte ich jeweils die Zeitbasis durchgedreht, kann natürlich sein, dass ich es gerade bei Pin 7 einmal vergessen habe. Das werde ich zur Sicherheit nochmal kontrollieren, ansonsten bin ich auf die Ergebnisse bei dem neueren Peugeot gespannt.

Viele Grüße,

Jürgen

 

 

Themenstarteram 2. Oktober 2017 um 11:37

Hallo,

ich habe das AL319 nun an einem Peugeot 206 Bj 2005 ausprobiert, hier funktioniert es einwandfrei. Es bleibt also festzuhalten, dass die frühen 206 trotz vorhandener Buchse nicht mit jedem Diagnosegerät arbeiten.

Viele Grüße,

Jürgen

Dann sollte das weiter Vorgehen ja klar sein, oder? Es hat noch ein eigenes Protokoll, was da läuft. Eine Lösung dafür habe ich ja schon genannt.

Themenstarteram 2. Oktober 2017 um 20:11

Hallo,

ja, danke für die Hilfe.

Viele Grüße,

Jürgen

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Wissen
  4. Fahrzeugtechnik
  5. On-Board-Diagnose
  6. AL319 kann sich nicht mit meinem Peugeot 206 verbinden