ForumLupo
  1. Startseite
  2. Forum
  3. Auto
  4. Volkswagen
  5. Lupo
  6. "kann Baudrate nicht synchronisieren"

"kann Baudrate nicht synchronisieren"

VW Lupo 6X/6E
Themenstarteram 16. November 2016 um 19:22

Hallo miteinander

Am WE habe ich versucht, den Fehlerspeicher des MSG bei einem 98er Lupo 1,4 auszulesen. Laptop mit VAGCom3.11 und Chinainterface, welches bei vielen VW und Audi Fahrzeugen bisher funktioniert hat.

Ich konnte auch das ABS Steuergerät finden, beim MSG erhielt ich aber nach etwa 30 sek und vielen Versuchen o.g. Fehlermeldung.

Kennt das einer und hat eine Idee dazu?

Der Fehlerspeicher sollte ausgelesen werden, weil das Auto im Autobahnstau manchmal etwas bockt und auch ausgeht.

Danke, Volker

9 Antworten

http://www.motor-talk.de/.../...ate-nicht-synchronisieren-t693182.html

Hallo TE,

gemäß den Lupo-Stromlaufplänen Nr.: 1, ab Sept. 1998, hatte der Lupo, Baujahr 1998, noch keinen CAN-Bus für OBD II - Diagnose. Für die Diagnose wurde ausschließlich die K-Leitung benutzt.

Die K-Leitung ist eine bidirektionale Verbindung, über die Daten vom Tester ans Gerät und zurück geschickt werden. Die L-Leitung ist beim Lupo nicht berücksichtigt, sodass sie hier nicht weiter betrachtet werden muss.

Verbreitete Protokolle für die Diagnose über die K-Leitung sind ISO 9141 und ISO 14230 sowie das von VW herstellerspezifische Protokoll KW1281.

Diagnose-Adapter, welche diese Funktionsweise unterstützen werden als KL-Interfaces bezeichnet. Für ältere Fahrzeuge, wie der Lupo von 1998, die noch nicht über OBD II verfügen, sind diese KL-Adapter zusammen mit der zum Fahrzeug-Protokoll passenden Software KW1281 für die Diagnose notwendig.

Ich weis nicht, welche Protokolle Du mit der Software einstellen kannst und ob das China-Interface den Datenaustausch über die K-Leitung vollziehen kann.

 

Gruß Hans

VAG-COM 3.11 ist schon die richtige Software hierfür (Vorgänger von VCDS). Allerdings gab es in der Vergangenheit Probleme mit so manchem eingachen Kabel.

Manche berichteten, dass Leitungen mit sog. Optokopplern als Bindeglied zwischen PC und Auto nicht arbeiteten, während die konventionellen keine Probleme bereiten.

Die Einstellungen den virtuellen COM Ports passen, die der Ausleser wird gefunden?

Hatte hier seinerzeit Probleme mit gehabt und fast verzweifelt.

cu..Marcus

Hallo Volker,

wenn Du nur Fehlerspeicher auslesen willst, versuche es mal mit der neuesten

Free Edition von Carport.

Evtl. akzeptiert die ja das Interface. Benutzt Du übrigens die RS232 Schnittstelle vom Laptop mit USB-Adapter und FTDI-Treibern oder direkt den USB-Anschluss ?

Da gab es übrigens auch mal Probleme mit gefälschten USB-Adapter-Chips und FTDI-Treibern.

https://www.heise.de/.../...FTDI-ruft-Fake-Killer-zurueck-2435079.html

http://www.golem.de/.../...wieder-bei-chip-nachbauten-1602-118855.html

Hallo TE,

wenn ich den TE richtig verstehe, hat die vorliegende Kombination, Interface und Programm, bzw, Protokoll, ja schon bei vielen Audi- und VW-Fahrzeugen einwandfrei funktioniert.

Dann müsste zwangsläufig das " nicht funktionieren " beim 1998er Lupo, 1,4 L, zu suchen sein. Poste mal bitte die Motor-Kenn-Buchstaben des Motors, möglichst Baujahrangabe mit Monat.

Hast Du immer die gleiche Kombination verwendet ..... oder den PC mal getauscht ? Ich gehe mal davon aus, dass der 1,4 er 1998 keine Can-Bus-Diagnose zulässt .... nur über die K-Leitung ..... und die kann das China-Interface wahrscheinlich nicht erkennen. Bitte das Protokoll KW 1281 beachten.

Gruß Hans

Themenstarteram 18. November 2016 um 12:09

Danke bisher erst mal, ich werde morgen nochmal nach den Protokollen schauen.

Diese Kombination, Interface "Autodia K409" mit Belinea Netbook und VAG Com 3.11 hat bisher funktioniert bei einem Audi A4B5, Bj2000, noch einem A4,zwei Polos und einem VW Bus, die Baujahre der Autos weiss ich nicht mehr, waren auch von Bekannten. Und auch das Lupo ABS Steuergerät wird ja gefunden.

Das interface hat direkt einen USB Anschluss, es wird allerdings ein Com port emuliert

Wie gesagt...die Software ist richtig und spielt alle damals gängigen Protokolle durch (siehst Du beim Verbindungsaufbauversuch oben links).

Ich hatte gefragt, ob die Einstellungen,des COM-Ports zur denen in VAG-Com passen. Thema Baudrate, Handshake und so weiter.

Ferner war die Frage, ob die Leitung Optokoppler verwendet oder TTL-Bausteine. Ersters bringt, wie geschrieben, oft Probleme. Dies ist noch unbrantwortet.

Auch möglich, dass bei einem Einbau eines Fremdradios vergessen wurde die Diagnoseleitung zu trennen. Dies kann ebenfalls zu diesem Problem führen.

cu..Marcus

Themenstarteram 18. November 2016 um 15:26

Die com port Einstellungen hab ich nicht geprüft, mache ich morgen, wenn das Auto wieder da ist. Da aber das ABS Steuergerät gefunden wurde, würde ich da mal von ausgehen, dass das stimmt.

Wie das Interface aufgebaut ist, weiss ich nicht, gibt die Anleitung auch nicht her.

Aber KL sollte gehen.

Autodia 409

Ein Fremdradio ist drin, Blaupunkt.

Hallo Volker,

natürlich ist für eine erschöpfende Betrachtung die Angabe der Motor-Kenn-Buchstaben, das Baujahr mit Monatsangabe und auch die Angabe ob ein "Nicht-VW-Radio" verbaut ist, einfach erforderlich.

Letzteres kann man einfach prüfen:

Bei allen überwachten Steuergeräte im Lupo sind die K-Leitungen parallel geschaltet. So auch die K-Leitung eines VW-Radios. ( Pin 3 des ISO-Steckers schwarz ). Da der Pin 3 des ISO-Steckers bei " Nicht-VW-Radio " mit Spannung oder ähnl. belegt sein kann .... ist vom Radio abhängig, kann es in dem Falle zu Fehlfunktionen der Diagnose im Lupo kommen, muss aber nicht, ist vom verwendeten Nicht-VW-Radio abhängig. Dieses ist aber auch Thema bei den neueren VW- und Audi-Radios sofern sie der Diagnose des Fahrzeuges zu geordnet sind.

Wir haben sicher alle gelesen, dass der TE schreibt, dass die komplette Einheit, Dateninterface, Leitungen und Protokolle, bei vielen Audi und VW-Fahrzeuge einwandfrei funktioniert hat. Leitungen mit Opto-Kopplern gehören unter der Berücksichtig des Vorgenannten wohl seit längerem der Vergangenheit an. Einen TTL-Baustein dürfte das Interface AutoDia K409 nicht besitzen.

 

Sonst hätte dies bei den vielen Audi- und VW-Fahrzeugen nicht funktionieren können.

Gemäß den Lupo-Stromlaufplänen Nr.: 1, ab Sept. 1998, hatte der Lupo, Baujahr 1998, noch keinen CAN-Bus für OBD II - Diagnose. Für die Diagnose wurde ausschließlich die K-Leitung benutzt. Das heißt: Die 16-polige Steckverbindung der Diagnose-Steckbuchse im Lupo 1998 hat nur 3 ( drei ) Anschlüsse

Pin 16 / 4 = Masseverbindung

Pin 16 / 7 = Verbindung K-Diagnose-Leitung

Pin 16 / 16 = + 12 Volt über die Sicherung SB 11, 5 A. Ist diese kontrolliert ?

Verbreitete Protokolle für die Diagnose über die K-Leitung sind ISO 9141 und ISO 14230 sowie das von VW herstellerspezifische Protokoll KW1281. Die K-Leitung, auch K-Diagnoseleitung genannt, liegt an Pin 16/7, Pin 7 des 16 poligen Diagnosesteckers, dort wo Du das Diagnose-Interface anschließt. Nun wäre zu klären ob Dein Diagnose-Gerät diese Leitung auch in der notwendigen Form benutzt.

Die Bezeichnung K-Leitung kennzeichnet eine Diagnose Daten Leitung TXD. Dies bedeutet das der PIN 7 des Diagnose-Steckers, einem genormten Protokoll zu geordnet ist. Dies sind die Protokolle ISO 9141 und ISO 14230 für die K-Leitung.

 

Auch herstellerspezifische Protokolle werden über die K- und L-Leitungen eingesetzt. Hier ist das Protokoll KW1281 ( VAG ), nur für die K-Leitung zu erwähnen. Zu der K-Leitung gibt es noch eine L-Leitung, die aber nicht weiter durch die billigen Interfaces benutzt wird. ( K=slow, L=fast ). Meines Wissen wird die L-Leitung bei VAG nicht benutzt.

Nun kommt aber das wichtigste: Im Internet werden billige Diagnose-Interfaces, mit Anzeigen wie ISO 9141, ISO 14230 oder OBD II angeboten, welche dem Käufer Sand in die Augen streuen und weis machen wollen, dass das Interface diese Protokolle beherrscht. Nichts von alle dem. Bei diesen Interfaces handelt es sich stets nur um Signalumsetzer, die in der Regel keine eigene Protokoll-Logik beinhalten, Diagnose-Adapter, welche diese Funktionsweise ( K-Leitung ) unterstützen werden als KL-Interfaces bezeichnet.

Für ältere Fahrzeuge, wie der Lupo von 1998, die noch nicht über OBD II verfügen, sind diese so genannten KL-Adapter oder KL-Interfaces zusammen mit dem zum Fahrzeug-Protokoll passenden Software-Protokoll KW1281 für die Diagnose notwendig. Suche da mal den Fehler.

Wenn Du weder Interface, noch PC, noch das Programm ( Keine Kopie, wo der Aktivierungscodes erneut eingegeben werden müssen ) verändert hast, müsste nach wenigen Sekunden das Interface und das KW 1281-Protokoll vom Programm erkannt werden.

Poste mal bitte die Motor-Kenn-Buchstaben und Baujahr mit Monat damit kontrolliert werden kann welcher Diagnose-Anschluss bei Deinem Lupo vorliegt. Alles andere ist vorerst Raterei.

Hast Du Unterlagen über das AutoDia K409 ? Bei allen Ausleseversuchen der Speicher war doch die Zündung eingeschaltet ? Sonst bekommt das Interface keine Versorgungsspannung.

Gruß Hans

Nachtrag: Das Interface hat auf der einen Seite den genormten 16-poligen Diagnose-Anschluss und auf der anderen Seite in der Regel einen USB-Stecker. Warum denn dieses ? Weil schon seit Jahren PCs und Laptops über keine serielle COM - Schnittstellen, welche nach außen geführt sind, mehr verfügen. Aus diesem Grunde werden von den Programmen serielle Schnittstellen emuliert.

Es können aber nur COM-Schnittstellen emuliert werden, welche im PC-System vorhanden sind. Das liegt in den Programmen begründet.

Es gibt auch noch die Möglichkeit, dass bei einigen Interface der COM-Port im Programm manuell eingestellt werden muss.

Habe eine Aufstellung gefunden, dass der Diagnose-Adapter AutoDia K409 :

1.) Nur mit der K-Leitung eines CAN-Bus OBDII funktioniert.
2.) Er funktioniert nicht mit der VAG- K-Leitung ....... die des Lupos

3.) Er funktioniert auch nicht mit dem VAG-CAN-Bus

Warum, war dem Beitrag nicht zu entnehmen. Die Interfaces :

AGV 4000 Expert, AGV 4500 und Diamex DXM-1 Expert sowie Scandevil 2 funktionieren mit allen drei

Was sagt die Beschreibung des VAG-COM 3.11 ? Lies mal bitte alles durch.

Deine Antwort
  1. Startseite
  2. Forum
  3. Auto
  4. Volkswagen
  5. Lupo
  6. "kann Baudrate nicht synchronisieren"