ForumSL
  1. Startseite
  2. Forum
  3. Auto
  4. Mercedes
  5. SL
  6. SL55 Lenkradschaltwippen ohne Funktion. (Profifrage)

SL55 Lenkradschaltwippen ohne Funktion. (Profifrage)

Mercedes SL R230
Themenstarteram 9. Febuar 2018 um 17:43

Hallo zusammen,

ich habe letztes Jahr einen SL55 BJ. 08.2003 gekauft.

Leider sind von Anfang an die Lenkradschalttasten ohne Funktion.

Die Stardiagnose zeigt folgenden Fehler:

Klick mich...!!!

Ich habe bereits das Lenkrad und den Lenkwinkelsensor einmal abgebaut und konnte das schalten der Wippen mit der Diodenmessfunktion meines Multimeters an zwei Steckpins des LWS nachmessen.

Meine Frage lautet nun, wohin führen die Signalleitungen. Der LWS wird ja in das Mantelrohrmodul gesteckt. An welchem Modul oder Steuergerät kann man prüfen ob das Signgal ankommt um einen Kabelbruch auszuschließen.

Eventuell hat ja auch jemand eine Idee, wie ich dem Fehler auf die Schliche kommen kann.!?!

Gruß und bis bald

Ralf

Star001
Ähnliche Themen
18 Antworten

Hallo Ralf

Vom MRM geht es in da Wahlhebelmodul

Dort sind die Micro Schalter die von deinem Schalthebel aus betrieben werden

Ich hatte das selbe Problem und Müslüm (ufaklik) konnte mir helfen

Grüße Stefan

Themenstarteram 10. Febuar 2018 um 12:11

Hallo Stefan,

vielen Dank, für die schnelle Antwort. :)

Dies würde ja auch zu der Fehlermeldung passen. Das N15/5 ist ja das Wahlhebelmodul.

Dann wird der Fehler wohl doch nicht von den Wippen, sondern aus der CAN Verbindung zwischen Wahlhebelmodul und dem EGS Steuergerät kommen.

Hoffentlich kann man die Busleitung erkennen wenn man die Mittelkonsole abnimmt.!?!

Dann werde ich jetzt versuchen die CAN Verbindung zwischen den beiden Geräten zu finden und diese durchzumessen.!?!

Gruß und bis bald

Ralf

Du schreibst „Wippen“, Dein Baujahr müsste aber die „SchaltKNÖPFE“ haben. Kann es sein, dass da nicht das Originallenkrad verbaut ist"? Das würde erklären, warum es nicht geht, denn die Lenkräder sind nicht kompatibel.

Themenstarteram 10. Febuar 2018 um 16:43

Nein, es sind noch die originalen 2003er (kleinen) Schaltknöpfe hinten am Lenkrad.

Sorry für die falsche Bezeichnung.

Wenn sie funktionieren wollte ich auf Wippen umrüsten, es soll da eine Plug and Play Lösung geben.?!?

Zitat:

@RalfCE schrieb am 10. Februar 2018 um 12:11:48 Uhr:

 

Dann wird der Fehler wohl doch nicht von den Wippen, sondern aus der CAN Verbindung zwischen Wahlhebelmodul und dem EGS Steuergerät kommen.

Hoffentlich kann man die Busleitung erkennen wenn man die Mittelkonsole abnimmt.!?!

Dann werde ich jetzt versuchen die CAN Verbindung zwischen den beiden Geräten zu finden und diese durchzumessen.!?!

Du solltest erst mal ein bisschen nachlesen wie ein CAN Bus funktioniert.

Themenstarteram 10. Febuar 2018 um 19:24

Ich weiß, das der CAN Bus eine Wissenschaft für sich ist und manchmal selbst Fachleute zur Verzweiflung bringt. Ich maße mir nicht an einen elektronischen defekt in einem Bauteil finden zu können.

Dafür reicht mein Wissen aus der Informationselektroniker Ausbildung, die über 30 Jahre zurück liegt sicher nicht aus. :(

Das Fahrzeug ist zwar aus dem Besitz eines Dr. med. und lückenlos bei MB gewartet, aber als ich neulich mal die Mittelkonsole offen hatte ist mir aufgefallen, das am Comand Befestigungsschrauben fehlten und die Verkabelung für das Kimasteuerteil lag auch etwas "komisch". Daher schließe ich nicht aus, das wohl auch schon einmal ein Dilettant am Werk war. :rolleyes:

Ich hoffe daher auf eine einfache unterbrochene Verbindung. (Kabelbruch gelöster Stecker etc.)

Also etwas, was ich mit den Augen erfassen kann. ;)

Hallo Ralf

Wenn Du wippen nach rüsten möchtest Vorsicht ,bei

den ganz neuen Lenkräder ist das ganz anders verschaltet.

Ich hab mir das neue von Müslüm umrüsten lassen ...

Grüße Stefan

Img-3097
Img-3104

Die Tasten am Lenkrad gehen in die separate 2 Pin Hülse am Schleifring. Die eine ist Masse die andere geht an Pin8 am Wahlhebelmodul. Erst würde ich den Durchgang mal prüfen ob ein Leitungsbruch vorliegt. Wenn kein Durchgang dann erstmal den Fehler am Schleifring suchen.

Über MRM kann man über Ansteuerung die Tasten auch prüfen.

 

Das Plug&Play System für größere Paddeln wird von meiner Wenigkeit angeboten ( Preis 359,- EUR inkl. Paddeln).

 

 

LG

Müslüm

Zitat:

@RalfCE schrieb am 10. Februar 2018 um 19:24:21 Uhr:

Ich weiß, das der CAN Bus eine Wissenschaft für sich ist und manchmal selbst Fachleute zur Verzweiflung bringt. Ich maße mir nicht an einen elektronischen defekt in einem Bauteil finden zu können.

Dafür reicht mein Wissen aus der Informationselektroniker Ausbildung, die über 30 Jahre zurück liegt sicher nicht aus. :(

Das Fahrzeug ist zwar aus dem Besitz eines Dr. med. und lückenlos bei MB gewartet, aber als ich neulich mal die Mittelkonsole offen hatte ist mir aufgefallen, das am Comand Befestigungsschrauben fehlten und die Verkabelung für das Kimasteuerteil lag auch etwas "komisch". Daher schließe ich nicht aus, das wohl auch schon einmal ein Dilettant am Werk war. :rolleyes:

Ich hoffe daher auf eine einfache unterbrochene Verbindung. (Kabelbruch gelöster Stecker etc.)

Also etwas, was ich mit den Augen erfassen kann. ;)

Ich meinte damit, dass der CAN Bus in Stern Architektur angelegt ist. Es gibt keine direkten Leitungen zwischen den Steuergeräten. Die CAN Bus Leitungen laufen alle auf einen zentralen Verteiler.

Wenn diese Leitung unterbrochen ist, dann gehen alle Funktionen nicht mehr welche über das Mantelrohrmodul laufen. Dann würde Dein Auto auch nicht mehr blinken, oder Hupen.

Themenstarteram 11. Febuar 2018 um 14:29

@ Müslüm

vielen Dank, das sind Infos wie ich sie mir erhofft habe. Ich werde jetzt mal Pin 8 am Wahlhebelmodul messen.

Den "Schleifring" hatte ich schon ab (weil es mein erster Verdacht war). Da konnte ich an zwei Pins von dem Langen Stecker, der ins Mantelrohrmodul geht, noch etwas messen.

Wenn ich es zum Laufen bekomme, würde ich mich wegen der größeren Wippen bei Dir melden.

Ich habe schon viel Gutes von Dir und über Dich in diesem Forum gelesen und wenn es keine 500km Weg wären, (ich wohne in Celle bei Hannover) hätte ich mich bestimmt schon bei Dir angemeldet. ;)

@ Stefan

wow... das sieht gut aus!!!:eek:

@ MichaelV12

Danke für die Info!!! Ich hoffe noch, dass es nicht auf einen CAN Fehler hinausläuft.

Obwohl es im Augenblick wohl fast so aussieht. :(

 

Ich melde mich sobald ich Pin am WHM gemessen habe.

Schönen Sonntag an alle, Gruß

Ralf

Themenstarteram 12. Febuar 2018 um 21:13

Ich glaube mein Fehler ist leider doch nicht so einfach zu finden. :rolleyes: :( :mad:

Ich habe zunächst am Stecker des Wahlhebelmoduls gemessen.

Pin 8 ist die Masse und an Pin 4 ist das "Signal" der Schaltwippen zu messen. Es kommt also doch etwas am WHM an.

Ich habe dann in meiner StarDiagnose das Getriebesteuergerät aufgerufen. (EGS)

Zum Bild hier *KLICKEN*

Mir ist dort aufgefallen, dass wenn ich am Lenkrad die Taste Minus (-) drücke, im Menü der Kick-down-Schalter auf "Betätigt" wechselt und beim drücken der Plus (+) Taste wieder auf "Nicht Betätigt".

In den eigentlichen Punkten für die Tasten ändert sich die Anzeige nicht.

Aber scheinbar kommt dann ja beim EGS auch noch etwas an?!? :confused:

Kann es sein, das "nur" etwas falsch Codiert ist...?!?

Das ziehen und stecken des Bus Steckers am WHM hat dabei überhaupt keine Auswirkung, auch auf die (i) Meldung im EGS nicht.

Zum Bild hier *KLICKEN*

Jetzt bin ich komplett Ratlos...?!? :confused:

Komm einfach mal vorbei.. oder ruf mich mal an

Zitat:

@RalfCE schrieb am 12. Februar 2018 um 21:13:03 Uhr:

 

Ich habe dann in meiner StarDiagnose das Getriebesteuergerät aufgerufen. (EGS)

 

Kann es sein, das "nur" etwas falsch Codiert ist...?!?

Wenn Du eine Star Diagnose hast, dann kannst Du die Codierungen doch prüfen.

Nur mal so als Frage am Rande, Du hast nicht selbst an den Codierungen herumgespielt oder etwas nachgerüstet ?

Themenstarteram 13. Febuar 2018 um 8:19

@ MichaelV12

Nein habe ich nicht, vor Codierungen habe ich genug Respekt.

Ohne eine detaillierte Anleitung würde ich da nicht alleine rumexperimentieren.

Die StarDiagnose habe ich mir in den 4Jahren mit meinem 500er zugelegt, der hätte mich sonst allein schon mit den ewigen Löschungen der Fehlerspeichereinträge in die Armut getrieben. :rolleyes:

Du scheinst ja Ahnung zu haben, wie kann ich denn die Codierung prüfen?!?

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Auto
  4. Mercedes
  5. SL
  6. SL55 Lenkradschaltwippen ohne Funktion. (Profifrage)