ForumAstra G & Coupé
  1. Startseite
  2. Forum
  3. Auto
  4. Opel
  5. Astra, Cascada & Kadett
  6. Astra G & Coupé
  7. Prüfen eines Nockenwellensensors X18XE1

Prüfen eines Nockenwellensensors X18XE1

Opel Astra G
Themenstarteram 25. März 2016 um 19:32

Hallo

Phänomen bei unserem neuen Astra G mit X18XE1 Motor. Gelegentlich nach dem Motorstart kommt die Motorkontollleuchte, macht man den Motor wieder aus und startet erneut ist alles iO.

Fehlercode immerzu P0340 und dessen Nebenwirkungen, also Nockenwellensensor.

Was macht das Teil überhaupt, wozu wird es genötigt, sicherlich hat es seine Daseinsberechtigung. Ich habe mich diesbezüglich etwas eingelesen....und mal zum Testen den billigsten bestellt den ich bekommen konnte, ca. 18€

Ich fasse mich kurz:

Das Teil bekommt über das Motorsteuergerät 5V über Pin 2 u. 3. im Testaufbau 5.02V. Liegt das Ding an Spannung führt die Signalleitung Pin 1 gegen Pin 2 (Masse) eine Spannung von 3.76V. Nährt man sich dem eingegossenen Hallsensor mit einem Stück Metall schaltet der Hall IC duch und zieht die Spannung auf 0 V. So entsteht ein auswertbares Rechecksingnal in Abhängigkeit der erhabenen Zahnung der Nockenwelle. Die Stromaufnahme beträgt dabei zwischen 1.8 und 2.2 mA

Also der neue billisch Sensor funktioniert zumindest mal im Versuchsaufbau....der sporadisch Bemängelte im PKW kommt die Tage an den Versuchsaufbau...mal sehen wie der sich verhällt

Gruß Thomas

Durchgeschaltet
Nichtdurchgeschaltet
Beste Antwort im Thema

moin

Zitat-

Allerdings wird immerzu der NWS im Fehlerspeicher abgelegt ??

dazu habe ich eine andere Meinung .

vielleicht sollte man davon ausgehen,das der NWS keinen eigenen Fehler melden kann ,

sondern einen Fehler der unmittelbare Bauteile in seiner Peripherie meldet und das wäre

in erster Linie der KWS der in dem Moment keine Signale liefert oder wo die Signale nicht

übereinstimmen !

es ist Schwierig sich da festzulegen ,welchen Sensor man tauschen soll !

beide Sensoren sollte man bei einem P0335 oder P0340 auswechseln .

der DTC sagt ja nicht viel aus,nur sieht man leider nicht alle Setzbedingungen dafür,

man bekommt nur den P0340 angezeigt,

aber es gibt ja mehr DTC dazu ,die aber das MSTG nicht anzeigt -

P0340 Stromkreis Stellungsgeber 1 Einlassnockenwelle/Unterbrechung

P0341 Stromkreis Stellungsgeber 1 Einlassnockenwelle Bereich/Verhalten

P0342 Stromkreis Stellungsgeber 1 Einlassnockenwelle niedrig

P0343 Stromkreis Stellungsgeber 1 Einlassnockenwelle hoch

P0344 Stromkreis Stellungsgeber 1 Einlassnockenwelle sporadisch

P034A Kurbelwellenstellungsgeber - Startposition Kurbelwelle ist falsch

P034B Kurbelwellenstellungsgeber - Richtung der Kurbelwelle ist falsch

Ausfälle des KWS sind sehr oft durch die lange Betriebsdauer dieses Sensors bedingt.

das Gehäuse des KWS bekommt Mikroriisse ,Öl dringt ein und ist platt oder

der KWS verliert sein Signal durch Wärmeschädigung und der Motor geht aus.

nach einer Abkühlzeit geht Er wieder,bis zur nächsten Erwärmung .

bei Verwendung von EIS - Spray kann man den Motor sofort wieder starten !

eine Lambdasonde hat oft einen sogenannten vorgeschlagenen Wechselintervall ,

ein KWS leider nicht !

ich schätze die Lebensdauer eines KWS auf 150.000 Km oder 10 Jahre .

ich habe nur eine Datei wo es für den 2,2er Motor in Amerika differenziert angegeben wird !

evtl hilft die ja Dir !

mfg

 

116 weitere Antworten
Ähnliche Themen
116 Antworten
Themenstarteram 30. März 2016 um 21:51

Hallo

Hätte jemand von euch eine Fehlercode-Setzbedingung bzw. Fehlerursache zum Nachlesen des Fehlers P0340 der Simtec 70 des X18XE1 ?.

Die Fehlercodeursachen der Simtec 56,56 1 sowie der 56,56 5 können nicht ganz zutreffend sein, das würde so nie funktionieren.

Diese gehen von einem fehlenden Signalwechsel des NWS zwischen dem 1. und 6. Zahn der Inkrementscheibe aus, diese wiederum bedient ja den Kurbelwellensensor. 1. bis 6. Zahn Inkrementscheibe bedeutet 6-36° Kurbelwelle, die Nockenwelle dreht sich dabei nur um 3-18°. im Uhrzeigersinn.

Die beiden Erhöhung des rechten Nockenwellenrades haben allerdings eine 180° Teilung?? Die Hälfte davon würde rechnerisch nur 90° betragen da sich die Nockenwelle ja nur halb so schnell dreht als die Kurbelwelle. Da würde nie ein Signalwechsel stattfinden innerhalb des 1. - 6. Zahn der Kurbelwellescheibe.

Habe ich einen Denkfehler

Gruß Thomas

am 31. März 2016 um 20:48

Also KWS wechseln, oder beide, würde ich so machen!

Themenstarteram 31. März 2016 um 21:29

Hallo

Danke für deine Einschätzung...aber warum den KWS erneuern obwohl nur der NWS als Fehlercode gespeichert wird.

Sollten beide defekt sein würde sich der Motor nicht mehr starten lassen, In welchem Zusammenhang stehen beide Sensoren. Wird der NWS nur benötigt um bei Ausfall des KWS den Motor am laufen zu halten? Das kann sicherlich nicht sein.

Wobei sich die Frage der Notlaufeigenschaften der Simtec 70 anschließt....läuft der Motor weiter bei Ausfall je Sensor, bei beiden ist Schluß mit Motorlauf.

Seltsamerweise wird der Fehler NWS nur beim starten des Motores gesetzt, im laufenden Betrieb scheint der wohl egal zu sein. Fällt der KWS komplett aus müsste/sollte der Motor per NWS weiterlaufen...ist das so?

Wie sind die Zusammenhänge der Motorlogik der Simtec 70,,,,,das würde wahrscheinlich nicht nur mich interessieren

Gruß Thomas

am 31. März 2016 um 22:00

Ich hatte ungefähr das gleiche Phänomen bei dem Corsa C meiner Tochter, der KWS verabschiedet sich schleichend, nicht abrupt, setzt auch anfangs keine Fehlercodes, ist nur eine Vermutung von mir. Den NWS hatte ich nur einmal kurz in der Fehlercode-Liste, der war es aber nicht, sondern der KWS!

Moin

die Notlaufeingenschaften der Simtec bestehen schon.

bei Ausfall von NWS läuft der Motor weiter.

bei Ausfall vom KWS läuft der Motor weiter.

bei nur NWS dauert es etwas länger mit Anspringen ,wie mit dem KWS alleine.

aber riesen Vorsicht ,sind beide Sensoren ausgebaut UND die Batterie abgeklemmt ,

so wird der Motor erst wieder Anspringen wenn beide Sensoren saubere Signale liefern .

das MSTG verliert sein Gedächtniß und muß dieses erst wieder Lernen (Lernwerte) ,

im Bezug auf die Signale .

hat man da einen defekten Sensor dabei,ist es Essig mit Anspringen !

in der Regel zieht man einen Sensor ab und startet den Motor um zu Testen,mit

welchem Sensor ER anspringt und kann beide SEnsoren dabei Testen .

auch eine größere Runde drehen ,schadet nichts,

aber nie die Batterie abklemmen dabei !!!

ich denke bei der Simtec 71 wird mit einem Verlauf von ca 130 Grad der KW gerechnet !

bei mir sind es 20 Zähne von der KW-Sensor Einbaulage bis zum OT.

20 Zähne x 6 =120 Grad bis zum Anfang der Bezugsmarke auf der KW

da ja 2 Zähne fehlen (Bezugsmarke) nimmt man die Hälfte der Bezugsmarke OT der KW .

21Zähne x6 = 126 Grad .

mfg

 

im Gegensatz zu Magnetaufnehmern/Induktivsensoren ,die selber ihre Spannung erzeugen ,

wird der Ausgang eines Halleffekt-Geräts nicht durch die Änderungsgeschwindigkeit des Magnetfeldes beeinflusst.

die vom Hallsensor erzeugte Spannung liegt im Millivoltbereich und wird von der Elektronik im Gerät selbst verstärkt.

die resultierende Ausgangsspannung wird normalerweise von der Versorgungsspannung vorgegeben.

Bei einer Versorgung mit 5 V ist das Ausgangssignal somit 5 V,

bei einer Versorgung mit 12 V ist das Ausgangssignal entsprechend 12 V.

Für jeden vorbeigehenden Zahn wird eine vollständige Schwingung erzeugt !

Themenstarteram 1. April 2016 um 21:37

Hallo

Besten Dank für die Info...

Zitat:

bei nur NWS dauert es etwas länger mit Anspringen ,wie mit dem KWS alleine.

Könnte ich bestätigen, dauert länger, beim starten weis ich schon das die MIL nicht ausgehen wird. Allerdings wird immerzu der NWS im Fehlerspeicher abgelegt ??

Zitat:

aber riesen Vorsicht ,sind beide Sensoren ausgebaut UND die Batterie abgeklemmt ,

so wird der Motor erst wieder Anspringen wenn beide Sensoren saubere Signale liefern .

das MSTG verliert sein Gedächtniß und muß dieses erst wieder Lernen (Lernwerte) ,

im Bezug auf die Signale .

Werden NWS u. KWS als Lernwerte abgelegt, dachte es handelt sich bei den beiden um Festwertgeber. Bei rein analogen Signalen wie Tempfühler, Drosselklappenpodi und LMM würde das zutreffen , beim Rechtecksignal des NWS sicherlich nicht. Beim KWS bin ich mir nicht sicher?

OK...also Finger weg von der Batterie, war schon kurz davor diese abzuklemmen.

Zitat:

ich denke bei der Simtec 71 wird mit einem Verlauf von ca 130 Grad der KW gerechnet !

Die älteren Simtec rechnen mit 114° vor OT, eventuell passt das auch auf die 70 er sowie auf die 71 er.

Hast eventuell noch Info zu den Fehlercode-Setzbedingungen für den NWS, bzw den KWS. Die Ausführungen der älteren Simtec 56 können sicht zutreffen, die Nockenwelle verhindert das

Gruß Thomas

PS. Bild stammt aus den weiten des Internet, rechts Nockenwelle mit 180° Teilung, 180° High (1 oder +5V) und 180° LOW (0 oder 0Volt)

Nockenwellenraeder

moin

Zitat-

Allerdings wird immerzu der NWS im Fehlerspeicher abgelegt ??

dazu habe ich eine andere Meinung .

vielleicht sollte man davon ausgehen,das der NWS keinen eigenen Fehler melden kann ,

sondern einen Fehler der unmittelbare Bauteile in seiner Peripherie meldet und das wäre

in erster Linie der KWS der in dem Moment keine Signale liefert oder wo die Signale nicht

übereinstimmen !

es ist Schwierig sich da festzulegen ,welchen Sensor man tauschen soll !

beide Sensoren sollte man bei einem P0335 oder P0340 auswechseln .

der DTC sagt ja nicht viel aus,nur sieht man leider nicht alle Setzbedingungen dafür,

man bekommt nur den P0340 angezeigt,

aber es gibt ja mehr DTC dazu ,die aber das MSTG nicht anzeigt -

P0340 Stromkreis Stellungsgeber 1 Einlassnockenwelle/Unterbrechung

P0341 Stromkreis Stellungsgeber 1 Einlassnockenwelle Bereich/Verhalten

P0342 Stromkreis Stellungsgeber 1 Einlassnockenwelle niedrig

P0343 Stromkreis Stellungsgeber 1 Einlassnockenwelle hoch

P0344 Stromkreis Stellungsgeber 1 Einlassnockenwelle sporadisch

P034A Kurbelwellenstellungsgeber - Startposition Kurbelwelle ist falsch

P034B Kurbelwellenstellungsgeber - Richtung der Kurbelwelle ist falsch

Ausfälle des KWS sind sehr oft durch die lange Betriebsdauer dieses Sensors bedingt.

das Gehäuse des KWS bekommt Mikroriisse ,Öl dringt ein und ist platt oder

der KWS verliert sein Signal durch Wärmeschädigung und der Motor geht aus.

nach einer Abkühlzeit geht Er wieder,bis zur nächsten Erwärmung .

bei Verwendung von EIS - Spray kann man den Motor sofort wieder starten !

eine Lambdasonde hat oft einen sogenannten vorgeschlagenen Wechselintervall ,

ein KWS leider nicht !

ich schätze die Lebensdauer eines KWS auf 150.000 Km oder 10 Jahre .

ich habe nur eine Datei wo es für den 2,2er Motor in Amerika differenziert angegeben wird !

evtl hilft die ja Dir !

mfg

 

P0355-und-p0340
Themenstarteram 3. April 2016 um 12:46

Hallo

Zitat:

vielleicht sollte man davon ausgehen,das der NWS keinen eigenen Fehler melden kann ,

sondern einen Fehler der unmittelbare Bauteile in seiner Peripherie meldet und das wäre

in erster Linie der KWS der in dem Moment keine Signale liefert oder wo die Signale nicht

übereinstimmen !

Allgemeine Fehlercode,s von Opel, nicht speziell für den X18XE1

Motordrehzahlgeber Fehler..........deutet auf KWS hin, Hmm

Nockenwellen-Positionsgeber Funktionsstörung C-009

Nockenwellen-Positionsgeber Signal zu groß C-009

Nockenwellen-Positionsgeber Signal zu klein C-009

Nockenwellen-Positionsgeber Stromkreis offen C-009

Nockenwellen-Positionsgeber Stromkreis offen C-010Fehlercode

Nockenwellensensor Signal nicht im Sollbereich B-017

Nockenwellensensor Signal nicht im Sollbereich C-009

Signal Nockenwellensensor nicht vorhanden

Nockenwellen-Positions-Sensor Schaltkreis Fehlfunktion

Irgendwie kann der wohl doch eigene Fehler setzen, scheint auf Funktion überwacht zu werden. Bei meinem Fehler stand in Klammer (8), keine Ahnung was das bedeutet. Der erste Fehler in der Liste deutet sogar auf den Motordrehzahlgeber, also den KWS.

Durch Querlesen in diversen Foren bin ich der Meinung der NWS wird nur beim Motorstart benötigt, da wird sich wohl der KWS mit dem NWS synchronisieren. Wenn der Motor läuft scheint der nicht mehr so interessant.

Zu lesen stand auch, was mich in meiner Meinung bestätigt:

.......Ein abrupter Ausfall des Nockenwellensignals im Betrieb (ohne

Wackelkontakt) kann erst beim nächsten Motorstart erkannt werden.......

Ich werde auf eure Empfehlung hin beide erneuern. Den NWS hatte ich vergangenen Sonntag erneuert gegen den Billigheimer Sensor in meiner ersten Beitrag........ging gar nicht. Der Motor sprang unwillig bis nicht an, Fehlzündungen ohne Ende, hörte sich mechanisch defekt an, Schläge, Gerummpel als würde er rückwärts laufen. Und das mit einem neuen Bauteil......verstehe wer will, ich kanns nicht nachvollziehen. Da war ich kurz davor die Batterie abzuklemmen, habe es mir aber verkniffen und den alten Sensor wieder eingebaut.

Gleiches Spiel wie zu Anfang, gelegentlich starten mit Fehlercode, Motor wieder aus machen, Motor erneut starten.....ohne Fehlerlampe??

@rosi

Besten Dank für die Unterlagen, werde ich gleich mal nachsehen

Gruß Thomas

das mit dem `neuen ` NWS konnte ich mir denken,weil Er beim Testen ,

nicht die Eingesteuerten 5 Volt auch wieder Ausgesteuert hatte ,

ergo die Signalamplitude zu klein war !

5V ein zu 3,7 V aus.

eine 8 in Klammern bedeuted Fehlfunktion Datenbus,Signalbus,CAN

eine 17 bedeuted,Spannungswert im Schaltkreis zu hoch

eine 9 in Klammern bedeuted Ausfall Bauteil

jetzt kannst DU auf deine Prüfanweisungen schauen,

auf die letzten Ziffern , C-009

 

mfg

Themenstarteram 3. April 2016 um 15:32

Hallo

Gutes Argument.....

Zitat:

das mit dem `neuen ` NWS konnte ich mir denken,weil Er beim Testen ,

nicht die Eingesteuerten 5 Volt auch wieder Ausgesteuert hatte ,

ergo die Signalamplitude zu klein war !

5V ein zu 3,7 V aus.

Also noch mal den Billig Sensor angeschlossen. Versorgungsspannung 5V.

Spannung an der Diagnoseleitung Pin 1 gegen Masse wie oben im Test 3.7V oder 0V

Spannung an der Diagnoseleitung Pin 1 gegen +5V gemessen...tja, da sind sie nun die fehlenden 1.3V.

Schaltet zwischen 1.3V und 5V (Differenz 3.7V)

Eventuell die eine oder andere Diode/Schutzdiode im Spiel, die Dinger schlucken je 0.7V. Ist nur ein Vermutung, keine Ahnung welcher Hall IC im Sensor verbaut ist. Ein Transistor ebenfalls. Irgendwas muss ja schalten in dem Ding (sehr wahrscheinlich ein Transistor mit Open Collektor)

Ich habe leider keine Vergleichsmöglichkeit den alten Sensor zu messen, zumindest nicht heute. Hat einer der Mitleser Vergleichsdaten oder auch mal einen NWS gemessen.....

Gruß Thomas

Themenstarteram 16. April 2016 um 21:22

Hallo

Wie es ausschaut hat wohl keiner der Mitleser Vergleichsdaten oder je irgendwelche Messungen am Nockenwellensensor durchgeführt......Schade, wirklich Schade :rolleyes:

Da ich wissen wollte wie ein N-Sensor aufgebaut ist, bzw wissen wollte was da eigentlich drinne ist wurde mein billisch Sensor geschlachtet.......nach dem Motto Jugend forscht, also forschen wir mal.

Dauermagnet auf der Rückseite des Hall IC

kleine Platine mit Widerständen, Kondensatoren und einer Diode (diese ist leider beim zerlegen zerbröckelt)

Bei dem Hall IC dürfte es sich um einen MLX90217 handeln (Aussage ohne Gewähr) Dieses Teil hat wie bereits weiter Oben vermutet einen Open Collektor Ausgang.

Ich werde die Tage mal sehen ob ich die Verdrahtung nachvollziehen kann aufgrund der Leiterbahnen der kleiner Platine. Mich interessiert vor allen Dingen wie die Datenleitung des Sensors beschaltet wurde, entweder per Pullup Widerstand durch das MSG oder per Pullup über den Sensorplus intern.......mal sehen. Wenn es intern verschaltet ist wären meine gemessenen 3.75V gar nicht mal so verkehrt..??

Das Steuergerät sollte sich auch mit 3.75V als High Pegel zufrieden geben, kein Mensch weis ja ob wirklich nur 5V als High anerkannt werden.

Spezifikation eines CMOS Eingangs lauten:

CMOS 5V < 1,5V Low bzw > 3,5V HIGH

Gruß Thomas

Camsensor
Mlx90217-circuits

Moin

solche Sachen überfordern mein altes Gehirn ,Grins !

das ist für mich Interessant aber wie schon gesagt,ist es meist immer so

das beide Sensoren NW und KW gewechselt werden,

damit man von der Seite wieder Ruhe hat !

wie man einen KW-Sensor prüfen kann hatte mich mal Interessiert,

da es ja Motorsteuerungen wie z.b. die Motronic gibt ,

die nur das KW-Sensorsignal zum Motorlauf verarbeitet ,

aber auch einen NW-Sensor haben für den Zünd-OT erster Zylinder.

bei diesen Motorsteuerungen gibt es keinen Motorlauf mehr,

wenn der KW-Sensor platt ist !

mfg

http://www.motor-talk.de/.../...sensor-selber-testen-t4884062.html?...

Themenstarteram 18. April 2016 um 20:24

Hallo

Das man immer beide zusammen wechseln soll habe ich nicht vergessen.... :)

Netten Beitrag hast das verlinkt, KWS per Drehbank testen, sehr schön umgesetzt. Eventuell eine Anregung zu meiner Frage in diesem Beitrag:

http://www.motor-talk.de/forum/agr-ansteuern-und-testen-t5626425.html

Zum eigentlichem Thema, dem Nockenwellensensor und seine Eigenarten der geringen Spannung von nur 3.7x V auf seiner Datenleitung.

Wer misst misst bekanntlich Mist.....oder auch nicht. Wer seine als gebröselt angedachte Diode in den Resten der Vergussmasse des Sensors heile wiederfindet der freut sich. Die klebte da noch drinne u. hatte sich nur von der Platine gelöst.

Es schaut folgendermaßen aus, im Spannungseingang liegt R1 mit 680 Ohm in Reihe mit der Diode. nach R1 wird R2 mit 5700 Ohm als Pullup Widerstand auf den offenen Collector geschaltet, soweit so gut.

Da nun etwas Strom fließen muss bewirkt dieser auch einen Spannungsabfall an den beiden R1 und R2, das bleibt leider nicht aus.

Lege ich 5V zugrunde fallen an R1 ca. 0.53V, an R2 4,44V ab...wir kommen der Sache schön Näher :cool:

Die Diode hat eine gemessene Flussspannung/Schwellenspannung von fetten 0.7V

4,44 minus 0.7 = meine gemessenen 3.7 irgendwas V

Ich behaupte mal das ,zumindest der Sensor des X18XE1, nur 3,7xV zum Motorsteuergerät leitet/leiten kann zum auswerten. Oszitest am verbauten Teil steht noch aus.

Angaben selbstverständlich ohne Gewähr und erheben keinen Anspruch auf Vollständigkeit

Gruß Thomas

 

 

 

ich würde mal denken ,

der NW-Sensor gibt seine Signalspannung erst nach der höchsten Spannungsamplitude ab und

die Spannungsamplitude wird über den 3,7 V liegen .

die interne Elektronik wird ja den `Hall` verstärken ,anhand des Magnetfeldes .

auch die Stärke des Magnetfeldes wird eine Rolle spielen,

nicht für die Signalspannung,aber für die Höhe der Amplitude.

einen Opel Ecotec sieht man hier gut,den Hall NW-Sensor ,Bild 1.4 und 1.5 -

http://www.interworldna.com/pico/automotive/trigger_signals_part_3.htm

 

mfg

Deine Antwort
Ähnliche Themen