Forum A4 B6 & B7
  1. Startseite
  2. Forum
  3. Auto
  4. Audi
  5. A4
  6. A4 B6 & B7
  7. 2.5 TDI (BDH) springt an und geht direkt wieder aus

2.5 TDI (BDH) springt an und geht direkt wieder aus

Audi A4 B6/8E

Hallo erstmal an alle Leser,

Ich habe mir vor gut anderthalb Jahren einen Unfall 8E5 gekauft, um ihn zu schlachten und den Motor in meinen T3 zu verpflanzen. Da das alles sehr kostenintensiv ist und es erstmal schnell gehen sollte wurde der Audi, leider ohne Motorhaube, ins Freie gestellt und nun sollte es vor etwa 3 Wochen losgehen. Motor zum laufen bringen, schlachten, verpflanzen.

Stehe zur Zeit bei Schritt eins: Er will nicht laufen.

Zu Anfang wurden neue Hydros eingebaut, da zwei schlepphebel weggefallen sind.

Dann die Drei Relais unterm Steuergerät erneuert, da gammelig aufgrund von Wassereintrag.

Motorsteuergerät hat nichts abbekommen, da es in der Trockenen Halle lag.

Pumpe und Hochdruckleitungen sind soweit entlüftet, er startet ja auch, nur geht er nach ner guten Sekunde aus.

Daraufhin habe ich das Motorsteuergerät weggeschickt, um die Wegfahrsperre rauszuprogrammieren. Nicht nur deaktivieren, sondern komplett rausnehmen lassen. Nun sagt VCDS auch nicht mehr, dass die Wegfahrsperre aktiv ist und auch nicht mehr, dass das Motorsteuergerät gesperrt ist. Zumindest solange ich das Kombiinstrument nicht anschließe. Schließe ich es an, ist es auch gesperrt.

Nun zu meinen Fragen:

- Braucht das Motorsteuergerät die Verbindung zum KI, um den Motor laufen zu lassen?

- Gibt es noch andere Fehler, die solch ein Symptom zeigen?

Im Vorraus Danke für die Hilfe

Ähnliche Themen
12 Antworten

So viel ich weiss, sind das Motosteuergerät, die Einspritzpumpe und das Kombiinstrument miteinander verheiratet.

Das sie miteinander verheiratet sind und mir das reine deaktivieren nichts bringt habe ich bereits herausgefunden. Jedoch will ich das KI nicht in den T3 übernehmen, weswegen ich bereits die Wegfahrsperre rausprogrammieren lassen habe. Oder bist du der Meinung, dass es mir nichts gebracht hat, die Wegfahrsperre aus dem MSG rauszunehmen, da weiterhin die Paarbildung zwischen MSG und KI stimmen muss?

Das deaktivieren bringt Dir gar nichts, ganz im Gegenteil. Du musst am besten den Motor mit Einspritzpumpe einbauen, dann ist das schon einmal aufeinander abgestimmt. Dann musst Du mit Deinem KI zum freundlichen, der kann das machen. Meiner nimmt 50€ ohne Rechnung in die Kaffeekasse. Oder Du wendest Dich an die Spezialisten hier, da können das auch manche. Aber um die 50€ werden die dann wohl auch nehmen. Sollte es Dir auch Wert sein.

Ich könnte hier mal @a4Mike verlinken, der weiß und kann das mit ziemlicher Sicherheit.

Das Kombiinstrument ist der Gateway und für die gesamte Kommunikation im Auto zuständig.

Die WFS im Msg kann nur aktiviert/deaktivert nicht aber komplett rausprogrammiert werden. Da hat dir jemand einen Schwachsinn verkauft.

Und warum genau sollte man die Wegfahrsperre nicht ausprogrammieren können?

Meines Erachtens wird der Transponder vom Schlüssel über die Lesespule ausgelesen. Dieser Code dann durch das KI ausgewertet, stimmt der Code nicht, gibt das KI über den Can-Bus eine Nachricht an das Motorsteuergerät, welches dann wiederrum über den Motor-Can ein Signal an die Dieselpumpe gibt. Und die regelt dann das Mengenstellwerk auf Nullförderung.

Sag ich dem Motor nun aber, dass ihm egal sein kann, was das KI von sich gibt, gibt der auch keine Nachricht an die Dieselpumpe, dass diese den wieder Motor abstellen soll.

Ist dementsprechend also keine Hardware, da es über den Can läuft, sondern Software. Diese ist irgendwann mal programmiert worden und kann dementsprechend auch wieder geändert werden. Natürlich nicht über VCDS, das weiß ich selber und dass mir dabei keine Vertragswerkstatt helfen kann, ist mir bewusst. Denn das, was die können, kann ich selber.

Oder liege ich jetzt komplett falsch?

Jein. Prinzipiell bist du aber schon auf dem richtigen Weg.

Zuerst wir die ID vom Transponder mit der hinterlegten Transponder-ID im Kombiinstrument abgeglichen. Wenn hier das OK kommt, stimmt sich das Kombiinstrument mit SKC (Login) und CS (Komponentschutz) mit dem Motorsteuergerät ab. Wenn hier auch das OK kommt, gibt die WFS die Startanforderung frei und dein Wagen startet.

Diese beiden Checks finden aber immer statt. Du hast die Möglichkeit die WFS auf OFF (deaktiviert) zu stellen. Dann wird die Startanforderung immer freigegeben oder eben auf ON (aktiviert) dann werden die beiden Checks plausibilisiert.

Die WFS aber komplett "raus zu programmieren" geht, aus den oben genannten Gründen, nicht.

Ich bin eurem Rat gefolgt und habe mir schalttafeleinsatz, Schlüssel mit Lenksäule und lesespule und Motorsteuergerät von einem zweiten 8e bdh besorgt. Eingebaut (angeklemmt) und in die Messwerteblöcke geguckt:

Da hat er mir gesagt, dass der Schlüssel nicht angelernt wäre. Also habe ich den Logincode ausgelesen und versucht den Schlüssel anzulernen. Ohne Erfolg neuen Schlüssel besorgt, kann ich auch nicht anlernen. Dann habe ich es mit dem alten Lenlschloss versucht. Also den Bart des Schlüssel für die Lenksäule in den Schlüssel mit dem Transponder für das neue MSG und KI gebaut und siehe da er erkennt den Schlüssel. Also noch mal fix Fehlerspeicher vom MSG ausgelesen und gelöscht und natürlich neu ausgelesen. Und er schreibt mir wieder "Motorsteuergerät gesperrt".

Und nun sagt mir bitte, wo mein Fehler liegt. Ich bin solangsam mit meinem Latein am Ende. Der Fehler bleibt übrigens der gleiche Startet und geht direkt wieder aus.

Nachtrag:

Laut Messwertblöcke 22,23

Ist alles i.O. außer Startvorgang erlaubt (logisch)

Und WFS-Status, da habe ich ne 4 statt ner 6, laut meiner Internetrecherche also KI nicht angelernt, was eigentlich gar nicht sein kann, da immoid von msg und KI die gleiche ist.

Ab in den Status 6 und gut ist ;-)

Wenn es so einfach wäre, Hätte ich es längst gemacht.

Schreib mir eine PN. Ich kann das fixen!

Deine Antwort
Ähnliche Themen
  1. Startseite
  2. Forum
  3. Auto
  4. Audi
  5. A4
  6. A4 B6 & B7
  7. 2.5 TDI (BDH) springt an und geht direkt wieder aus